Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.97/186: Рейтинг темы: голосов - 186, средняя оценка - 4.97
22 / 22 / 2
Регистрация: 17.06.2008
Сообщений: 613
1

Как работать с Переключателями?

23.06.2011, 16:08. Просмотров 34944. Ответов 10
Метки нет (Все метки)

Здравствуйте!

1с - Версия 8.1

1. Положила на форму рамку группы.
2. В неё поместила два переключателя: Переключатель1 и Переключатель2
3. Переключатель1 сделала первым в группе, Тип значения - Число
4. Форма-Настройка порядка обхода - проверила, Переключатели идут один за другим.
5. Выбираемое значение для первого сделала 0, для второго 1
6. Код по нажатию кнопки "Посчитать Сумму"

Процедура ПосчитатьСуммуНажатие(Элемент)
Если ЭлементыФормы.Переключатель1.ВыбираемоеЗначение=0 Тогда
бла-бла-бла...
КонецЕсли;
КонецПроцедуры

Но Выбираемое Значение для Переключателя1 - ВСЕГДА НОЛЬ!!!
Никак не пойму, как сделать, если пользователь выбрал второй переключатель.
Помогите, пожалуйста!
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
23.06.2011, 16:08
Ответы с готовыми решениями:

Помогите с переключателями
Как сделать так, чтобы в таблицу из формы вводилось не число 1,2,3..., соответствующее нажатому...

Список с переключателями
Создал список с переключателями в виде когда щелкаешь на элемент списка, то правее появляется...

Проблемы с переключателями
Добрый день. Даны две формы. Обе - обычные разделенные. На одной форме есть поле со списком. На...

Работа с переключателями
Ситуация такая: есть два переключателя, предположим А и В, и два окна диалога С и D. Если мы...

10
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
23.06.2011, 16:16 2
Значение по умолчанию переключателя.
0
22 / 22 / 2
Регистрация: 17.06.2008
Сообщений: 613
23.06.2011, 16:20  [ТС] 3
fimbulwinter, извините, я только начинаю работать с 1с, может не понимаю чего, но по указанной ссылке нет ответа на МОЙ вопрос. Там разбираются с НАЗВАНИЯМИ переключателей. С ними все в порядке у меня. У меня вопрос как построить код, если пользователь выбрал Переключатель2.
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
23.06.2011, 16:27 4
зачем тебе через ЭлементыФормы?
используй напрямую
Код
Если Переключатель1 = 0 Тогда
...
КонецЕсли;
1
22 / 22 / 2
Регистрация: 17.06.2008
Сообщений: 613
23.06.2011, 16:33  [ТС] 5
fimbulwinter, фу ты блин, как всё просто Спасибо, получилось)

А почему такая разница? Вроде смысл тот же...
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
23.06.2011, 16:40 6
хех...
не уж, разница есть и многие начинающие программмеры не могут её понят.
ЭлементыФормы.<ИмяЭлемента> Это всего лишь объект формы, который обладает рядом свойств. Даблклик по элементу, увидишь все те свойства, которые есть у объекта. Как то: Имя, заголовок, доступность, видимость и т.д. Этими свойствами ты можешь управлять через элементы формы.
Реквизит формы есть объект, в котором непосредственно хранятся данные. Элемент формы связан с ревизитом формы и является всего лишь его графическим отображением.
Надеюсь доступно объяснил.
0
22 / 22 / 2
Регистрация: 17.06.2008
Сообщений: 613
23.06.2011, 16:47  [ТС] 7
т.е. Переключатель1 - это реквизит, имеющий значение 0
а ЭлементыФормы.Переключатель1.ВыбираемоеЗначение - это уже элемент я лезу в свойства объекта Переключатель1
так?
0
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
23.06.2011, 17:06 8
Переключатель (RadioButton)
ВыбираемоеЗначение (SelectionValue)
Использование:
Чтение и запись.
Описание:
Тип: Совпадает с описанием типа первого в группе переключателя. Определяет значение, которое будет присвоено связанному с группой переключателей переменной при выборе данного переключателя.
Недоступно на сервере 1С:Предприятие. Не используется в модуле внешнего соединения.

т.е при создании группы переключателей ты определила значения этих переключателей
Первый = 0, Второй = 1
метод ВыбираемоеЗначение может как считывать так и устанавливать значение Переключатель1 при его выборе. Т.е. например если ЭлементыФормы.Переключатель1.ВыбираемоеЗначение = 3 и ЭлементыФормы.Переключатель1.ВыбираемоеЗначение = 10, тогда при выборе первого в группе переключателя Переключатель1 будет равен 3, при выборе второго в группе переключателя Переключатель1 будет равен 10. Фактически эти значения ты задала программно. Зачем это нужно? для динамического (или программного, как угодно) добавления реквизитов на форму и определения его первоначальных параметров.
0
22 / 22 / 2
Регистрация: 17.06.2008
Сообщений: 613
23.06.2011, 19:42  [ТС] 9
Спасибо

Добавлено через 2 часа 34 минуты
Ну, прелестно теперь не получается обратиться к ВыбираемомуЗначению переключателей из МОДУЛЯ ОБЪЕКТА в Процедуре ОбработкаПроведения(Отказ, Режим).

Подскажите, как это сделать?
0
Модератор
Эксперт 1С
2847 / 2584 / 464
Регистрация: 10.03.2011
Сообщений: 9,556
Записей в блоге: 1
23.06.2011, 22:17 10
Сделай реквизит например переключатель1 и используй его в Модуле Объекта
1
22 / 22 / 2
Регистрация: 17.06.2008
Сообщений: 613
23.06.2011, 22:46  [ТС] 11
Dethmontt, а где именно нужно сделать реквизит?

Добавлено через 27 минут
ААА! Всё, дошло! Я не тормаз, спасибо)
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
23.06.2011, 22:46

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Работа с переключателями (TRadioButton)
Используя 2 зависимых переключателя, решить: В зависимости от выбора, возрастающая или убывающая...

работа с переключателями/флажками
требуется функция, которая будет анализировать некоторое поле из запроса(текстовое) и в...

Форма с переключателями со значениями из БД
Доброе время суток. У меня в базе данных есть в таблице столбец со значениями, которые являются...

Повторяющийся блок с переключателями
Здравствуйте! есть блок с 2 кнопками и li. При нажатии первой кнопки показывает только четные li,...

Работа с переключателями бд Предприятие
Задание: Отобразить на основе группы переключателей значения поля Семейное положение. БД прилагаю

Программа демонстрации работы с переключателями
Пишу программу, которая, демонстрирует работу с переключателями. Отобразить все знаки зодиака. При...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.