Заблокирован
1
1C 8.x

Кто нибудь делал перенос сотрудников из .dbf в 1с?

31.08.2011, 13:13. Показов 1868. Ответов 4
Метки нет (Все метки)

Author24 — интернет-сервис помощи студентам
написал код но понять не могу как с полом определиться
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
31.08.2011, 13:13
Ответы с готовыми решениями:

Кто-нибудь делал чат?
У меня возникло две проблемы. 1. Не мгоу отправить курсор после отправки сообщения обратно в поле...

А делал ли кто-нибудь частотомер на MSP430?
Если кто-нибудь делал, поделитесь исходным кодом.

Кто нибудь делал интеграцию с ФЭР 2?
Добрый день! Скажите, кто нибудь занимался интеграцией с федеральной электронной регистратурой 2...

Кто-нибудь делал базу на Fox'e?
FoxPro - хитрая штука. Если из Delphi удалять записи из таблицы, то фокс просто помечает их на...

4
34 / 34 / 3
Регистрация: 31.03.2011
Сообщений: 197
31.08.2011, 17:01 2
А поподробнее в чем проблема?
А то пока что кроме низкопробных шуток про смену пола никаких мыслей.
2
Заблокирован
01.09.2011, 07:31  [ТС] 3
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
     Для Каждого Стр из ФизическиеЛица цикл
        Спр = ФизическиеЛица.Получить(ФизическиеЛица.Индекс(Стр));
        Сообщить(Спр.Наименование);
        Сообщить(Спр.ИНН);
        ТСпр = Справочники.ФизическиеЛица;
        ТекЭлем = ТСпр.СоздатьЭлемент();
        ТекЭлем.Наименование  = Спр.Наименование;
        ТекЭлем.ИНН = Спр.ИНН;
         
        
          ТекЭлем.Записать();
          Сообщить("Элемент записан");
     КонецЦикла;                        
КонецПроцедуры
 
Процедура ИмяФайлаНачалоВыбора(Элемент, СтандартнаяОбработка)
    // Вставить содержимое обработчика.
    Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    Фильтр = "Таблицы баз данных *.dbf (*.dbf)|*.dbf";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите таблицу базы данных *.dbf";
    
    Если ДиалогОткрытияФайла.Выбрать() Тогда
        ИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;
    КонецЕсли;
КонецПроцедуры
 
Процедура ОсновныеДействияФормыЗаполнить(Кнопка)
Если ПустаяСтрока(ИмяФайла) = Ложь тогда
        Путь =  ИмяФайла;
        База= Новый XBase;
        База.Кодировка = КодировкаXBase.ANSI;
        //Открываем файл для чтения
        
        База.ОткрытьФайл(ИмяФайла,,Истина);
        Если База.Открыта() = Истина тогда        // проверяем открыта ли база
            Сообщить("База отрыта!");           // выводим сообщение в слечае если база открыта
        КонецЕсли;
        
        
        База.Первая();                            // позиционируем на первой записи открытой базы
        //Цикл по записям DBF файла
        Пока НЕ База.ВКонце() Цикл   
            Стр = ФизическиеЛица.Добавить();
            Стр.Группа = Ложь;
            Стр.Код = База.tabn;      
            Стр.Наименование = СокрЛП(База.fio);
    //      Стр.ГоловнойКонтрагент = "";
            Стр.ДатаРождения = База.datrojden;
            Стр.ИНН = СокрЛП(База.inn);
            Стр.СтраховойНомерПФР = СокрЛП(База.pens_strah);
             Если СокрЛП(База.Pol)="Мужской" Тогда  Стр.Пол = Перечисления.ПолФизическихЛиц.Мужской ;
             ИначеЕсли СокрЛП(База.Pol)="Женский" Тогда Стр.Пол = Перечисления.ПолФизическихЛиц.Женский ;
           //  Иначе
             КонецЕсли ;
            Стр.МестоРождения = СокрЛП(База.me_rozd);
            
            База.Следующая();                    // переходим к следуей записи
        КонецЦикла;
        База.ЗакрытьФайл();                        // закрываем файл базы данных
        Сообщить("База закрыта!");
    иначе 
        ОчиститьСообщения();
        Сообщить("Не выбран файл источник");
        Возврат;
    КонецЕсли;
КонецПроцедуры
вот так вроде что то кидает но не хочет кидать пол,пенсномер и дату рождения почему то
0
Модератор
Эксперт 1С
3787 / 2966 / 590
Регистрация: 10.03.2011
Сообщений: 11,671
Записей в блоге: 1
01.09.2011, 23:30 4
Куда не кидает то? Давай по подробнее
0
Заблокирован
02.09.2011, 07:33  [ТС] 5
Цитата Сообщение от Dethmontt Посмотреть сообщение
Куда не кидает то? Давай по подробнее
В 1с физические лица это он фамилию берет и инн тока

Добавлено через 12 минут
я тебе в аське ссобщение кинул ты молчишь!
0
02.09.2011, 07:33
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
02.09.2011, 07:33
Помогаю со студенческими работами здесь

Кто-нибудь делал бухгалтерию на Excel?
Здесь решил полазить по интернету, посмотреть: есть ли бухгалтерские программы на Эксель. Нашел...

PoE, самопальная реализация - кто-нибудь делал?
Народ, подскажите, делал кто-нибудь проекты с питанием от Ethernet? Есть некоторые задумки и, пока...

Кто-нибудь делал свой форум под Лотус?
Дело вот в чем. Мне, да и моим коллегам сисадминам не нравится дизайн стандартного форума, идущего...

Кто нибудь делал функции (например, поиск) с хешированием?
подскажите кто нибудь делал функции с хешированием? поиск допустим? если да то киньте ссылку плиз...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2024, CyberForum.ru