Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/7: Рейтинг темы: голосов - 7, средняя оценка - 4.71
OGur4ik
1 / 1 / 0
Регистрация: 06.07.2010
Сообщений: 147
1

Несовместимость типов 1С8.2

11.04.2012, 15:50. Просмотров 1426. Ответов 2
Метки нет (Все метки)

Всем доброго времени суток!
Возник вопрос. Поставлена задача: есть регистр Регистр1, кот-й содержит колонку Колонка1 типа "СсылкаПеречислениеПеречисление1". Надо сравнить все значения в колонке со значением поля Поле1 на форме.

Делаю так:
1C
1
2
3
4
5
6
7
8
9
10
Знач = ЭтаФорма.Элементы.Поле1.ТекстРедактирования; //это в отдельной процедуре на клиенте
 
//в другой процедуре на сервере, куда я передаю Знач в качестве параметра:
Выборка = РегистрыСведений.Регистр1.Выбрать();
Пока Выборка.Следующий() Цикл 
    
    Если (Выборка.Колонка1= Знач) тогда
                   //............................................
            КонецЕсли;
КонецЦикла;

Ну и, конечно, сравнение всегда дает ложь. Думаю, Колонка1 рассматривается как ссылка, а Знач - как строка. Но что с этим делать, какие свойства использовать, никак не могу сообразить. Помогите, пожалуйста! Заранее очень благодарна!

Добавлено через 1 час 10 минут
Тьфу ты господи... даже через "выразить" пыталась, а ведь все просто))) в общем, сама себе отвечаю:
Если (СТРОКА(Выборка.Колонка1)= Знач) тогда
- ну и т.д.
Даже не думала, что так просто.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.04.2012, 15:50
Ответы с готовыми решениями:

Несовместимость типов
День добрый. Прошу помощи, procedure TForm4.BitBtn3Click(Sender: TObject); begin...

несовместимость типов
помогите разобраться, передаю в функцию update_table массив указателей на фигуры, для каждой из...

Несовместимость типов
В справке по BASS.DLL есть пример который выглядит так: FILE *file; ... // the recording...

Несовместимость типов
Всем доброго времени! Написал вот такую вот функцию (только начало): function...

2
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
11.04.2012, 16:05 2
невредно ещё в регистре начать различать колонки-измерения и колонки-ресурсы

Добавлено через 3 минуты
Из классики:
1C
1
2
3
4
5
6
7
8
9
Курсы = РегистрыСведений.КурсыВалют;
ОтборВалют = Новый Структура("Валюта");
ОтборВалют.Валюта = ВыбВалюта; 
ВыборкаКурсовВалют = Курсы.Выбрать(,,ОтборВалют);
Пока ВыборкаКурсовВалют.Следующий() Цикл
    Сообщить("Дата " + ВыборкаКурсовВалют.Период + 
    " Валюта "+СокрЛП(ВыборкаКурсовВалют.Валюта) +
    ", Курс "+  ВыборкаКурсовВалют.Курс );
КонецЦикла;
1
OGur4ik
1 / 1 / 0
Регистрация: 06.07.2010
Сообщений: 147
24.04.2012, 10:38  [ТС] 3
duk337, спасибо!
0
24.04.2012, 10:38
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.04.2012, 10:38

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Несовместимость типов
Где тут может быть несовместимоcть типов? mas: array of string; plus: array of string; ...

Несовместимость типов
var m,n,k:real; begin write('Введите M: '); readln(m); write('Введите N :'); readln(n); if...

Несовместимость типов
Созданы следующие типы: type TEvent = record Title: string; DateTimeEv: TDateTime; ...

Несовместимость типов
Всем привет, помогите разобраться в ошибке. Нижеприведенный код работает в ADOTable.Filter а в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.