Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.77/13: Рейтинг темы: голосов - 13, средняя оценка - 4.77
Pascal +
133 / 132 / 127
Регистрация: 16.03.2011
Сообщений: 461
1

Добавление в справочник через документ?

06.05.2012, 15:44. Просмотров 2675. Ответов 7
Метки нет (Все метки)

Добрый день!
Вопрос - создаю документ "зачисление в колледж". Возможно ли такое, чтобы записи, внесенные в документ при проведении документа, попадали в справочник?
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.05.2012, 15:44
Ответы с готовыми решениями:

документ и справочник
Здравствуйте, не так давно занимаюсь программированием в 1с предприятие v8, столкнулась с...

Документ и справочник
Привет всем помогите вообщем есть справочник Маршрут - имеет реквизиты наименование(100) код(5) и...

Документ-Справочник
Здравствуйте, подскажите пожалуйста как при добавлении элемента в документ добавить его в...

От Новичка: Табличный документ или справочник ?
Дано: Некая таблица в которой примерно 500 тыс. ячеек со значениями. Вопрос: Распихать все...

7
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
06.05.2012, 16:35 2
да. Док = Спрвочник.НайтиПоКоду("").Полу читьОбъект(); Док.Реквизит = ""; Это делаешь при записи в процедуре.
0
Pascal +
133 / 132 / 127
Регистрация: 16.03.2011
Сообщений: 461
06.05.2012, 17:28  [ТС] 3
Цитата Сообщение от wade25 Посмотреть сообщение
Спрвочник.НайтиПоКоду("")
А вы не могли бы этот момент подробнее объяснить?
0
Pascal +
133 / 132 / 127
Регистрация: 16.03.2011
Сообщений: 461
06.05.2012, 17:35  [ТС] 4
Допустим я фамилию вношу в документе
0
Миниатюры
Добавление в справочник через документ?  
Модератор
Эксперт 1С
2804 / 2550 / 455
Регистрация: 10.03.2011
Сообщений: 9,396
Записей в блоге: 1
Завершенные тесты: 1
06.05.2012, 17:54 5
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
&НаКлиенте 
Процедура ЧегоТоПриИзменении(Елемент)
    ЗначениеПеременной = "Петров";
    ЗапихнутьВРеквизитСправочникаФамилию(ЗначениеПеременной);
КонецПроцедуры
 
&НаСервереБезКонтекста
Процедура ЗапихнутьВРеквизитДокументОбъект(ЗначениеПеременной)
    СсылкаНаОбъект = Справочники.<ИмяСправочника>.НайтиПоНаименованию(ЗначениеПеременной); //Или по коду, как тебе захочется
    Если Не СсылкаНаОбъект.Пустая() Тогда
        СпрОбъект = СсылкаНаОбъект.ПолучитьОбъект();
    Иначе
        СпрОбъект = Справочники.<ИмяСправочника>.СоздатьЭлемент();
    КонецЕсли;
    СпрОбъект.ИмяРеквизита = "Всякая чушь которую ты хочешь записать в справочник";
    СпрОбъект.Записать();
       
КонецПроцедуры
1
Pascal +
133 / 132 / 127
Регистрация: 16.03.2011
Сообщений: 461
06.05.2012, 18:21  [ТС] 6
Цитата Сообщение от Dethmontt Посмотреть сообщение
ЗапихнутьВРеквизитСправочникаФ амилию
А можно это немножко подробнее объяснить, как это? Запихнуть?

Добавлено через 8 минут
Простите, я еще только учусь. Поправьте пожалуйста, что не правильно
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
&НаКлиенте
Процедура ДанныеОСтудентеФамилияПриИзменении(Элемент)
    ЗначениеПеременной = "Петров";
    Записать(ЗначениеПеременной);
КонецПроцедуры
 
    &НаСервереБезКонтекста
Процедура ЗаписатьВРеквизит.Фамилия(ЗначениеПеременной)
    СсылкаНаОбъект = Справочники.Студенты.НайтиПоНаименованию(ЗначениеПеременной); 
    Если Не СсылкаНаОбъект.Пустая() Тогда
        СпрОбъект = СсылкаНаОбъект.ПолучитьОбъект();
    Иначе
        СпрОбъект = Справочники.Студенты.СоздатьЭлемент();
    КонецЕсли;
    СпрОбъект.ИмяРеквизита = "Всякая чушь";
    СпрОбъект.Записать();
       
КонецПроцедуры
0
Модератор
Эксперт 1С
2804 / 2550 / 455
Регистрация: 10.03.2011
Сообщений: 9,396
Записей в блоге: 1
Завершенные тесты: 1
06.05.2012, 22:01 7
Все не правильно =)

Добавлено через 1 минуту
Из клиентской процедуры ты должен вызвать серверную чтобы получить данные из БД, обработать их и записать...
Синтаксис помощник посмотри что такое функции и что такое процедуры

Добавлено через 2 минуты
Цитата Сообщение от UserABC Посмотреть сообщение
Сообщение от Dethmontt
ЗапихнутьВРеквизитСправочникаФ амилию
А можно это немножко подробнее объяснить, как это? Запихнуть?
Это имя серверной процедуры с передачей в нее параметра
"ЗапихнутьВРеквизитСправочника Фамилию" - Имя процедуры
ЗапихнутьВРеквизитСправочникаФ амилию(ЗначениеПеременной) - Имя процедуры с параметром

Добавлено через 2 минуты
Цитата Сообщение от Dethmontt Посмотреть сообщение
&НаКлиенте
Процедура ЧегоТоПриИзменении(Елемент)
* * ЗначениеПеременной = "Петров";
* * ЗапихнутьВРеквизитСправочникаФ амилию(ЗначениеПеременной);
КонецПроцедуры
&НаСервереБезКонтекста
Процедура ЗапихнутьВРеквизитДокументОбъе кт(ЗначениеПеременной)
* * СсылкаНаОбъект = Справочники.<ИмяСправочника>.Н айтиПоНаименованию(ЗначениеПер еменной); //Или по коду, как тебе захочется
* * Если Не СсылкаНаОбъект.Пустая() Тогда
* * * * СпрОбъект = СсылкаНаОбъект.ПолучитьОбъект( );
* * Иначе
* * * * СпрОбъект = Справочники.<ИмяСправочника>.С оздатьЭлемент();
* * КонецЕсли;
* * СпрОбъект.ИмяРеквизита = "Всякая чушь которую ты хочешь записать в справочник";
* * СпрОбъект.Записать();
КонецПроцедуры
Я опечатался...
вот так
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Процедура ЧегоТоПриИзменении(Елемент)
* * ЗначениеПеременной = "Петров";
* * ЗапихнутьВРеквизитДокументОбъект(ЗначениеПеременной);
КонецПроцедуры
&НаСервереБезКонтекста
Процедура ЗапихнутьВРеквизитДокументОбъект(ЗначениеПеременной)
* * СсылкаНаОбъект = Справочники.<ИмяСправочника>.НайтиПоНаименованию(ЗначениеПеременной); //Или по коду, как тебе захочется
* * Если Не СсылкаНаОбъект.Пустая() Тогда
* * * * СпрОбъект = СсылкаНаОбъект.ПолучитьОбъект();
* * Иначе
* * * * СпрОбъект = Справочники.<ИмяСправочника>.СоздатьЭлемент();
* * КонецЕсли;
* * СпрОбъект.ИмяРеквизита = "Всякая чушь которую ты хочешь записать в справочник";
* * СпрОбъект.Записать();
КонецПроцедуры
1
Pascal +
133 / 132 / 127
Регистрация: 16.03.2011
Сообщений: 461
06.05.2012, 22:49  [ТС] 8
Спасибо огромное! Буду разбираться.. =)
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.05.2012, 22:49

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Документ ПриходТовара: выбрать в таблице из Справочник.Товары
Собственно, пришлось разбиратся в 1С. И так, входные данные: Есть Справочник.Товары Его...

Справочник (Документ, Отчет)->Форма->Диалог->Объект
Всем доброго времени суток! Имеем... файловая 7-ка (27 платформа). Конфа - бухгалтерия 512-я. Вот...

справочник + регистр сведений (независимый) = отбор для поля в документ
Добрый вечер. Бухгалтерия 8.2 1) есть документ, в шапке которого указывается точка продажи,...

Добавление атрибута в справочник
Нуждаюсь в помощи,в 1C я ноль,но по учебе нужно сделать лабу,может кто поможет. Задание такое...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.