Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/19: Рейтинг темы: голосов - 19, средняя оценка - 5.00
39 / 39 / 4
Регистрация: 20.04.2011
Сообщений: 789
Записей в блоге: 1
1
1C 7.x

Добавление нового поля в документе 1с 7.7

06.07.2012, 14:28. Показов 3893. Ответов 7
Метки нет (Все метки)

думаю многие столкнулись с декларированием отчетности по алкоголю. в связи с этим для отчетности необходимо указывать для алкоголя производителя(ИНН, КПП). идея такая добавить в справочник номенклатура реквизит с типом контрагент. а в документ прихода добавить поле, аналогично количеству, объем в литрах, ну и насколько я понимаю нужно добавить это поле в регистрах. так вот где посмотреть в какой регистр заносятся сведения по документу, 1с8 знаю где смотреть а вот в семерке не могу найти это.
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.07.2012, 14:28
Ответы с готовыми решениями:

УТ 10.3 Реализация товаров и услуг, добавление нового поля
Добрый вечер форумчане! Имеется конфигурация УТ 10.3 платформа8.2. В табличной части документа...

Динамический список. Добавление нового поля
Всем добрый день. 1С:Предприятие 8.3 (8.3.8.1747) Конф Зарплата и кадры государственного...

Добавление нового поля в таблицу
Здравствуйте. Access2003. При закрытии формы пытаюсь добавить поле в имеющуюся таблицу (форма с...

Добавление нового поля в ADOTabel
Помогите разобраться куда какие данные заносить в выделенном месте.

7
34 / 34 / 3
Регистрация: 31.03.2011
Сообщений: 197
06.07.2012, 15:03 2
Модуль документа копать. Только так.
0
2953 / 1765 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
06.07.2012, 22:00 3
Надо начать с отчетности: откуда что берётся. Вот туда и добавлять, глядя в ОбработкуПроведения().
0
39 / 39 / 4
Регистрация: 20.04.2011
Сообщений: 789
Записей в блоге: 1
09.07.2012, 09:06  [ТС] 4
в обработке проведения вызывается вот эта процедура:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
Процедура ПроведениеПоРегистрам()
    
    Перем ВремРегистры;
    Перем ВремПоставщики, ВремЗаказы, ВремЗаказыЗаявки;
    
    // Удаление движений по регистрам.
    Для Номер = 1 По Метаданные.Регистр() Цикл
        ОчиститьДвижения("Регистр."+Метаданные.Регистр(Номер).Идентификатор);
    КонецЦикла;
    
    ТаблицаДокумента=глПодготовитьТаблицуДокумента(Контекст);
    
    СписокПараметров=СоздатьОбъект("СписокЗначений");
    
    СписокПараметров.ДобавитьЗначение(ТекущийДокумент(),"ТекДок");
    СписокПараметров.ДобавитьЗначение(Склад,       "Склад");
    СписокПараметров.ДобавитьЗначение(Фирма,       "Фирма");
    СписокПараметров.ДобавитьЗначение(Контрагент, "Контрагент");
    СписокПараметров.ДобавитьЗначение(Договор,       "Договор");
    
    СписокПараметров.ДобавитьЗначение(КодОперации,   "КодОперации");
            
    ВремРегистры     = СоздатьОбъект("Регистры");
    ВремЗаказы         = ВремРегистры.Заказы;
    ВремЗаказыЗаявки = ВремРегистры.ЗаказыЗаявки;
    
    ФильтрЗаказов(ТаблицаДокумента, ВремЗаказы, ВремЗаказыЗаявки);
    Если (КодОперации=Перечисление.КодыОпераций.Закупка) или (КодОперации=Перечисление.КодыОпераций.ЗакупкаРозница) Тогда
        ВремПоставщики = ВремРегистры.Поставщики;
        глФильтрДолгов(Контекст, Договор, СписокПараметров, ВремПоставщики);
    КонецЕсли;
    
    Если ИтогиАктуальны() = 0 Тогда
        ВремРегистры.Актуальность(1);
        ВремРегистры.РассчитатьРегистрыНа(ТекущийДокумент());
    КонецЕсли;
    
    // Принимать на реализацию будет только товары
    Если КодОперации=Перечисление.КодыОпераций.ПриемНаРеализациюРозница  Тогда
                                  
        ТаблицаДокумента.ВыбратьСтроки();
        Пока ТаблицаДокумента.ПолучитьСтроку()=1 Цикл
            ТаблицаДокумента.ВидТМЦ       = Перечисление.ВидыТМЦ.Товар;
        КонецЦикла;      
    КонецЕсли;    
    
    ДвижениеЗаказов(ТаблицаДокумента, ВремЗаказы, ВремЗаказыЗаявки);
    глПриходОстатковТМЦ      (Контекст,ТаблицаДокумента,СписокПараметров);
    глОприходованиеПартийТМЦ(Контекст,ТаблицаДокумента,СписокПараметров);
                                                                     
    Если (КодОперации=Перечисление.КодыОпераций.Закупка) или (КодОперации=Перечисление.КодыОпераций.ЗакупкаРозница) Тогда
                                  
        ТаблицаДокумента.Свернуть("ВидТМЦ,СтавкаНДС","Сумма,СуммаУпр,СуммаРуб,СуммаНДС,СуммаНП");
        ТаблицаДокумента.НоваяКолонка("ВидДолга");
        ТаблицаДокумента.НоваяКолонка("КредДокумент");
        
        ТаблицаДокумента.ВыбратьСтроки();
        Пока ТаблицаДокумента.ПолучитьСтроку()=1 Цикл
            ТаблицаДокумента.ВидДолга       = ВидДолгаПоТМЦ(ТаблицаДокумента.ВидТМЦ);
            ТаблицаДокумента.КредДокумент   = ТекущийДокумент();
        КонецЦикла;      
        
        СписокПараметров.Установить("ЗнакДвижения", -1); // уменьшение долга контрагента
        глДвижениеДолгов(Контекст, Договор, ТаблицаДокумента,СписокПараметров,ВремПоставщики);
    КонецЕсли;    
 
КонецПроцедуры // ПроведениеПоРегистрам()
но из нее не понятно какие регистры используются, либо я не туда смотрю
0
34 / 34 / 3
Регистрация: 31.03.2011
Сообщений: 197
09.07.2012, 09:41 5
Цитата Сообщение от deeller Посмотреть сообщение
ВремРегистры = СоздатьОбъект("Регистры");
ВремЗаказы = ВремРегистры.Заказы;
ВремЗаказыЗаявки = ВремРегистры.ЗаказыЗаявки;
Цитата Сообщение от deeller Посмотреть сообщение
ВремПоставщики = ВремРегистры.Поставщики;
Т.е. регистры "Заказы", "ЗаказыЗаявки", "Поставщики"
0
39 / 39 / 4
Регистрация: 20.04.2011
Сообщений: 789
Записей в блоге: 1
09.07.2012, 09:48  [ТС] 6
Танцор_С_Бубном, спасибо теперь понял. хотя я был уверен что должен быть регистр ПартииНаличие из него вытаскивается вся инфа по остаткам.
0
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
09.07.2012, 23:57 7
Вы правы насчет регистра партий. Танцор_С_Бубном указывает не на те регистры.
Смотрите процедуры глобального модуля:
1C
1
2
 глПриходОстатковТМЦ     (Контекст,ТаблицаДокумента,СписокПараметров);
 глОприходованиеПартийТМЦ(Контекст,ТаблицаДокумента,СписокПараметров);
Модифицировать регистр партий непростая задача. Если Вы не имеете достаточного опыта, нужно делать это с большой осторожностью. В ТИС алгоритм списания партий совсем не простой.
0
39 / 39 / 4
Регистрация: 20.04.2011
Сообщений: 789
Записей в блоге: 1
10.07.2012, 08:51  [ТС] 8
отказался от модификации регистров. пошел другим путем.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
10.07.2012, 08:51

Добавление нового поля в таблицу
В таблицу Access мне нужно добавлять поле при нажатии на кнопку. ADOQuery1->Active=false;...

Добавление нового поля в подчиненную форму
Здравствуйте, уважаемые специалисты. Помогите пожалуйста. Делаю БД в Аксесс 2013. Есть форма,...

Добавление нового поля заданного типа в запрос
Здравствуйте! Есть таблица с несколькими колонками.Нужно написать запрос, который выведет на...

Добавление нового поля на форме, если в таблице отсутствует
Создана форма. Допустим, уже на ней 5 полей(со своими форматами). Через некоторое время, например,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.