Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.55/11: Рейтинг темы: голосов - 11, средняя оценка - 4.55
kuz93
0 / 0 / 0
Регистрация: 25.12.2010
Сообщений: 10
1

Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".

08.12.2012, 15:36. Просмотров 2001. Ответов 5
Метки нет (Все метки)

МОЙ ВОЗРАСТ. Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".

Сообщить("Введите возраст:"+a); ВвестиЧисло(а);
Сообщить("Мне "+ а);
если 10>Цел(а/100)<20 тогда Сообщить("лет"+a)
КонецЕсли;
ИначеЕсли Цел(а/10) = 1 тогда Сообщить("год"+a)
КонецЕсли;
ИначеЕсли 2> Цел(а/10)<4 тогда Сообщить("года"+a)
иначе Сообщить("лет"+a);
КонецЕсли;


КонецПроцедуры




помогите исправить код[/QUOTE]
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.12.2012, 15:36
Ответы с готовыми решениями:

Вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет"
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст человека,вывести фразу вида: &quot;Мне...

Вывести на экран фразу "Мне k лет" правильно заменяя слово "лет" на "год" или "года"
Дано целое k. Вывести на экран фразу &quot;Мне k лет&quot; правильно заменяя слово &quot;лет&quot; на &quot;год&quot; или...

Для заданного возраста человека, вывести фразу вида: "Мне 18 лет", "Мне k лет"
Для заданного 0 &lt; k &lt; 200,рассматриваемого как возраст человека,вывести фразу вида: &quot;Мне 18 лет&quot;,...

Вывести на экран фразу "Мне n лет", учитывая что при некоторых значениях n слово "лет" надо заменить на "год"
дано натуральное число n. Вывести на экран фразу &quot;Мне n лет&quot;, учитывая что при некоторых значениях...

5
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
08.12.2012, 18:50 2
А в чем проблема то?
0
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
08.12.2012, 19:56 3
Проблема в том, что надо применять не Цел(Возраст/10), а Возраст%10. Вот исправленный код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
Процедура МойВозраст(Команда)
    Возраст=0;
    Сообщить("Введите возраст:");
    ВвестиЧисло(Возраст);
    Если Возраст%100<10 ИЛИ Возраст%100>20 Тогда
        Если Возраст%10 = 1 Тогда Сообщить("Мне "+ Возраст +" год")
        ИначеЕсли Возраст%10<5 И Возраст%10>1 Тогда Сообщить("Мне "+ Возраст +" года")           
        Иначе Сообщить("Мне "+ Возраст + " лет"); 
        КонецЕсли;
    Иначе Сообщить("Мне "+ Возраст + " лет"); 
    КонецЕсли;
КонецПроцедуры
1
Dethmontt
Модератор
Эксперт 1С
2764 / 2516 / 448
Регистрация: 10.03.2011
Сообщений: 9,199
Записей в блоге: 1
Завершенные тесты: 1
10.12.2012, 00:48 4
1C
1
2
3
Возраст = 15;    
А = ЧислоПрописью(Возраст,"Л=ru_RU","Год,Года,Лет,м,Год,Года,Лет,м,0");
Сообщить(А);
1
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
10.12.2012, 18:01 5
Цитата Сообщение от Dethmontt Посмотреть сообщение
1C
1
2
3
Возраст = 15;    
А = ЧислоПрописью(Возраст,"Л=ru_RU","Год,Года,Лет,м,Год,Года,Лет,м,0");
Сообщить(А);
Оно выдаёт выражение вида "пятнадцать лет". А если нужно число цифрами, но чтобы предмет исчисления также склонялся (год, года, лет,...)?
0
Dethmontt
Модератор
Эксперт 1С
2764 / 2516 / 448
Регистрация: 10.03.2011
Сообщений: 9,199
Записей в блоге: 1
Завершенные тесты: 1
10.12.2012, 18:03 6
1C
1
2
3
4
5
Возраст = 15;   
А = ЧислоПрописью(Возраст,"Л=ru_RU","Год,Года,Лет,м,Год,Года,Лет,м,0");
А = Прав(А,4);
А = СтрЗаменить(А," ","");
Сообщить("Мне "+Возраст+" "+А);
0
10.12.2012, 18:03
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.12.2012, 18:03

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Напечатать фразу "Мне N лет", согласовав слово "лет, год, года" с числом N
Составьте программы разветвляющейся структуры согласно вариантам задания (используя SWITCH) . ...

Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с последующим словом "год", "года" или "лет"
Здравствуйте! Помогите решить задачу! Ввести возраст человека (от 1 до 150 лет) и вывести его...

Составить программу, которая по введённому возрасту k формирует фразу: "Мне К лет/год/года".
Составить программу, которая по введённому возрасту k (k-количество полных лет,...

Вывести возраст вместе с последующим слово "год", "года" или "лет".
В общем вот. Ввести возраст человека (1-150 лет) и вывести его вместе с последующим слово &quot;год&quot;,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.