Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.89/19: Рейтинг темы: голосов - 19, средняя оценка - 4.89
72 / 72 / 1
Регистрация: 18.12.2012
Сообщений: 390
1
1C 8.x

Редактирование данных этого периода запрещено

20.03.2013, 07:10. Просмотров 3404. Ответов 5
Метки нет (Все метки)


Подскажите, где косяк, пожалуйста. Делаю движения в документе (выбираю данные запросом). Вроде параметры запроса правильно указаны, но при попытке проведения выдает "Редактирование данных этого периода запрещено. Изменения не могут быть записаны...". Дата запрета изменения данных стоит меньше, чем тот период, за который проводится документ. Вот сам код
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
Процедура ОбработкаПроведения(Отказ, РежимПроведения)
 
    Движения.Хозрасчетный.Записывать = Истина;
    Запрос = Новый Запрос;
    Проводки = Движения.Хозрасчетный;
    СписокСчетов = Новый Массив;
    НачПериода = НачалоКвартала(Дата);
    КонПериода = КонецКвартала(Дата);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ОсновноеПроизводство);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПроизводствоИзДавальческогоСырья);
    Запрос.УстановитьПараметр("СписокСчетов", СписокСчетов);
    Запрос.Текст = "ВЫБРАТЬ
                   |    ХозрасчетныйОборотыДтКт.СчетДт,
                   |    ХозрасчетныйОборотыДтКт.СчетКт,
                   |    ХозрасчетныйОборотыДтКт.СубконтоДт1 КАК ВидСубконтоДт1,
                   |    ХозрасчетныйОборотыДтКт.СубконтоДт2 КАК ВидСубконтоДт2,
                   |    ХозрасчетныйОборотыДтКт.СубконтоДт3 КАК ВидСубконтоДт3,
                   |    ХозрасчетныйОборотыДтКт.СубконтоКт1 КАК ВидСубконтоКт1,
                   |    ХозрасчетныйОборотыДтКт.СуммаОборот,
                   |    ХозрасчетныйОборотыДтКт.Период
                   |ИЗ
                   |    РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт(&НачПериода, &КонПериода, Квартал, , , СчетКт В (&СписокСчетов), , ) КАК ХозрасчетныйОборотыДтКт";
                                                                   
    Запрос.УстановитьПараметр("НачПериода", НачПериода);
    Запрос.УстановитьПараметр("КонПериода", КонПериода);
    Результат = Запрос.Выполнить().Выгрузить();
    Проводки.Загрузить(Результат);
    Проводки.Добавить();    
    
    
КонецПроцедуры // ОбработкаПроведения()
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
20.03.2013, 07:10
Ответы с готовыми решениями:

Период из запроса разбить на начало периода и конец периода
есть запрос "выбрать оборотыпродажи. период как период из продажиобороты " на выходе имеем...

Запрет правки данных после закрытия периода
Помогите, пожалуйста: перед мной встала задача в базе 1с 7,7 Торговля+Склад 9,2 сделать так, чтобы...

Редактирование реестра запрещено администратором сисемы
Такое дело, что у меня после загрузки компа и появления окна приветствия окно монитора чёрное с...

Редактирование запрещено пользователем "другой пользователь"
Доброго времени суток! Ситуация такая: существует порядка 20 пользователей, которые работают с...

5
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.03.2013, 09:34 2
Цитата Сообщение от Augusto Посмотреть сообщение
|* * ХозрасчетныйОборотыДтКт.Период
Цитата Сообщение от Augusto Посмотреть сообщение
Проводки.Загрузить(Результат);
Вы делаете проводки датой, которая выбирается запросом, а не датой документа.

Augusto, все еще 20 счет закрываете?
0
72 / 72 / 1
Регистрация: 18.12.2012
Сообщений: 390
20.03.2013, 09:40  [ТС] 3
Удалил строку | * * ХозрасчетныйОборотыДтКт.Период, все равно ту же ошибку выдает.

Fenomen, ага, забил на время, но допилить-то надо
0
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.03.2013, 14:18 4
Цитата Сообщение от Augusto Посмотреть сообщение
Удалил строку | * * ХозрасчетныйОборотыДтКт.Период, все равно ту же ошибку выдает.
Теперь Вы делаете проводки с пустой датой.

Цитата Сообщение от Augusto Посмотреть сообщение
Fenomen, ага, забил на время, но допилить-то надо
Не хочу Вас расстраивать - но приведенный кусок кода, в контексте задачи - ерунда полная.
1
72 / 72 / 1
Регистрация: 18.12.2012
Сообщений: 390
20.03.2013, 14:35  [ТС] 5
Цитата Сообщение от Fenomen Посмотреть сообщение
Не хочу Вас расстраивать - но приведенный кусок кода, в контексте задачи - ерунда полная.
А вот так?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
Процедура ОбработкаПроведения(Отказ, РежимПроведения)
 
    Движения.Хозрасчетный.Записывать = Истина;
    Запрос = Новый Запрос;
    Проводки = Движения.Хозрасчетный;
    СписокСчетов = Новый Массив;
    НачПериода = НачалоКвартала(Дата);
    КонПериода = КонецКвартала(Дата);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ОсновноеПроизводство);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПроизводствоИзДавальческогоСырья);
    Запрос.УстановитьПараметр("СписокСчетов", СписокСчетов);
    Запрос.Текст = "ВЫБРАТЬ
                   |    ХозрасчетныйОборотыДтКт.СубконтоДт1,
                   |    ХозрасчетныйОборотыДтКт.СубконтоДт2,
                   |    ХозрасчетныйОборотыДтКт.СуммаОборот,
                   |    ХозрасчетныйОборотыДтКт.СчетДт,
                   |    ХозрасчетныйОборотыДтКт.СчетКт,
                   |    ХозрасчетныйОборотыДтКт.Период
                   |ИЗ
                   |    РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт(&НачПериода, &КонПериода, Квартал, , , СчетКт В (&СписокСчетов), , ) КАК ХозрасчетныйОборотыДтКт
                   |ГДЕ
                   |    ХозрасчетныйОборотыДтКт.Период МЕЖДУ &НачПериода И &КонПериода";
                   
    Запрос.УстановитьПараметр("НачПериода", НачПериода);
    Запрос.УстановитьПараметр("КонПериода", КонПериода);
    Результат = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
         Проводка = Проводки.Добавить();
         Проводка.Период = ВыборкаДетальныеЗаписи.Период;
         Проводка.Организация = ЭтотОбъект.Организация;
         Проводка.Сумма = ВыборкаДетальныеЗаписи.СуммаОборот;
         Проводка.Регистратор = ЭтотОбъект.Ссылка;
         Проводка.СчетДт = ВыборкаДетальныеЗаписи.СчетДт;
         Проводка.СчетКт = ВыборкаДетальныеЗаписи.СчетКт;
         БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"НоменклатурныеГруппы",        ВыборкаДетальныеЗаписи.СубконтоДт1);
         БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"СтатьиЗатрат",           ВыборкаДетальныеЗаписи.СубконтоДт2);
     КонецЦикла;
            
        
    
        
    
КонецПроцедуры // ОбработкаПроведения()
Добавлено через 1 минуту
П.С. Опять непонятки с периодом! Как я только с ним не бился, не хочет работать и все тут

Добавлено через 8 минут
С периодом вроде разобрался, только у меня счета вместо того чтоб закрыться, наоборот открываются. Подскажите, пожалуйста, что удалить надо, чтоб сальдо к нулю сводилось, а не накапливалось
0
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.03.2013, 16:21 6
Augusto, сделайте в типовой бухгалтерии пример. Закройте в нем 20 счет, и посмотрите какие проводки формируются, чтобы понять суть решаемой Вами задачи.
Ваша проблема в том, что Вы пишете код, не понимая, что нужно сделать.

Добавлено через 1 минуту
Цитата Сообщение от Augusto Посмотреть сообщение
|ГДЕ
* * * * * * * * * *|* * ХозрасчетныйОборотыДтКт.Период МЕЖДУ &НачПериода И &КонПериода";
Не нужное условие.

В целом если объяснить Ваш код, ты задваиваете обороты по счетам, а не делаете его закрытие.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
20.03.2013, 16:21

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Как исправить ошибку: Запрещено разрешение на объект базы данных
При добавления записи в бд SQL-server через делфи возникает такая ошибка.

Публикация в IIS. разрешение create database запрещено в базе данных master
В общем есть такая библиотека классов https://github.com/brucedog/u2flib с демо-сайтом. Открыл с...

Ввод периода через InputBox и обновление данных на форме
Помогите, пожалуйста, решить проблему: Нужно, чтобы в форме(frm_Glavnaya) В полях «Период» ...

Выбор данных, выгружаемых из Excel в Word в зависимости от выбранного периода
Добрый день, помогите, пожалуйста, со следующей заморочкой: У меня осуществляется выгругрузка в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.