Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.62/34: Рейтинг темы: голосов - 34, средняя оценка - 4.62
1 / 1 / 1
Регистрация: 20.03.2013
Сообщений: 50
1

Булево

20.03.2013, 18:05. Просмотров 6152. Ответов 7
Метки нет (Все метки)


Как написать модуль, чтобы если при установке Булево (Константы.Адреса) в значении Истина, в значение строки (Константы.ПочтовыйАдрес) вводилось значение строки (Константы.Адрес) без возможности редактирования, а если Булево (Константы.Адреса) было в значении Ложь строка (Константы.ПочтовыйАдрес) была доступна для редактирования?????

Добавлено через 11 минут
Цитата Сообщение от Костик24 Посмотреть сообщение
Как написать модуль, чтобы если при установке Булево (Константы.Адреса) в значении Истина, в значение строки (Константы.ПочтовыйАдрес) вводилось значение строки (Константы.Адрес) без возможности редактирования, а если Булево (Константы.Адреса) было в значении Ложь строка (Константы.ПочтовыйАдрес) была доступна для редактирования?????
Забыл: У меня 1С 8.2.17.169
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
20.03.2013, 18:05
Ответы с готовыми решениями:

Булево
Здравствуйте,подскажите пожалуйста.Я в 1 с совсем недавно.Есть реквизит Адрес проживания совпадает...

Булево у Чистова
В своем видеокурсе (1 часть, 20-21 минута) Чистов приводит такое выражение: B = 10 > 48 = 45 ИЛИ...

Выбор булево
Добрый день. Делаю отбор картсчетафизлиц. КартСчетаФизЛиц.АктивностьСчета КАК АктивностьСчета,...

Булево и Автозаполнение строк
Подскажите в чем проблема, данная процедура взята из Бухгалтерии, но выдает ошибку:...

7
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.03.2013, 18:47 2
Если понял о чем Вы, то:
1C
1
ЭлементыФормы.ПочтовыйАдрес.Доступность = ЭлементыФормы.Адреса.Значение;
Имена элементов управления у Вам могут быть другие.
1
1 / 1 / 1
Регистрация: 20.03.2013
Сообщений: 50
20.03.2013, 19:05  [ТС] 3
Цитата Сообщение от Fenomen Посмотреть сообщение
Если понял о чем Вы, то:
1C
1
ЭлементыФормы.ПочтовыйАдрес.Доступность = ЭлементыФормы.Адреса.Значение;
Имена элементов управления у Вам могут быть другие.
Не совсем, я имел в виду что:
Если ставишь булево истиной тогда значение Константы.ПочтовыйАдрес берется из Константы.Адрес, и редактировать это поле нельзя
а галочку не ставишь тогда Константы.Почтовый адрес заполняется вручную
0
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.03.2013, 19:08 4
Константа - это объект конфигурации. Она не может быть доступна или нет

Доступен или недоступен может быть элемент управления формы. Детализируйте Ваш вопрос, потому что сейчас по нему вообще непонятно о чем Вы спрашиваете.
1
1 / 1 / 1
Регистрация: 20.03.2013
Сообщений: 50
20.03.2013, 19:20  [ТС] 5
Цитата Сообщение от Fenomen Посмотреть сообщение
Константа - это объект конфигурации. Она не может быть доступна или нет

Доступен или недоступен может быть элемент управления формы. Детализируйте Ваш вопрос, потому что сейчас по нему вообще непонятно о чем Вы спрашиваете.
Ну ок, тогда так:
Как сделать чтобы:
В форме если ставишь галочку (константы.Адреса)
Значение поля (Константы.ПочтовыйАдрес) бралось
из значения (Константы.Адрес).

НО! Если ставишь галочку тогда элемент формы (Константы.ПочтовыйАдрес) становилось не доступным для редактирования, а если галочка не стоит тогда это поле заполняется вручную??????????
0
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
20.03.2013, 19:34 6
Для элемента формы флажок(константы.Адреса), на событие ПриИзменении назначаете процедуру.
В ней:
1C
1
2
3
4
5
6
7
Если ЭлементыФормы.ИмяФлажка.Значение Тогда
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Значение = Константы.Адрес.Получить();
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Доступность = Ложь;
ИНаче
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Значение = "";
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Доступность = Истина;
КонецЕсли;
2
1 / 1 / 1
Регистрация: 20.03.2013
Сообщений: 50
21.03.2013, 13:21  [ТС] 7
Цитата Сообщение от Fenomen Посмотреть сообщение
Для элемента формы флажок(константы.Адреса), на событие ПриИзменении назначаете процедуру.
В ней:
1C
1
2
3
4
5
6
7
Если ЭлементыФормы.ИмяФлажка.Значение Тогда
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Значение = Константы.Адрес.Получить();
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Доступность = Ложь;
ИНаче
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Значение = "";
       ЭлементыФормы.ИмяЭлементаПочтовыйАдрес.Доступность = Истина;
КонецЕсли;
В результате получилось:
Процедура ПриИзменении() Экспорт;
Если Константы.АдресРПАдресОрганизации.Значение Тогда
Константы.ПочтовыйАдресОрганизации.Значение = Константы.АдресОрганизации.Получить();
Константы.ПочтовыйАдресОрганизации.Доступность = Ложь;
Иначе
Константы.ПочтовыйАдресОрганизации.Значение = "";
Константы.ПочтовыйАдресОрганизации.Доступность = Истина;
КонецЕсли;
КонецПроцедуры;


Но ничего не работает
0
72 / 72 / 1
Регистрация: 18.12.2012
Сообщений: 390
21.03.2013, 14:22 8
Цитата Сообщение от Костик24 Посмотреть сообщение
Процедура ПриИзменении() Экспорт;
Если Константы.АдресРПАдресОрганизации.Значение Тогда
Константы.ПочтовыйАдресОрганизации.Значение = Константы.АдресОрганизации.Получить();
Константы.ПочтовыйАдресОрганизации.Доступность = Ложь;
Иначе
Константы.ПочтовыйАдресОрганизации.Значение = "";
Константы.ПочтовыйАдресОрганизации.Доступность = Истина;
КонецЕсли;
КонецПроцедуры;
Причем тут Если Константы.АдресРПАдресОрганизации.Значение? Вы должны передавать в условие флажок, а не константу

Добавлено через 2 минуты
И зачем Вам Экспорт? Вешать процедуру надо на событие ПриИзменении флажка, который размещается в форме

Добавлено через 4 минуты
И обращаться Вы должны к элементу формы ПочтовыйАдресОрганизации, а не к константе. Из константы получаете только значение адреса в том случае, если доступность поля ввода Ложь
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
21.03.2013, 14:22

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Ошибка заполнения реквизита булево
Товарищи программисты, подскажите пожалуйста, в чем может быть ошибка, в 1С первый раз, припахали...

Где в таблице *.dbf булево (да, нет)?
Добрый день. беру данные из файловой версии 1С 7,7 таблицы *.DBF открываю их DBFnavigator но там не...

Колонка типа "Булево" в динамически создаваемом отчете
Помогите, пожалуйста! Мне в отчет "Анализ заказов покупателей" в типовой УТ v8 нужно вставить...

Преобразование значения к типу Булево не может быть выполнено
Подскажите в чем проблема, и как ее решить При начислении заработной платы, когда нажимаю...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.