0 / 0 / 0
Регистрация: 04.04.2013
Сообщений: 2
1
1C 8.x

Ошибка при вызове метода контекста (ВыбратьИзСписка)

04.04.2013, 10:58. Показов 5875. Ответов 3
Метки нет (Все метки)

Люди срочно помогите что не так????
В программе не лазили возникла ошибка:

При выборе Формирование книги продаж - формирование записей книги продаж возникает ошибка при нажатии на выбрать(F4) в строке счет - фактура

err {ОбщийМодуль.РаботаСДиалогами.Модуль(258)}: Ошибка при вызове метода контекста (ВыбратьИзСписка)
ВыбранныйЭлемент = ФормаДокумента.ВыбратьИзСписка(СписокТипов, ЭлементФормы);
по причине:
Недопустимое значение параметра (параметр номер '2')

сам модуль:
1C
1
2
3
4
5
6
7
8
9
10
11
ВыбранныйЭлемент = ФормаДокумента.ВыбратьИзСписка(СписокТипов, ЭлементФормы);
 
        Если ВыбранныйЭлемент = Неопределено Тогда // Отказ от выбора
            Возврат;
        КонецЕсли;
        ВыбранныйТип = ВыбранныйЭлемент.Значение;
    КонецЕсли;
 
    Если ТипЗнч(ЭлементФормы.Значение) <> Тип("ДокументСсылка." + ВыбранныйТип) Тогда
        ЭлементФормы.Значение = Документы[ВыбранныйТип].ПустаяСсылка();
    КонецЕсли;
Если нужно больше информации напишите сообщу Ждуууу.

Инфа о программе:
1С:Предприятие 8.3 (8.3.2.163) (8.2) то же самое.
Бухгалтерия предприятия, редакция 2.0 (2.0.32.6)
Виндовс не важно на всех машинах то же самое.
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
04.04.2013, 10:58
Ответы с готовыми решениями:

Ошибка при вызове метода контекста
Задача сделать автоподбор. Но вот при выполнении выдает...

Ошибка при вызове метода контекста
есть ссылка &quot;e79ba7ae-0747-11db-9244-0011955c22cb&quot;... как присвоить ее новому элементу справочника...

Ошибка при вызове метода контекста (ПолучитьОбъект)
Привет народ Программа ругается что: {Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста...

Ошибка при вызове метода контекста (Выполнить)
Ошибка при выполнении обработчика - 'ОбработкаПроведения' по причине:...

3
2954 / 1766 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
04.04.2013, 13:37 2
умозрительно сложно сказать. По тексту траблов нет, дело в конкретной ситуации. быстрый 100%-й результат даст отладка. Если некому - тогда тестирование и исправление,обновление конфигурации... типа стёкла протереть, по колёсам попинать

Добавлено через 8 минут
ЭлементФормы должен иметь тип "контрол" или элемент коллекции ЭлементыФормы. Служит тупо для позиционирования выпад.списка.
0
0 / 0 / 0
Регистрация: 04.04.2013
Сообщений: 2
04.04.2013, 13:58  [ТС] 3
Вот отладку не пробовал конфигурацию менял не помогло. тестирование и исправления тоже проводились не помогло сейчас нужно попробовать отладку........
0
2954 / 1766 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
04.04.2013, 15:18 4
1C
1
2
3
4
5
6
7
8
9
10
11
12
Процедура РеализацияСчетФактураНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    ТД = ЭлементыФормы.Реализация.ТекущиеДанные;
    Если ТД = Неопределено тогда
        Возврат;
    КонецЕсли;
    СтандартнаяОбработка = Ложь;
    
    Отбор = Новый Структура("Организация,Контрагент", Организация,ТД.Покупатель);
    РаботаСДиалогами.НачалоВыбораЗначенияДокументаСоставногоТипа(ЭтотОбъект, ЭтаФорма, Элемент, СтандартнаяОбработка, Отбор, "Реализация");
 
КонецПроцедуры
типа здесь

Добавлено через 20 секунд
это форма КПр

Добавлено через 49 секунд
трабл в третьем параметре. Но он передаётся системой

Добавлено через 2 минуты
либо кто-то ковырял конфу, либо одно из двух. Но таки было обновление по поддержке?
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
04.04.2013, 15:18
Помогаю со студенческими работами здесь

Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!
Доброго всем времени суток! подскажи пожалуйста как исправить ошибку: Ошибка при чтении изменений...

Ошибка при вызове метода контекста (МоментВремени): Элемент не выбран
В УТ 8.2 скопировал печатную форму &quot;Сравнительная накладная &quot; из РеализацияТоваровУслуг в Заказ...

Ошибка разбора XML/ Ошибка при вызове метода контекста (Прочитать)
1C 8.2 Документооборот КОРП 1.2 Текст ошибки...

Ошибка при вызове метода контекста по причине испльзование модальных окон в данном режиме запрещено
Здравствуйте! столкнулась вот с такой ошибкой, понятия не имею, что делать. Сделала все по...

Не удалось сформировать внешнюю печатную форму(толстую)! Ошибка при вызове метода контекста (Выполнить): {(14, 1)}: Синтаксическая ошибка "ИЗ" <<?>>ИЗ
Подскажите, пожалуйста. Выбрал для счета только услуги, написал: Шапка =...

Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("
Что делать с этой ошибкой? Ошибка при вызове метода контекста (Выполнить)...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2023, CyberForum.ru