Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.77/43: Рейтинг темы: голосов - 43, средняя оценка - 4.77
1 / 1 / 0
Регистрация: 30.05.2013
Сообщений: 82
1

управляемая форма и картинка

31.05.2013, 15:39. Просмотров 7771. Ответов 11
Метки нет (Все метки)

нужно в управляемой форме загрузить картинку в поле картинки.
есть форма элемента справочника и на ней есть поле картинки с установленным свойством гиперссылка. По нажатию на это поле будет появлятся диалог для выбора картинки. После этого картинка загружается. После сохранения этой записи и ее открытия из списка элементов справочинка этого, картинка должна так же само загружаться. Я так понял для ее хранения нужно будет использовать реквезит с типом хранилище значений.

в обычной форме это сделать получилось, а вот в управляемой не выходит. Помогите плизз, если можно исходники кода были очень к стате.

вот как делал в обычной форме

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
Процедура ОтобразитьФотографию()
    ЭлементыФормы.ПолеФотографии.Картинка = Новый Картинка(Фотография.Получить());
КонецПроцедуры
 
Процедура ПриОткрытии()
    ОтобразитьФотографию();
    Если Валюта.Пустая() Тогда
        Валюта=Справочники.Валюты.НайтиПоНаименованию("ГРН");
    КонецЕсли;
КонецПроцедуры
 
Процедура ПолеФотографииНажатие(Элемент)
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Если НЕ Диалог.Выбрать() Тогда
        Возврат;
    КонецЕсли;
    
    Картинка = Новый Картинка(Диалог.ПолноеИмяФайла);
    
    Фотография = Новый ХранилищеЗначения(Картинка.ПолучитьДвоичныеДанные());
    
    ОтобразитьФотографию();
 
КонецПроцедуры
 
Процедура ДействияФормыПечать(Кнопка)
    ПечатьЭлемента(); 
КонецПроцедуры
есть реквезит фотография с типом хранилище значений
и поле картинки ПолеФотографии.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
31.05.2013, 15:39
Ответы с готовыми решениями:

Управляемая форма обработки
Есть обработка (не внешняя, а в конфигурации), есть её форма. 2 процедуры: &НаКлиенте...

Не изменяется управляемая форма
проблема такая. есть УТ в ней обработка. я сделал ее как внешнюю обработку и изменил в том числе...

Горячие клавиши управляемая форма
Ребят, может в курсе кто: каким образом на управляемой форме можно поменять горячую клавишу для...

Управляемая форма. Не работает форма списка документа
Здравствуйте! Создал форму списка документа, сделал ее основной формой списка. В конфигураторе все...

11
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
31.05.2013, 16:03 2
про картинки в управляемых режимах очень много было, и недавно. Можно даже визуально полистать. С примерами.
0
1 / 1 / 0
Регистрация: 30.05.2013
Сообщений: 82
31.05.2013, 18:12  [ТС] 3
Цитата Сообщение от duk337 Посмотреть сообщение
про картинки в управляемых режимах очень много было, и недавно. Можно даже визуально полистать. С примерами.
нашел только вот это Загрузка картинок
но ничего не понял как подстроить это под мой пример. Мозг закипел

Добавлено через 1 час 39 минут
Цитата Сообщение от delete2013 Посмотреть сообщение
нашел только вот это Загрузка картинок
но ничего не понял как подстроить это под мой пример. Мозг закипел
фух, вроде сделал. Вот по этой инфе. http://infostart.ru/public/73821/
0
1 / 1 / 0
Регистрация: 30.05.2013
Сообщений: 82
31.05.2013, 19:31  [ТС] 4
теперь новая проблема. Особо в коде разобраться не получилось и вот не пойму от куда берется вот это сообщение

управляемая форма и картинка


и как на форме поле картинки поместить в эту область
управляемая форма и картинка


чет не нашел где это сделать.

а да, вот исходник
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
 
    Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
        ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресКартинки);
        ТекущийОбъект.Фото = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных());
    КонецЕсли;
    Элементы.ПолеКартинки.РазмерКартинки=РазмерКартинки.Пропорционально; 
КонецПроцедуры
 
&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
 
    АдресКартинки = ПолучитьНавигационнуюСсылку(ТекущийОбъект.Ссылка, "Фото");
    Элементы.ПолеКартинки.РазмерКартинки=РазмерКартинки.Пропорционально;
КонецПроцедуры
 
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
 
    Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
        УдалитьИзВременногоХранилища(АдресКартинки);
    КонецЕсли;
 
    АдресКартинки = ПолучитьНавигационнуюСсылку(ТекущийОбъект.Ссылка, "Фото");
    Элементы.ПолеКартинки.РазмерКартинки=РазмерКартинки.Пропорционально;
    
 
КонецПроцедуры
 
&НаКлиенте
Процедура АдресКартинкиНажатие(Элемент, СтандартнаяОбработка)
    Перем ВыбранноеИмя,АдресВременногоХранилища;
    Если ПоместитьФайл(АдресВременногоХранилища, "", ВыбранноеИмя, Истина, УникальныйИдентификатор) Тогда
        АдресКартинки = АдресВременногоХранилища;
        Модифицированность = Истина;
    КонецЕсли;
    Элементы.ПолеКартинки.РазмерКартинки=РазмерКартинки.Пропорционально; 
 
КонецПроцедуры
0
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
31.05.2013, 20:41 5
Спасибо за исходник
0
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
31.05.2013, 21:46 6
Цитата Сообщение от delete2013 Посмотреть сообщение
теперь новая проблема. Особо в коде разобраться не получилось и вот не пойму от куда берется вот это сообщение
Оно в какой момент появляется?

Цитата Сообщение от delete2013 Посмотреть сообщение
и как на форме поле картинки поместить в эту область
Добавить группу. Установить свойство Группировка в значение Горизонтальная. Нужные элементы переместить в группу.
1
1 / 1 / 0
Регистрация: 30.05.2013
Сообщений: 82
31.05.2013, 22:42  [ТС] 7
Цитата Сообщение от Fenomen Посмотреть сообщение
Оно в какой момент появляется?
код вроде кое как теперь понятен и функции что используются не должны приводить к такому результату т.е показу этого сообщения.

а появлятеся тогда как выбрал нужную картинку в диалоговом окне и нажал ок. После этого появляется это сообщение.

Цитата Сообщение от Fenomen Посмотреть сообщение
Добавить группу. Установить свойство Группировка в значение Горизонтальная. Нужные элементы переместить в группу.
ага, спасибо. Попробую
0
1 / 1 / 0
Регистрация: 30.05.2013
Сообщений: 82
31.05.2013, 23:15  [ТС] 8
Цитата Сообщение от Fenomen Посмотреть сообщение
Добавить группу. Установить свойство Группировка в значение Горизонтальная. Нужные элементы переместить в группу.
попробывал так, чтот не вышло. Можете сказать что сделал я не так?
управляемая форма и картинка
0
1 / 1 / 0
Регистрация: 30.05.2013
Сообщений: 82
31.05.2013, 23:28  [ТС] 9
Цитата Сообщение от delete2013 Посмотреть сообщение
Оно в какой момент появляется?
как я понял сообщения появляется после вызова процедуры
1C
1
2
3
4
5
6
7
8
9
Процедура АдресКартинкиНажатие(Элемент, СтандартнаяОбработка)
    Перем ВыбранноеИмя,АдресВременногоХранилища;
    Если ПоместитьФайл(АдресВременногоХранилища, "", ВыбранноеИмя,Истина, УникальныйИдентификатор) Тогда
        АдресКартинки = АдресВременногоХранилища;
        Модифицированность = Истина;
    КонецЕсли;
    Элементы.ПолеКартинки.РазмерКартинки=РазмерКартинки.Пропорционально; 
 
КонецПроцедуры
а точнее после обработки этого условия
1C
1
2
3
4
Если ПоместитьФайл(АдресВременногоХранилища, "", ВыбранноеИмя,Истина, УникальныйИдентификатор) Тогда
        АдресКартинки = АдресВременногоХранилища;
        Модифицированность = Истина;
    КонецЕсли;
но как его не показывать (оповещение) я пока не разобрался
0
Модератор
Эксперт 1С
3027 / 2727 / 504
Регистрация: 10.03.2011
Сообщений: 10,403
Записей в блоге: 1
01.06.2013, 00:51 10
Цитата Сообщение от delete2013 Посмотреть сообщение
как я понял сообщения появляется после вызова процедуры
Процедура АдресКартинкиНажатие(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
1
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
01.06.2013, 10:56 11
Цитата Сообщение от delete2013 Посмотреть сообщение
попробывал так, чтот не вышло. Можете сказать что сделал я не так?
Внутри Группы1, создайте еще одну группу, с вертикальной группировкой, и перетащите в нее все остальные элементы, кроме картинки.

Я думаю после этого "упражнения", Вы освоите управление элементами на форме .
1
1 / 1 / 0
Регистрация: 30.05.2013
Сообщений: 82
01.06.2013, 12:11  [ТС] 12
Цитата Сообщение от Fenomen Посмотреть сообщение
Я думаю после этого "упражнения", Вы освоите управление элементами на форме .
спасибо) да, стало более менее уже понятней как с ними работать. Но еще изучать и изучать)
только с двумя группами не вышло. Создал вообщем 3 группы. 1 горизонтальная и в ней две вертикальных группы. в 2ю группу поместил все поля кроме поля картинки, а ее поместил в 3ю группу. Вот тогда получилось то что надо)
хотя может и с двумя можно, но я чет не так закинул(

Добавлено через 4 минуты
Цитата Сообщение от Dethmontt Посмотреть сообщение
Процедура АдресКартинкиНажатие(Элемент, СтандартнаяОбработка) СтандартнаяОбработка = Ложь;
точно. Спасибо
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
01.06.2013, 12:11

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Управляемая форма.ОсновныеНачисленияСотрудникОбработкаВыбора
Вопрос по программированию управляемого интерфейса.Есть книжка "Сборник задач для подготовки к...

Форма списка управляемая, базовые моменты
Возможно ли на управляемой форме списка создать новую табличную часть с данными. Или можно создать...

Управляемая форма обработки с компонентами, создаваемыми программно
Изучаю программирование. Что прочесть, чтобы сделать управляемую форму с компонентами, создаваемыми...

Отбор помеченных на удаление в иерархическом справочнике управляемая форма
Добрый день. Устанавливаю отбор в справочнике Пользователи, при открытии формыВыбора выдает только...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.