Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.78/9: Рейтинг темы: голосов - 9, средняя оценка - 4.78
0 / 0 / 0
Регистрация: 14.03.2013
Сообщений: 25
1

Помгите разобраться новичку

20.09.2013, 12:36. Показов 1845. Ответов 11
Метки нет (Все метки)

Добрый день помогите разобраться с обращение к элементам формы в клиент серверном приложении.
в примере написано ЭлементыФормы но у меня выдает ошибку о том что переменая не найдена.
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
20.09.2013, 12:36
Ответы с готовыми решениями:

Помгите новичку
Добрый день! Хочу научиться писать скрипты, которые выполняют действия на сайте. Есть небольшой...

Помгите разобраться с журналом
Здравствуйте, компьютер проблемный, в том плане, что за последние пол года раз 5 меняли...

просто помгите разобраться..исправить
program zadacha; uses crt; var i,j,k,n,m:integer; s1,s2:real; a,y:array of real; ...

помгите разобраться в чем ошибка? (найти все натуральные числа в диапазоне между m и n (m<n))
Вот мое задание:найти все натуральные числа в диапазоне между m и n (m&lt;n), в записи которых нет...

11
10 / 10 / 2
Регистрация: 16.08.2013
Сообщений: 53
20.09.2013, 12:45 2
Просто Элементы попробуй
0
0 / 0 / 0
Регистрация: 14.03.2013
Сообщений: 25
20.09.2013, 12:47  [ТС] 3
пробовал но потом столкнулся с проблемой
Элементы.Поле.перейти("");
На перейти начинает выдавать ошибку Форма.ОсновнаяФорма.Форма(9)}: Метод объекта не обнаружен (Перейти)
0
Эксперт 1С
475 / 413 / 92
Регистрация: 26.09.2012
Сообщений: 1,878
20.09.2013, 12:49 4
скинь весь пример, что тут пальцев в небо тыкать
0
10 / 10 / 2
Регистрация: 16.08.2013
Сообщений: 53
20.09.2013, 12:50 5
А что вообще требуется?
0
0 / 0 / 0
Регистрация: 14.03.2013
Сообщений: 25
20.09.2013, 12:53  [ТС] 6
В общем пробую сделать парсер по примеру с сайта создал внешнюю обработку добавил Поле HTML документа название сайт создал кнопку загрузить
при нажатии:

1C
1
2
3
4
&НаКлиенте
Процедура Загрузка(Команда)
    Элементы.Сайт.Перейти("Ссылка на сайт"); 
КонецПроцедуры
0
Эксперт 1С
475 / 413 / 92
Регистрация: 26.09.2012
Сообщений: 1,878
20.09.2013, 13:24 7
Цитата Сообщение от Bizzywolf Посмотреть сообщение
Элементы.Сайт.Перейти("Ссылка на сайт");
если вот это должно открывать сайт в поле хтмл документа тогда вот так Сайт = "Ссылка на сайт"
0
0 / 0 / 0
Регистрация: 14.03.2013
Сообщений: 25
20.09.2013, 13:33  [ТС] 8
вот так чтото получилось:
&НаКлиенте
Процедура Загрузка(Команда)
Объект.Сайт ="http://help1c.com/faq82/view/1435.html";
КонецПроцедуры

только пишет что Эта программа не может отобразить эту веб-страницу
0
Модератор
Эксперт 1С
3076 / 2764 / 521
Регистрация: 10.03.2011
Сообщений: 10,632
Записей в блоге: 1
20.09.2013, 13:34 9
1C
1
2
3
4
5
6
7
8
9
10
    
ЭлементыФормы.Хтмл.Перейти("http://internet.yandex.ru/");
Для Каждого Стр из ЭлементыФормы.Хтмл.Документ.body.all Цикл
        Если НРег(Стр.tagName) = "div" и Найти(Стр.innerText,"Мой IPv4:") > 0 Тогда
            Позиция = Найти(Стр.innerText,Символы.ПС);
            МойАЙПИ = СокрЛП(Сред(Стр.innerText,Найти(Стр.innerText,":")+1,Позиция));
                        Сообщить(МойАЙПИ);
            Прервать;
        КонецЕсли; 
    КонецЦикла;
1
Эксперт 1С
475 / 413 / 92
Регистрация: 26.09.2012
Сообщений: 1,878
20.09.2013, 13:35 10
У меня отработал
1
0 / 0 / 0
Регистрация: 14.03.2013
Сообщений: 25
20.09.2013, 13:40  [ТС] 11
в общем большое спасибо буду копаться и разбираться. если есть стать или книги по парсерам можете скинуть ссылку или название ?
0
Модератор
Эксперт 1С
3076 / 2764 / 521
Регистрация: 10.03.2011
Сообщений: 10,632
Записей в блоге: 1
20.09.2013, 18:15 12
http://help1c.com/faq/view/1435.html
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
20.09.2013, 18:15

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Помогите разобраться новичку!!
Всем здрасте!) Мы только начали изучать среду Borland C++ Builder, поэтому многих вещей я не...

Поомогите новичку разобраться
хочу, чтобы основным доменом было www.sajt.ru . В яндекс добавлял без www и все страницы...

Помогите новичку разобраться.
Решил изучать php с Видео-курса. но столкнулся с вопросами. По уроку: У нас есть post_max_size...

Помогите новичку разобраться с С++
Доброго всем времени суток! Пытаюсь изучать С++ и у меня такие вопросы(накопились из разных тем):...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.