Форум программистов, компьютерный форум, киберфорум
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.62/13: Рейтинг темы: голосов - 13, средняя оценка - 4.62
0 / 0 / 1
Регистрация: 03.01.2013
Сообщений: 75
1

Поле ввода (условие по значению)

23.09.2013, 08:16. Показов 2311. Ответов 6
Метки нет (Все метки)

Всем привет. Подскажите как программно задать условие?

Если значение не Москва или не Санкт-Петербург то условие выполняется

Вот написал такой код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
Если  Запись.CRM_РегионКонтрагента <> ("Москва г") ИЛИ ("Санкт-Петербург г") Тогда
    
    Если ( ЗначениеЗаполнено (Запись.ГородКонтрагента))ИЛИ
        ( ЗначениеЗаполнено(Запись.CRM_РайонКонтрагента))Тогда
                    
        ЗарегистрироватьКонтрагента();
    Иначе  
        Предупреждение("Не заполнен адрес контрагента!");
        Возврат;                                            
    КонецЕсли; 
    
КонецЕсли;
Но в режиме приложения выдает ошибку:

Преобразование значения к типу Булево не может быть выполнено

Каким методом обратиться к полю ввода чтобы можно было задать условие?
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
23.09.2013, 08:16
Ответы с готовыми решениями:

Условие в запросе: отбор в поле по значению другого поля
Здравствуйте. Подскажите как правильно записать условие в запросе? В запросе есть поля: Фамилия,...

HTML!? Есть поле ввода Type text, после ввода текста и нажатия entrer теряется фокус, как его оставить в этом же поле?
HTML!? Есть поле ввода Type text, после ввода текста и нажатия entrer теряется фокус, как его...

Как программно изменить цвет текста в поле ввода и как выделить весь текст в поле ввода по умолчанию
Как программно изменить цвет текста в поле ввода и как выделить весь текст в поле ввода по...

Как сделать запрет ввода букв в поле для ввода input
Здравствуйте! Есть стандартное поле ввода &lt;input type='text' name='name1' size='30'...

6
10 / 10 / 2
Регистрация: 16.08.2013
Сообщений: 53
23.09.2013, 08:27 2
("Москва г") ИЛИ ("Санкт-Петербург г")
Вот это попробуйте в скобки взять
0
0 / 0 / 1
Регистрация: 03.01.2013
Сообщений: 75
23.09.2013, 08:35  [ТС] 3
AmikronPersei9, посмотрите код повнимательней так скобки и так стоят
0
10 / 10 / 2
Регистрация: 16.08.2013
Сообщений: 53
23.09.2013, 08:43 4
(("Москва г") ИЛИ ("Санкт-Петербург г"))
вот так поставьте

Добавлено через 2 минуты
У вас получается что ("Москва г") сравнивается с реквизитом Запись.CRM_РегионКонтрагента, а ("Санкт-Петербург г") просто висит без сравнения и компилятор проверяет содержит ли он Истину или Ложь, но так как не содержит ни того ни другого выдает ошибку
Преобразование значения к типу Булево не может быть выполнено
0
11 / 11 / 1
Регистрация: 05.09.2013
Сообщений: 48
23.09.2013, 08:44 5
Сделать, например, перечисление "Регионы", в нем два реквизита "Москва" и "Санкт-Петербург". "Запись" - это табличная часть, как я понимаю? Присвоить к ячейке табличной части "CRM_РегионКонтрагента" созданное перечисление. А дальше
1C
1
2
3
4
5
6
7
8
9
Если НЕ ЭтаФорма.Запись.ТекущиеДанные.CRM_РегионКонтрагента = Перечисления.Регионы.ПустаяСсылка()
    Если ( ЗначениеЗаполнено (Запись.ГородКонтрагента))ИЛИ
        ( ЗначениеЗаполнено(Запись.CRM_РайонКонтрагента))Тогда           
        ЗарегистрироватьКонтрагента();
    Иначе   
        Предупреждение("Не заполнен адрес контрагента!");
        Возврат;                                            
    КонецЕсли;  
КонецЕсли;
0
10 / 10 / 2
Регистрация: 16.08.2013
Сообщений: 53
23.09.2013, 08:48 6
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Если  Запись.CRM_РегионКонтрагента <> ("Москва г") 
ИЛИ Запись.CRM_РегионКонтрагента <>("Санкт-Петербург г") Тогда
    
    Если ( ЗначениеЗаполнено (Запись.ГородКонтрагента))ИЛИ
        ( ЗначениеЗаполнено(Запись.CRM_РайонКонтрагента))Тогда
                    
        ЗарегистрироватьКонтрагента();
    Иначе   
        Предупреждение("Не заполнен адрес контрагента!");
        Возврат;                                            
    КонецЕсли;  
    
КонецЕсли;
Ну или так
1
0 / 0 / 1
Регистрация: 03.01.2013
Сообщений: 75
23.09.2013, 10:26  [ТС] 7
AmikronPersei9, Спасибо за совет!
Вот с таким кодом заработало:
1C
1
2
3
4
5
6
7
8
9
10
Если Запись.CRM_РегионКонтрагента = ("Москва г") ИЛИ 
         Запись.CRM_РегионКонтрагента = ("Санкт-Петербург г")Тогда
         ЗарегистрироватьКонтрагента();
    ИначеЕсли ( ЗначениеЗаполнено (Запись.ГородКонтрагента))ИЛИ
              ( ЗначениеЗаполнено(Запись.CRM_РайонКонтрагента))Тогда
               ЗарегистрироватьКонтрагента();
    Иначе  
        Предупреждение("Не заполнен адрес контрагента!");
        Возврат;                                            
    КонецЕсли;
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
23.09.2013, 10:26

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Как числа из поля ввода в программе отправить в поле ввода браузера?
Есть обработчик кнопки ,в поле ввода- числа. Как из поля программы отправить эти числа в нужное...

Нужно сделать поле ввода для ввода даты по шаблону
Нужно сделать поле ввода для ввода даты по шаблону ( __ . __ . ____ ). При воде нужно будет вводить...

Реализовать контроль ошибок ввода данных в поле, предназначенное для ввода пароля
4.Реализовать в JavaScript контроль ошибок ввода данных в поле, предназначенное для ввода пароля.

Реализовать контроль ошибок ввода данных в поле, предназначенное для ввода времени
5.Реализовать в JavaScript контроль ошибок ввода данных в поле, предназначенное для ввода времени.


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.