0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 6
1

(Ошибка 500) После установки IIS 5.0 не могу даже посмотреть встроенный help

20.09.2007, 08:40. Показов 2901. Ответов 14
Метки нет (Все метки)

После установки IIS не могу просмотреть даже каталог IISHELP из диспетчера служб интернета. HTML-файлы открываются, а ASP нет. Выдается ошибка 500 (внутренняя ошибка сервера). В журнале событий возникает одно предупреждение и ошибка:

COM-приложению '{3D14228D-FBE1-11d0-995D-00C04FD919C1}' на '/LM/W3SVC/1/ROOT/IISHELP' не удалось активизировать внешний процесс.

и

Серверу не удалось загрузить приложение '/LM/W3SVC/1/ROOT/IISHELP'. Ошибка: 'c000003b'.

Переустановка IIS ничего не меняет.
Подскажите где копать, заново ставить винды не очень охота. W2K SRV RUS 2195 SP 1
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
20.09.2007, 08:40
Ответы с готовыми решениями:

Проблема с запуском ASP после перестановки IIS 5.1(ошибка 500)
После того как не сколько раз перестанавливал IIS (пытался нормально настроить ASP.net - я тогда...

Проблема с запуском ASP после перестановки IIS 5.1(ошибка 500)
После того как не сколько раз перестанавливал IIS (пытался нормально настроить ASP.net - я тогда...

IIS 7.5 500 ошибка
Здравствуйте! Встретился с проблеммой 500 ошибка. Заметил что простой скрипт...

IIS 6.0 - ошибка 500
На одной машине IIS 6.0 папки типа XXX_XX работают, на второй точно такой же XXX_XX нет маму её...

14
Sergik
20.09.2007, 10:39 2
отключи в IE
сервис-свойства обозревателя-выводить подробные сообщения об ошибках HTTP
и посмотри, что за ошибка
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 6
20.09.2007, 20:31  [ТС] 3
Ошибка приложения сервера
Сервер обнаружил ошибку при загрузке приложения во время обработки вашего запроса. Дополнительные сведения см. в журнале событий. Обратитесь за помощью к администратору сервера.

То, что в журнале, я уже писал выше
0
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 6
22.09.2007, 07:57  [ТС] 4
up
0
Sergik
23.09.2007, 10:55 5
я бы посоветовал переустановить IIS
Jim
23.09.2007, 13:07 6
У меня была точно какая же проблема.
После долгих поисков, которые ничего
не дали(переустановка IIS).
Я поступил просто даже тупо.
У становил Windows поверх старой версии.
И все заработало. Может это не учший путь
но проблема решена все заработало.
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 6
23.09.2007, 16:53  [ТС] 7
Про переустановку IIS написано в первом сообщении - от этого ничего не меняется.

По поводу установки w2k поверх - это не то же самое, что переустановка win9x - все программы придется ставить заново, офис, 1С и проч...

Ну где бы кача в этих вопросах найти...
0
Sergik
23.09.2007, 17:04 8
ну тогда попробуй покопаться с разрешениями на файлы, к примеру на каталог program filescommon files поставить разрешения на исполнение и чтение пользователю IUSR_имякомпьютера (IWAM_имякомпьютера); также посмотри разрешения на system32inetsvr (это куда asp.dll ставится), и вообще на весь system32
Jim
27.09.2007, 13:00 9
Здесь ты вероятно не прав.
Я о переустановке Win2k.
Запусти Win2k затем запусти Setup и все
будет впорядке (я пробовал) тебе не
придется устанавливать заново C1 итд..
(если правильно ответишь на вопросы
задаваемые при установкие)
Как я уже писал вероятно это не лучший
вариант но в моем случае он принес плоды.
Желаю удачи
Sergik
30.09.2007, 10:57 10
Вот выписка из рассылки, может поможет:
Здравствуйте !

С каких-то пор перестал работать IIS 5.0 на Win2000 Server

Выдает 500-ю ошибку. В евентлоге:

1)DCOM пишет - The server {3D14228D-FBE1-11D0-995D-00C04FD919C1} did not register with DCOM within the required timeout.
2)W3SVC пишет - The server failed to load application '/LM/W3SVC/1/ROOT'. The error was 'Server execution failed'.

Не получается ни переустановить, ни удалить IIS - сразу 3 ошибки от
WinMgmt:
1) WMI ADAP failed to connect to namespace \.
ootcimv2MS_419 with the following error: 0x8004100e
2) WMI ADAP was unable to load the perfproc.dll performance library due to an unknown problem within the library: 0x0
3) WMI ADAP was unable to load the winspool.drv performance library due to an unknown problem within the library: 0x0

при попытке удаления Connection Manager.

ЧЕГО ЕМУ НАДО?
================================
АЕ>> при попытке удаления Connection Manager.

IS> А что это такое?
IS> И главное, как он соотносится с IIS?

Науке в моем лице это неизвестно. Но операция по удалению любого
из интернет-сервисов вызывает удаление этого компонента.

Кстати, новые подробности - все глюки наблюдаются, только если приложение
выполняется в pooled-режиме. Если его поставить как IIS Process, то все
работает нормально.

Как я понимаю, имеются глюки в COMе, но вот как их править?
================================
Какой компонент выдает ощибку?
================================
IISWAM.OutOfProcessPool
=========================
На этом обсуждение данного вопроса оканчиывется (пока оканчивается?)
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 6
01.10.2007, 08:16  [ТС] 11
Переустановил таки винды, от проблемы ушел. Правда, не тем путем
0
0 / 0 / 0
Регистрация: 26.08.2007
Сообщений: 8
02.10.2007, 10:33 12
Да, видимо, все же винды придется сносить... (это мой вопль о помощи в рассылке был ) Вот вы только точно скажите, как винды переставить, чтобы не похерился регистри.
0
Sergik
02.10.2007, 10:54 13
как минимум, устанавливай в ту же папку и запускай setup из под windows
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 6
02.10.2007, 13:07  [ТС] 14
Люди, поправьте меня, если я не прав, но я буду сопротивляться и утверждать, что если заново ставить в2к поверх то все и установится заново. И реестр будет чистенький.
0
0 / 0 / 0
Регистрация: 26.08.2007
Сообщений: 8
02.10.2007, 13:17 15
Не знаю. Но вот думается - если глюк связан с неправильностями в реестре, то при его сохранении получится что глюк останется!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
02.10.2007, 13:17

Ошибка 500 IIS 8.5
Не работает PHP выше 5.3. CGI ее спокойно обрабатывает. Но на остальные версии выдает ошибку 500 в...

Перестал работать микрофон (встроенный в наушники) на компьютере после установки Windows 7
Раньше стояла на компьютере Windows XP,потом решила установить Windows 7,после установки перестали...

Windows Server 2008, IIS 7, 500-ая ошибка
Перепробовал уже все что можно. Настраивал PHP по статье . При попытке открытия страницы постоянно...

IIS- asp ошибка: HTTP 500.100 - Внутренняя ошибка сервера - ошибка ASP Internet Information Services
Привет! Конфигурация win2000pro sp2, стандартный IIS, IE 5. При попытке обратиться к...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.