Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.91/11: Рейтинг темы: голосов - 11, средняя оценка - 4.91
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 4
1

Cisco 891 Не могу настроить два канала ISP

02.12.2013, 11:42. Просмотров 1906. Ответов 8
Метки нет (Все метки)

Здравствуйте!
Купили Cisco 891, пытался настроить самостоятельно. К слову, оборудование Cisco держу в руках первый раз.

Суть проблемы такова:
Есть два канала от провайдера, один подключаю в FastEthernet8, другой в GigabitEthernet0. Как мне показалось, с моей конфигурацией работают оба канала одновременно. Если отключаю кабель из FastEthernet8, то все идет через GigabitEthernet0. Но вот если отключить GigabitEthernet0, то всё сразу падает, ничего не пингуется. Но если роверять соединение в Cisco Configuration Professional, показывает, что соединение успешно проверено.

Ниже моя конфигурация. Подскажите пожалуйста, что мне надо дописать, чтобы оба порта работали одновременно и при падении одного из каналов, весь траффик шел через порт, на котором есть живое соедниение.

конфиг
no aaa new-model

ip name-server DNS1 ISP1
ip name-server DNS2 ISP1
ip name-server DNS1 ISP2
ip name-server DNS2 ISP2

ip cef
no ipv6 cef

multilink bundle-name authenticated

interface FastEthernet8
description $ETH-WAN$
ip address xxx.xxx.xxx.xxx 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0
description $ETH-WAN$
ip address yyy.yyy.yyy.yyy 255.255.255.224
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async1
no ip address
encapsulation slip
!
ip http server
ip http authentication local
ip http secure-server
ip forward-protocol nd
!
!
ip nat inside source list 1 interface GigabitEthernet0 overload
ip nat inside source list 2 interface FastEthernet8 overload
ip route 0.0.0.0 0.0.0.0 GATE ISP1
ip route 0.0.0.0 0.0.0.0 GATE ISP2
!
ip sla auto discovery
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 remark CCP_ACL Category=2
access-list 2 remark INSIDE_IF=Vlan1
access-list 2 permit 192.168.0.0 0.0.0.255
!
!
!
control-plane
!
!
!
!
mgcp profile default
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
02.12.2013, 11:42
Ответы с готовыми решениями:

Два канала ISP на cisco 891
проблема немного странная, первый раз держу Cisco 891-k9 в руках мне нужно настроить 2 ISP...

Cisco 891 и WAN интерфейсы
Добрый день! Столкнулся с проблемой. Есть маршрутизатор Cisco 891. Есть необходимость чтобы...

Cisco 891 как разобраться новичку?
Здрасте! Помогите пожалуста полному юзеру! поблема такая у меня стоит циска 891 подключена к веб...

Проблемы с сетевыми пользователями cisco 891
Добрый вечер. Ситуация следующая, прописал стандартный конфиг на cisco 891, на маршрутизаторе...

8
14 / 14 / 0
Регистрация: 18.05.2012
Сообщений: 84
02.12.2013, 12:41 2
Цитата Сообщение от fstranger Посмотреть сообщение
ip name-server DNS1 ISP1
ip name-server DNS2 ISP1
ip name-server DNS1 ISP2
ip name-server DNS2 ISP2
Проблема вероятнее всего в этом блоке... попробуйте использовать гугловские сервера ДНС для теста 8.8.8.8 8.8.4.4
0
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 4
02.12.2013, 12:43  [ТС] 3
Цитата Сообщение от Nik0L Посмотреть сообщение
Проблема вероятнее всего в этом блоке... попробуйте использовать гугловские сервера ДНС для теста 8.8.8.8 8.8.4.4
Ну тут DNS провайдеров, они заведомо рабочие.
И в принципе все работает, имена разрешаются нормально.
Проблемы начинаются, когда отключаешь канал ge0.
0
14 / 14 / 0
Регистрация: 18.05.2012
Сообщений: 84
02.12.2013, 12:44 4
Цитата Сообщение от fstranger Посмотреть сообщение
Проблемы начинаются, когда отключаешь канал ge0.
Каким образом эти проблемы проявляются, пинги на 8.8.8.8 например проходят?
0
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 4
02.12.2013, 12:47  [ТС] 5
Цитата Сообщение от Nik0L Посмотреть сообщение
Каким образом эти проблемы проявляются, пинги на 8.8.8.8 например проходят?
Пинги вообще перестают ходить куда-либо.
0
14 / 14 / 0
Регистрация: 18.05.2012
Сообщений: 84
02.12.2013, 13:00 6
Цитата Сообщение от fstranger Посмотреть сообщение
Пинги вообще перестают ходить куда-либо
Тогда еще один вопрос, с циски пинговать тоже не получается? Я имею ввиду пинги на ip адреса.
И еще это походу не весь конфиг, можно весь увидеть?
0
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 4
02.12.2013, 13:14  [ТС] 7
Цитата Сообщение от Nik0L Посмотреть сообщение
Тогда еще один вопрос, с циски пинговать тоже не получается? Я имею ввиду пинги на ip адреса.
И еще это походу не весь конфиг, можно весь увидеть?
С циски тоже не пингуется в таком случае.
Конфиг можно:

конфиг
Building configuration...

Current configuration : 3931 bytes
!
! Last configuration change at 16:59:53 UTC Thu Nov 28 2013 by user
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname CISCO
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 XNOSvqf8ow8OCa8GUCO4nkkzLJe4fzD82U6AYXfQP76
!
no aaa new-model
!
!
!
!
!
!
ip domain name MYDOMAIN
ip name-server DNS1 ISP1
ip name-server DNS2 ISP1
ip name-server DNS1 ISP2
ip name-server DNS2 ISP2
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
username user privilege 15 password 0 mypassword
!
redundancy
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
no ip address
!
interface FastEthernet5
no ip address
!
interface FastEthernet6
no ip address
!
interface FastEthernet7
no ip address
!
interface FastEthernet8
description $ETH-WAN$
ip address xxx.xxx.xxx.xxx 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0
description $ETH-WAN$
ip address yyy.yyy.yyy.yyy 255.255.255.224
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async1
no ip address
encapsulation slip
!
ip http server
ip http authentication local
ip http secure-server
ip forward-protocol nd
!
!
ip nat inside source list 1 interface GigabitEthernet0 overload
ip nat inside source list 2 interface FastEthernet8 overload
ip route 0.0.0.0 0.0.0.0 GATE ISP1
ip route 0.0.0.0 0.0.0.0 GATE ISP2
!
ip sla auto discovery
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 remark CCP_ACL Category=2
access-list 2 remark INSIDE_IF=Vlan1
access-list 2 permit 192.168.0.0 0.0.0.255
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
!
line con 0
password mypassword
login
line 1
modem InOut
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
login local
transport input telnet ssh
line vty 5 15
login local
transport input all
!
!
end
0
14 / 14 / 0
Регистрация: 18.05.2012
Сообщений: 84
02.12.2013, 14:03 8
Цитата Сообщение от fstranger Посмотреть сообщение
ip route 0.0.0.0 0.0.0.0 GATE ISP1
ip route 0.0.0.0 0.0.0.0 GATE ISP2
Все понял, проблема в этих строках. Потому что ISP меняется, а маршрут остается старый!
Копай в этом направлении.
1
237 / 232 / 8
Регистрация: 05.05.2011
Сообщений: 1,553
02.12.2013, 16:10 9
Я уверен, что после прочтения этой статьи у вас все разрешится.
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
02.12.2013, 16:10

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

CISCO 891 и скорость интернета ниже предоставляемой
Уважаемые форумчане! Будте любезны подсказать начинающему пользователю 891-К9 циски. Имеется сие...

Не могу настроить Cisco 857w
Может кто поможет с настройкой Cisco 857w? Проблема в том что когда захожу в SDM Express все...

не могу настроить cisco 2901
Здавствуйте , прислали мне оборудование cisco... вот особых знаний не знаю, прошу помочь , вот...

Не могу настроить Cisco Packet tracer
очень нужно настроить маршрутизацию, сам не могу, потому что пролежал в больнице когда проходили...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.