Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.86/56: Рейтинг темы: голосов - 56, средняя оценка - 4.86
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
1

Маршрутизация между VLAN на коммутаторе L3

25.08.2015, 10:12. Просмотров 10673. Ответов 59
Метки нет (Все метки)

Добрый день! Появилась задача создать VLANы в сетке, ядром будет являться коммутатор L3.

В тестовой модели создал VLANы на коммутаторе L3:
VLAN1: 10.130.4.2/24
VLAN2: 10.130.5.2/24
VLAN3: 192.168.210.2/24

ip routing включен
с хоста 192.168.210.1/24 успешно работает пинг до хоста 10.130.5.1/24
(на хостах прописаны шлюзы соответствующих им vlan)

для выхода наружу предполагается использовать маршрутизатор, на интерфейсе которого задан адрес 10.130.4.1/24, этот интерфейс подключен в коммутатор L3 через access-port (vlan 1 - по умолчанию). На маршрутизаторе кроме ip адреса интерфейса более ничего не настроено (и не предполагается т.к. к его конфигурированию нет доступа).

При запуске пинга с коммутатора до маршрутизатора 10.130.4.1 пинги есть,
При запуске пинга любого из хостов маршрутизатор 10.130.4.1 не доступен.


Я думал, что задав на коммутаторе vlan'y 1 ip адрес 10.130.4.2/24, маршрутизация будет работать и будет доступ до 10.130.4.1/24 с любого из хостов.. Но...! Видимо я чего-то не понимаю.

Маршрутизация между VLAN на коммутаторе L3




mynetwork.zip
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
25.08.2015, 10:12
Ответы с готовыми решениями:

Маршрутизация между Vlan и статическая маршрутизация
Не могу понять, в чем проблема, пакет даже на роутер не приходит. В чем причина?

Маршрутизация между Vlan
Прочитал много тем про Vlan, но до сих пор не могу разобраться в чем дело. Помогите решить вот...

Маршрутизация между VLAN на свиче
Ситуация такая: Хочу создать два разных виртуальных сетей в сети 192.168.0.0./24. Первый корпус...

Cisco 881: маршрутизация между Vlan
Всем доброго времени суток! есть cisco 881. провайдер подключен к порту Fa4, настроен nat есть...

59
Эксперт по компьютерным сетям
3835 / 2638 / 822
Регистрация: 03.11.2009
Сообщений: 8,307
Записей в блоге: 3
25.08.2015, 10:22 2
Вы не понимаете, что роутер не может сам знать о сетях 192.168.210.0/24 и 10.130.5.0/24, ему нужно или сказать, где они или поднять между ним и L3 свитчом динамику.

вариант 1:

Код
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip route 192.168.210.0 255.255.255.0 10.130.4.2
Router(config)#ip route 10.130.5.0 255.255.255.0 10.130.4.2
Router(config)#
идею вы поняли, думаю с динамикой тоже не должно быть проблем.
1
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
06.11.2015, 10:14  [ТС] 3
Добрый день! Продолжаю изучение VLAN'ов и построение тестовой модели, к сожалению снова возникла небольшая трудность.

Сейчас существует сеть 10.130.4.0 /22.

Шлюзом у всех хостов является маршрутизатор 2911 (10.130.4.1), через который осуществляется соединение с другими филиалами (MSK NETWORK сеть 10.252.0.0) и выход в интернет.
На прилагаемой картинке хосты у которых прописан этот шлюз old 6.98 /22 и oldGTWtestBase (6.99/22). Друг друга видят, выход в MSK NETWORK и интернет работает.

Новый планируемый шлюз Cisco 3750, на нём прописаны VLAN:
VLAN1 (10.130.4.11 /25)
VLAN4 (10.130.4.131 /25)
VLAN5 (10.130.5.1 /24)
VLAN6 (10.130.6.1 /23)
Прописаны маршруты во вне, через 10.130.4.1 (2911SPB)

Хосты RSP1 (6.28) и RSP2 (6.29) во VLAN 6, шлюз 10.130.6.1 (CISCO3750)
Хосты OK1 (5.10) и OK2 (5.11), во VLAN 5, шлюз 10.130.5.1 (CISCO3750)

На CISCO3750 включен ip routing, RSP1 видит OK1, всё в порядке. Все хосты находящиеся во VLAN имеют доступ к MSK NETWORK и интернет.



Имеется одна загвоздка.
Хосты old 6.98 /22 и oldGTWtestBase (6.99/22), у которых шлюз 10.130.4.1
не видят остальные хосты, у которых шлюзы 10.130.6.1 (CISCO3750) и 10.130.5.1 (CISCO3750).

Пытаюсь решить данную задачу, так как одномоментный перевод всех хостов со шлюза 10.130.4.1 на новые шлюзы VLAN не получится, нужно время.
0
Миниатюры
Маршрутизация между VLAN на коммутаторе L3  
Вложения
Тип файла: zip myvlan.zip (23.3 Кб, 13 просмотров)
845 / 295 / 39
Регистрация: 16.05.2014
Сообщений: 2,293
06.11.2015, 21:23 4
Цитата Сообщение от BigBanks Посмотреть сообщение
Хосты old 6.98 /22 и oldGTWtestBase (6.99/22), у которых шлюз 10.130.4.1
Что такое 6.98/22? Полный адрес какой?
1
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
06.11.2015, 23:15  [ТС] 5
Адреса 10.130.6.98 и 10.130.6.99 соответственно.
Да и любые другие компы с ip из диапазона 10.130.4.0 / 22 и шлюзом 10.130.4.1 (2911 SPB), не видят никого из тех, у которых шлюзом является CISCO3750.
0
845 / 295 / 39
Регистрация: 16.05.2014
Сообщений: 2,293
07.11.2015, 21:56 6
Судя по схеме у вас пересечение адресного пространства, потому и не видят.
1
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
07.11.2015, 22:27  [ТС] 7
xeonz, благодарю за ответ.
Да у хостов которыe во VLAN'ax, на шлюзе 3750 диапазон адресов фактически из сети 10.130.4.0 /22
и у хостов которые на шлюзе 2911SPB, адреса из того же самого диапазона 10.130.4.0 /22.
настроить их совместную работу никак не получится?


хорошо, тогда возник еще вопрос, дабы решить задачку.

если я переведу все хосты на шлюз CISCO 3750, есть ли возможность чтобы запросы во вне (интернет, московский филиал) от определенных хостов адресовались на шлюз 2911 SPB, а от других хостов запросы во вне шли на другой шлюз (на этой схеме он не отображен).

например
запросы с адресов 10.130.5.0 /24 , идут на шлюз 2911 SPB
запросы с адресов 10.130.4.128 /25 идут на воображаемый пока шлюз SPB2
или из VLAN 1.... на 2911 SPB из VLAN 4..... на шлюз SPB2


можно ли это реализовать на cisco, и какими методами?
буду благодарен за любую наводку.
0
845 / 295 / 39
Регистрация: 16.05.2014
Сообщений: 2,293
08.11.2015, 11:26 8
Цитата Сообщение от BigBanks Посмотреть сообщение
настроить их совместную работу никак не получится?
Представьте что у вас в телефонной сети есть три аппарата с одинаковыми номерами. И вы спрашиваете, как позвонить с одного на другой? Это неверное проектирование сети. И надо сразу задаваться вопросом - как избавится от дублирования адресов/сетей.

В редких случаях при объединении сетей, такие ситуации не удается разрулить изменением сетевых адресов. Тогда городят сложные схемы с трансляцией адресов. Но это сильно усложняет сеть и понимание, сложности настройки и поддержки. В общем такого всячески избегают.

Добавлено через 2 минуты
Цитата Сообщение от BigBanks Посмотреть сообщение
если я переведу все хосты на шлюз CISCO 3750, есть ли возможность чтобы запросы во вне (интернет, московский филиал) от определенных хостов адресовались на шлюз 2911 SPB, а от других хостов запросы во вне шли на другой шлюз (на этой схеме он не отображен).
Абстрактно есть. Это называется policy based routing, или маршрутизация по источнику. Роутеры циско это точно умеют. Насчет коммутаторов L3 типа 3750 - я точно не помню, нужно смотреть.
1
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
13.11.2015, 10:59  [ТС] 9
Абстрактно есть. Это называется policy based routing, или маршрутизация по источнику. Роутеры циско это точно умеют. Насчет коммутаторов L3 типа 3750 - я точно не помню, нужно смотреть.
Спасибо, прочитал про эту интересную технологию. Посмотрел, на коммутаторе 3750 данная возможность есть, но требуется обновление прошивки устройства. Прошивать не буду, так как нет подменного аппарата на случай проблем.

Поразмыслив, решил ограничиться обычными маршрутами.



Возник очередной вопрос, на этот раз по шлюзам VLAN. Топология сети практически та же.

Ядро Cisco 3750, прописаны:

VLAN1 (10.130.4.11/25)
VLAN4 (10.130.4.131/25)
VLAN5 (10.130.5.1/24)
VLAN6 (10.130.6.1/23)

и включен ip routing

Имеется комп 10.130.5.10/24, который принадлежит к VLAN 5
в качестве шлюза для этого компьютера задан адрес 10.130.5.1, всё работает, выход в другие сети есть.
при изменении адреса шлюза на 10.130.4.11 или 10.130.6.1 - чудеса, всё по прежнему работает.

вопрос - почему оно работает?
можно ли всем компам из разных VLAN (1, 4, 5, 6) в этом случае задать один шлюз, например 10.130.4.11.
будет ли это правильным решением? какие могут быть проблемы?
0
457 / 438 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
13.11.2015, 11:03 10
Цитата Сообщение от BigBanks Посмотреть сообщение
чудеса, всё по прежнему работает
чудес не бывает, смотрите внимательнее
0
845 / 295 / 39
Регистрация: 16.05.2014
Сообщений: 2,293
13.11.2015, 11:09 11
Цитата Сообщение от BigBanks Посмотреть сообщение
в качестве шлюза для этого компьютера задан адрес 10.130.5.1, всё работает, выход в другие сети есть.
при изменении адреса шлюза на 10.130.4.11 или 10.130.6.1 - чудеса, всё по прежнему работает.
А у вас винда не ругается при этом? Когда такой шлюз задаете?
0
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
13.11.2015, 11:19  [ТС] 12
Код
А у вас винда не ругается при этом? Когда такой шлюз задаете?
вся работа пока ведётся в Packet Tracer

Винда будет ругаться если шлюз не входит в диапазон заданный маской хоста /24
А если мы её "обманем", и поставим маску хоста /22...
0
845 / 295 / 39
Регистрация: 16.05.2014
Сообщений: 2,293
13.11.2015, 11:30 13
Цитата Сообщение от BigBanks Посмотреть сообщение
А если мы её "обманем", и поставим маску хоста /22...
Вот этот момент и не понятен, что на хосте сконфигурировано.

Добавлено через 2 минуты
Собственно если на хосте расширена маска, то дальше включается в дело функционал proxy-arp. По умолчанию он включен, поэтому расширение маски и приводит к тому, что все работает. Его можно выключить и тогда работать перестанет.
1
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
13.11.2015, 11:31  [ТС] 14
Для наглядности прикладываю скрин.

Хост 10.130.5.10 /24 во VLAN 5, шлюз назначен 10.130.6.1

На скрине трасировка до 10.252.0.11 и маршрут показывает что пошел через 10.130.5.1
0
Миниатюры
Маршрутизация между VLAN на коммутаторе L3  
457 / 438 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
13.11.2015, 11:55 15
никогда не сравнивайте пакет трасер с работой реальной сети
1
845 / 295 / 39
Регистрация: 16.05.2014
Сообщений: 2,293
13.11.2015, 12:00 16
Цитата Сообщение от BigBanks Посмотреть сообщение
На скрине трасировка до 10.252.0.11 и маршрут показывает что пошел через 10.130.5.1
Работа трейсрут - это отдельная тема. В нем светятся адреса, с которых вам был отправлен ответ, а не те, на которые пакет пришел.

Дайте команду no ip proxy-arp на vlan5 и посмотрите на результат.
1
0 / 0 / 0
Регистрация: 15.12.2012
Сообщений: 13
13.11.2015, 12:43  [ТС] 17
Дайте команду no ip proxy-arp на vlan5 и посмотрите на результат.
Ситуация не изменилась.

В понедельник попробую тоже самое на живом оборудовании .
0
0 / 0 / 0
Регистрация: 28.07.2017
Сообщений: 21
28.07.2017, 16:01 18
Доброго дня, знатоки. Возможно я покажусь безголовым и криворуким, но уже доведен до состояния отчаяния.
Есть у меня 3 каталиста C3750G, соединены в стек. Прошивка последняя 15-я сервисная. У меня есть сеть на 100 машин, её нужно поделить на 3 влана. В пакет-трейсере сделал всю схему, работает...Машинки вланов видят друг друга, пинги бегают. Соответственно всё это после #ip routing.

Взял свой реальный стек, врубил в него 2 машины, они соответственно в нативном Vlan1.
Телнечусь, Создаю 2 Vlan:

Switch(config)#vlan 50
Switch(config-vlan)#name 50
Switch(config-vlan)#exit
Switch(config)#vlan 40
Switch(config-vlan)#name 40
Switch(config-vlan)#exit

Далее назначаю машинкам настройки сети:

1. 192.168.50.2
255.255.255.0
192.168.50.1

Вешаю на порт Gi1/0/8
На С3750 отрабатываю код:
Switch(config)#int Fa0/8
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 40
Switch(config-if)#no shut
Switch(config-if)#exit

2. 192.168.40.2
255.255.255.0
192.168.40.1
На С3750 отрабатываю код:
Switch(config)#int Fa0/7
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 50
Switch(config-if)#no shut
Switch(config-if)#exit

Назначаю адреса SVI-интерфейсам:
Switch(config)#int vlan50
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan50, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan50, changed state to up
Switch(config-if)#ip address 192.168.50.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#int vlan40
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan40, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up
Switch(config-if)#ip address 192.168.40.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#exit

Маршрутизация между VLAN на коммутаторе L3


При такой настройке и конфигурации в пакет-трейсере обе машины друг друга видят и пингуют.
При такой же конфигурации на реальном С3750 каждый хост в вилане пингует SVI свой (как осн.шлюз) и соседнего вилана,но хост в соседнем вилане не пигуется. Т.е. вроде как маршрутизация и работает, но как-то не до конца. У меня конечная цель - имея несколько виланов дать возможность отдельным компьютерам и разныз подсетей видеть друг друга. От этого я, увы, уйти не смогу, т.к. моя плоская сеть уже настойко укоренилась, что ломать сложнее, чем сделать правила маршрутизации. Чуть ниже я приведу конфиг.Максимально его укомпактил как мог, сократив лишь количество неиспользуемых портов.
Гуру, прошу вашей помощи в совете что я сделал не так или не сделал? Я пытался создавать правила ACL,вешал их уже как угодно в разных вариациях на 4 возможных варианта (как на оба порта, так и на оба SVI)...Видать я жёстко туплю. Прошу помощи.
Конфиг:
Cisco3#show configuration
Using 4389 out of 524288 bytes
!
! Last configuration change at 17:46:40 EET Fri Mar 5 1993
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname NDCisco3
!
boot-start-marker
boot-end-marker
!
enable secret 5
enable password 0000000000
!
no aaa new-model
clock timezone EET 2 0
switch 1 provision ws-c3750g-24ts-1u
switch 2 provision ws-c3750g-24ts-1u
switch 3 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip routing
!
crypto pki trustpoint TP-self-signed-
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-
revocation-check none
rsakeypair TP-self-signed-
!
crypto pki certificate chain TP-self-signed-
certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/1
interface GigabitEthernet1/0/2
interface GigabitEthernet1/0/3
interface GigabitEthernet1/0/4
interface GigabitEthernet1/0/5
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
no switchport
no ip address
!
interface GigabitEthernet1/0/8
no switchport
no ip address
!
interface GigabitEthernet1/0/9
interface GigabitEthernet1/0/10
interface GigabitEthernet1/0/11
interface GigabitEthernet1/0/12
interface GigabitEthernet1/0/13
interface GigabitEthernet1/0/14

interface GigabitEthernet1/0/15
switchport mode access

interface GigabitEthernet1/0/16
...........куча незадействованных портов.............
interface GigabitEthernet3/0/28

interface Vlan1
ip address 192.168.112.12 255.255.255.0
!
interface Vlan40
ip address 192.168.40.1 255.255.255.0
!
interface Vlan50
ip address 192.168.50.1 255.255.255.0
!
ip http server
ip http secure-server
!
line con 0
password 00000000000
login
line vty 0 4
password 0000000
login
line vty 5 15
password 000000000
login
!
end
0
457 / 438 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
28.07.2017, 16:13 19
с компьютеров шлюзы пингуются ?
0
0 / 0 / 0
Регистрация: 28.07.2017
Сообщений: 21
28.07.2017, 16:37 20
Да, конечно. Машина с ипом 192.168.50.2 пингует свой гейт 192.168.50.1 и SVI vlan40 с адресом 192.168.40.1....а вот хост за ним в самом vlan 40, который с адресом 192.168.40.2 нет...по ICMP он не виден. Вайршарк я ставил, но я ни бум-бум в нём..мне информация в телах пакетов ничего толком не сказала. Я так понимаю, что так и должно быть, чтобы одна подсеть не видела другую. Если так, то как мне сделать так, чтобы только эти две машины могли видеть друг друга, а остальные члены подсетей были в тени?
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
28.07.2017, 16:37

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Packet Tracer Маршрутизация Между VLAN
Доброго всем времени суток! Вот уже который час мучаюсь с такой проблемой: Имеется, вот такая...

Маршрутизация между VLAN Cisco 1811
Здравствуйте Прошу помощи в настройке маршрутизации между VLAN на Cisco 1811. При такой настройке...

Не работает маршрутизация между VLAN (Packet Tracer)
Добрый день, не работает маршрутизация между VLAN. TRUNK порты настроены на коммутаторах и с ними...

CPT: маршрутизация между VLAN с разными подсетками
Всем привет. Вопросы такие: 1. Как разрешить доступ PC0 к PC4, если они находятся в разных...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.