Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.52/25: Рейтинг темы: голосов - 25, средняя оценка - 4.52
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
1

Не могу настроить маршрутизатор

23.03.2016, 21:18. Показов 5160. Ответов 21
Метки нет (Все метки)

Один раз настроил, повторить не смог(

Есть 2 роутера:

R1 через f0/1 смотрит в интернет, получая адрес по DHCP (192.168.1.115)
через f0/0 подключен R2, выполняющий роль клиента для опытов, соответственно, адрес тоже получает с DHCP
проблема в том R2 адрес по DHCP получает, что пинги наружу с R2 через R1 не проходят(

Код
version 15.1
    
!         
ip dhcp pool MYPOOL
 network 10.0.0.0 255.255.255.0
 default-router 192.168.1.115 


interface FastEthernet0/0
 description LAN
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 description WAN
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!         
interface FastEthernet0/3/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
ip forward-protocol nd
no ip http server
no ip http secure-server
!         
!         
ip nat inside source list 1 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!         
access-list 1 permit 10.0.0.0 0.0.0.255
R1

Код
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, FastEthernet0/1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, FastEthernet0/0
L        10.0.0.1/32 is directly connected, FastEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/1
L        192.168.1.115/32 is directly connected, FastEthernet0/1
R2

Код
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, FastEthernet0/1
L        10.0.0.2/32 is directly connected, FastEthernet0/1
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
23.03.2016, 21:18
Ответы с готовыми решениями:

Cisco isb7031 нужно настроить маршрутизатор или windows 7
Оператор - билайн. Локальная сеть - 10.20.*.* Подключение к сети билайн напрямую компьютером. ...

Не могу настроить маршрутизатор!
Вообщем дело обстоит так: Раньше у меня стоял ADSL маршрутизатор,который был настроен провайдером....

Не могу настроить маршрутизатор! Посопутствуйте пожалуйста
Маршрутизатор asus rt n11p Вот что дал провайдер.

Не могу настроить маршрутизатор для работы с Filezilla
Здраствуйте! Никак не могу настроить свой маршрутизатор для работы с программой Filezilla. Все...

__________________

Записывайтесь на профессиональные курсы DevOps-инженеров
21
[Удалено]
97 / 94 / 11
Регистрация: 12.02.2013
Сообщений: 718
24.03.2016, 07:10 2
Можешь приложить схему сетки ?
Делаешь на реальном железе или в эмуляторах ?
1
Эксперт по компьютерным сетям
8509 / 5722 / 1418
Регистрация: 25.12.2012
Сообщений: 24,210
24.03.2016, 08:05 3
Цитата Сообщение от Fluder_asdasd Посмотреть сообщение
Можешь приложить схему сетки ?
Делаешь на реальном железе или в эмуляторах ?
и если в эмуляторах, то файл проекта еще
0
4 / 4 / 1
Регистрация: 07.05.2014
Сообщений: 19
24.03.2016, 10:30 4
На R1 нужно еще строку "ip nat pool" добавить. Без нее он не знает через какие адреса натить следует.
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
24.03.2016, 14:07  [ТС] 5
На R1 нужно еще строку "ip nat pool" добавить. Без нее он не знает через какие адреса натить следует.
Так вместо ip nat pool вроде как вожно указать интерфейс? Но в любом случае, с пулом тоже не работает.

Добавлено через 2 минуты
Цитата Сообщение от Fluder_asdasd Посмотреть сообщение
Можешь приложить схему сетки ?
Делаешь на реальном железе или в эмуляторах ?
На реальном железе, это две 2801.

Схему сейчас накидаю.
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
24.03.2016, 14:22  [ТС] 6
Схема
0
Миниатюры
Не могу настроить маршрутизатор  
459 / 440 / 75
Регистрация: 26.12.2012
Сообщений: 2,881
24.03.2016, 14:24 7
Цитата Сообщение от vkeyster Посмотреть сообщение
ip dhcp pool MYPOOL network 10.0.0.0 255.255.255.0 default-router 192.168.1.115
как так раздаете пул 10.0.0.0 255.255.255.0 а default-router 192.168.1.115 из другой сетки получается
0
4 / 4 / 1
Регистрация: 07.05.2014
Сообщений: 19
24.03.2016, 14:54 8
Цитата Сообщение от corlovito Посмотреть сообщение
как так раздаете пул 10.0.0.0 255.255.255.0 а default-router 192.168.1.115 из другой сетки получается
И правда, дефолт-то надо ставить тот что на инсайд интерфейсе, а не тот что на внешнем.
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
24.03.2016, 17:40  [ТС] 9
Сделал, как посоветовали:

Bash
1
2
3
ip dhcp pool MYPOOL
 network 10.0.0.0 255.255.255.0
 default-router 10.0.0.1
Bash
1
2
ip nat pool MYPOOL 192.168.1.115 192.168.1.115 netmask 255.255.255.0
ip nat inside source list 1 pool MYPOOL overload
не помогло(
0
459 / 440 / 75
Регистрация: 26.12.2012
Сообщений: 2,881
24.03.2016, 18:55 10
выкладывайте оба конфига полностью
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
24.03.2016, 19:19  [ТС] 11
R1

Bash
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
Current configuration : 1329 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
!
!
ip dhcp pool MYPOOL
 network 10.0.0.0 255.255.255.0
 default-router 10.0.0.1 
!         
!         
ip cef    
no ipv6 cef
!         
multilink bundle-name authenticated
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
voice-card 0
!         
crypto pki token default removal timeout 0
!         
!         
!         
!         
license udi pid CISCO2801 sn FCZ1402919H
!         
redundancy
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface FastEthernet0/0
 description LAN
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 description WAN
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!         
interface FastEthernet0/3/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
ip forward-protocol nd
no ip http server
no ip http secure-server
!         
!         
ip nat pool MYPOOL 192.168.1.115 192.168.1.115 netmask 255.255.255.0
ip nat inside source list 1 pool MYPOOL overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!         
access-list 1 permit 10.0.0.0 0.0.0.255
!         
!         
!         
!         
!         
!         
control-plane
!         
!         
!         
!         
mgcp profile default
!         
!         
!         
!         
!         
!         
line con 0
line aux 0
line vty 0 4
 login    
 transport input all
!         
scheduler allocate 20000 1000
end
Добавлено через 6 минут
R2

Bash
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
Current configuration : 923 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
!
!
!         
ip cef    
no ipv6 cef
!         
multilink bundle-name authenticated
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
voice-card 0
!         
crypto pki token default removal timeout 0
!         
!         
!         
!         
license udi pid CISCO2801 sn FCZ1402919G
!         
redundancy
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface FastEthernet0/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!         
interface FastEthernet0/3/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
ip forward-protocol nd
no ip http server
no ip http secure-server
!         
!         
!         
!         
!         
!         
!         
!         
!         
control-plane
!         
!         
!         
!         
mgcp profile default
!         
!         
!         
!         
!         
!         
line con 0
line aux 0
line vty 0 4
 login    
 transport input all
!         
scheduler allocate 20000 1000
end
0
459 / 440 / 75
Регистрация: 26.12.2012
Сообщений: 2,881
24.03.2016, 19:53 12
1. вот эта строчка для чего ?
Цитата Сообщение от vkeyster Посмотреть сообщение
ip nat pool MYPOOL 192.168.1.115 192.168.1.115 netmask 255.255.255.0
2. первый роутер в инет напрямую выходит или у него реально на wan интерфейсе локальная сеть ? и там еще какой то шлюз...

3. покажите
Код
sh ip route
со второго роутера
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
24.03.2016, 20:03  [ТС] 13
1. Диапазон внешних IP адресов, на которые перебиваются адреса из внутренней сети.
2. На WAN интерфейсе локальная сеть, и там еще какой-то шлюз
3.

Bash
1
2
3
4
5
6
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
 
S*    0.0.0.0/0 [254/0] via 10.0.0.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, FastEthernet0/1
L        10.0.0.2/32 is directly connected, FastEthernet0/1
только что заметил, что R2 при загрузке пишет

Default route without gateway, if not a point-to-point interface, may impact performance
0
459 / 440 / 75
Регистрация: 26.12.2012
Сообщений: 2,881
24.03.2016, 20:18 14
Цитата Сообщение от vkeyster Посмотреть сообщение
Default route without gateway
добавьте маршрут по умолчанию вручную
Цитата Сообщение от vkeyster Посмотреть сообщение
На WAN интерфейсе локальная сеть, и там еще какой-то шлюз
тогда вообще уберите нат на первом роутере он там ни к чему
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
24.03.2016, 20:26  [ТС] 15
Да я понимаю, что NAT ни к чему, пытаюсь сымитировать интернет, в субботу это нужно уже в реальном офисе запускать.

Маршрут по-умолчанию добавил.
0
459 / 440 / 75
Регистрация: 26.12.2012
Сообщений: 2,881
24.03.2016, 20:47 16
ок теперь покажите с компа за вторым роутером это
Код
ipconfig /all
route print
ping ya.ru
ping 8.8.8.8
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
24.03.2016, 20:53  [ТС] 17
Да нет за вторым роутером компа) Я пытаюсь настроить первый роутер под своего провайдера в офисе, т.е. получить настройки от провайдера по DHCP на f0/1, и с f0/0 раздать это дело на коммутатор и по хостам.
Второй роутер использую просто как хост, т.е. получили настройки по DHCP с первого роутера, и можем попингать, чтобы убедиться, как все работает.
0
459 / 440 / 75
Регистрация: 26.12.2012
Сообщений: 2,881
24.03.2016, 21:19 18
ну тогда со 2-го роутера
Код
sh ip int br
ping 10.0.0.1 
ping 8.8.8.8
с первого
Код
sh ip route
sh ip int br
ping 8.8.8.8
traceroute 8.8.8.8
0
0 / 0 / 0
Регистрация: 26.01.2016
Сообщений: 22
25.03.2016, 04:08  [ТС] 19
R2

Bash
1
2
3
4
5
R2#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
FastEthernet0/1            10.0.0.2        YES DHCP   up                    up
FastEthernet0/3/0          unassigned      YES NVRAM  administratively down down
Bash
1
2
3
4
5
R2#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
Bash
1
2
3
4
5
R2#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1

Bash
1
2
3
4
5
6
R1#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.0.0.1        YES NVRAM  up                    up      
FastEthernet0/1            192.168.1.109   YES DHCP   up                    up      
FastEthernet0/3/0          unassigned      YES NVRAM  administratively down down    
NVI0                       10.0.0.1        YES unset  up                    up
Bash
1
2
3
4
5
R1#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Bash
1
2
3
4
5
R1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Кстати R1 при загрузке тоже пишет

Bash
1
Default route without gateway, if not a point-to-point interface, may impact performance
Хотя маршрут по-умолчанию добавлен.
0
459 / 440 / 75
Регистрация: 26.12.2012
Сообщений: 2,881
25.03.2016, 08:29 20
ну дак у вас и на первом нет интернета, с этим надо в начале разбираться

Добавлено через 1 минуту
Цитата Сообщение от vkeyster Посмотреть сообщение
Кстати R1 при загрузке тоже пишет
укажите маршрут не через интерфейс а через адрес
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
25.03.2016, 08:29

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Не получается настроить маршрутизатор на модеме.
В общем, в чем проблема. Есть модем Acorp Sprinter@ADSL LAN410, там 4 порта LAN.Первый компьютер...

Нужно настроить маршрутизатор, чтобы РАВНОМЕРНО распределял интернет
Структуру сети прилагаю. Проблема в том, что у меня интернет(3мб/с.) раздается на 17 пк и у кого...

Настроить маршрутизатор, чтобы один из ПК был во внешней сети
Необходимо маршрутизатор Acorp WR-150N, чтобы один из ПК был во внешней сети. Какие настройки и где...

Как настроить маршрутизатор ZyXEL Keenetic Start Интернет-центр по MAC?
Купили роутер ZyXEL Keenetic Start Интернет-центр и сами пытались настроить. нужно поключить...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.