Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
0 / 0 / 0
Регистрация: 18.07.2019
Сообщений: 2
1

Проброс портов

19.07.2019, 00:14. Просмотров 892. Ответов 6

Сетевики , нужна ваша помощь ! Я пробросил 80 порт для http сервера , когда tcp пакет проходит второй раз через маршрутизатор, на котором прописаны статические маршруты nat - то есть возвращается обратно на компьютер - DA порта становится нулевым - и пакет умирает на компе , с которого он был отправлен --> соединение не устанавливается ! Как исправить такую ситуацию? В чём ошибка ? Можете подсказать? Буду очень признателен ! !!!
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
19.07.2019, 00:14
Ответы с готовыми решениями:

проброс портов
Делаю на роутере проброс портов настроил но не могу довести до ума, запросы идут в одну сторону....

Проброс портов
Здравствуйте. Подскажите, что не так я сделал. Хочу вывести radmin наружу, соединения нет. Киску...

Проброс портов cisco
Доброго времени суток, проброшен 80 порт в локалку Доступ из мира есть, но звери из локалки не...

Проброс портов до сервера
Сеажите пожалуйста. А без подключения к консоли и танцев с бубнами никак не настроить виртуальный...

6
61 / 46 / 22
Регистрация: 30.09.2017
Сообщений: 153
19.07.2019, 15:52 2
на примере файла и cisco packet было проще найти проблему, а так можно долго гадать...
0
0 / 0 / 0
Регистрация: 18.07.2019
Сообщений: 2
19.07.2019, 16:02  [ТС] 3
К сожалению, файл по какой то причине не загружается на форум! Вот конфигурации роутера - подсеть 30 - та, где находится сервер + 192.168.30.4 - ip адрес сервера ! --------------------------------------------------------------------------------------------------------------------------------------------------------Current configuration : 1119 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.20.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.30.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.40.2 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.20.0
network 192.168.30.0
network 192.168.40.0
auto-summary
!
ip nat inside source static 192.168.20.2 192.168.40.2
ip nat inside source static 192.168.20.3 192.168.40.2
ip nat inside source static 192.168.30.3 192.168.40.2
ip nat inside source static 192.168.30.2 192.168.40.2
ip nat inside source static tcp 192.168.30.4 80 192.168.40.3 8080
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
-----------------------------------------------------------------------------------------------------------------------------------------------------
0
61 / 46 / 22
Регистрация: 30.09.2017
Сообщений: 153
19.07.2019, 22:05 4
не хватает маршрута
ip route 0.0.0.0 0.0.0.0 192.168.40.1 (ваш шлюз)

Добавлено через 15 минут
я бы nat для сетей по другому сделал

ip access-list standard nat
permit 192.168.20.0 0.0.0.255
permit 192.168.30.0 0.0.0.255

затем привязать к интерфейсу
ip nat inside source list nat interface FastEthernet1/0 overload
0
100 / 74 / 34
Регистрация: 06.11.2018
Сообщений: 376
Записей в блоге: 1
20.07.2019, 00:23 5
Бред какой-то, я не улавливаю логику. Сети внутренние маршрутизируемые, хочется чтобы пользователи обращались к циске, чтобы шлюзовать запрос к вебсерверу? А зачем?
Я так понимаю маршрутизацие занимается сосед по eigrp?

Покажите show ip route и show nat translations
0
1 / 2 / 2
Регистрация: 11.06.2019
Сообщений: 108
04.09.2019, 22:55 6
Цитата Сообщение от Robocop01 Посмотреть сообщение
не хватает маршрута
ip route 0.0.0.0 0.0.0.0 192.168.40.1 (ваш шлюз)
Но ведь если бы не было восьминулевки, пакет бы и не возвращался, он даже не пошел бы дальше роутера.. Или я что то не догоняю
0
61 / 46 / 22
Регистрация: 30.09.2017
Сообщений: 153
05.09.2019, 16:18 7
Цитата Сообщение от PavelBree Посмотреть сообщение
Но ведь если бы не было восьминулевки, пакет бы и не возвращался, он даже не пошел бы дальше роутера.. Или я что то не догоняю
Если бы автор выложил файл была бы ясна картина, а так можно только предполагать.
ip route 0.0.0.0 0.0.0.0 192.168.40.1 работает только для всех исходящих пакетов.
поскольку там в egrp указан сеть 192.168.40.0, то статику ненужно добавлять, но с другой стороны мы то не видим общую картину.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
05.09.2019, 16:18

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Проброс портов на роутере cisco
есть 3 одинаковых видео регистратора. порт интернета 80 и еще один порт на нем 2000 задача в том...

Cisco 1941. Проброс портов
Добрый день! Сразу прошу - не пинать меня сильно! Гуглил много. Итак, есть Cisco 1941 - уже...

Проброс портов PPPoE + DDNS
Здравствуйте! Несколько дней назад купил cisco 851. И сейчас мучаюсь с конфигурацией. С...

ASA5512X Проброс\маппинг портов
Здравствуйте! Ситуация слудющая. Стояла задача: открыть 80 порт и замапить его в 3389 на один...

Проброс портов на ASA 9.1(2) - Static PAT
Добрый день, тема совсем не новая, но походу без совета не разберусь. Что имеем: 1) ASA...

проброс портов для видео регистратора
как смотреть видео из интернета ? есть локальная сеть, циска. нужно что бы в браузере вбив...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.