Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
0 / 0 / 0
Регистрация: 23.07.2019
Сообщений: 4
1

Настройка cisco 871

23.07.2019, 10:28. Просмотров 640. Ответов 0
Метки нет (Все метки)

День добрый!
Попала в руки Cisco 871, но к сожалению никогда с cisco раньше не работал, погуглил, пошаманил, родил конфиг, но что-то не то, да и не всё понял!
Прошу глянуть конфиг, и вразумить, если не сложно=)
По факту нужно чтобы была раздача dhcp, доступ в интернет и впн, чтобы я из дома мог пробираться в локальную сеть предприятия!
Буду благодарен за любую помощь.

Задаём имя пользователя и пароль администратора
conf t
service password-encryption
aaa new-model
aaa authentication login default local
username admin privilege 15 secret **************

Настраиваем доступ по ssh
hostname ololo
ip domain-name ololo.ru
cryptokey generate rsa modulus 1024
ip ssh time-out 2 30
ip ssh authentication-retries 2
ip ssh version 2
line vty 0 4
transport input ssh
privilege level 15
exit


ускоренная коммутация пакетов
ip cef

устанавливаем временную зону москва GMT+3
clock timezone MSK 3
exit
clock set 12:56:00 19 Jul 2019

обновление системных часов по ntp
ntp server ntp3.stratum2.ru
ntp server ntp1.vniiftri.ru

настройка dns
ip domain-lookup
ip dns server
ip name-server (77.88.8.8)

настройка ip-адреса на портах в ВЛАН1
int vlan1
ip address 192.168.0.99 255.255.255.0
exit

Настройка ДШСП)))

настройка списка исключения выдаваемых ip-адресов
configure terminal
ip dhcp excluded-address 192.168.0.1 192.168.0.3
ip dhcp excluded-address 192.168.0.100 192.168.0.151
ip dhcp excluded-address 192.168.0.21
ip dhcp excluded-address 192.168.0.65
ip dhcp excluded-address 192.168.0.90
ip dhcp excluded-address 192.168.0.62
ip dhcp excluded-address 192.168.0.205
ip dhcp excluded-address 192.168.0.11 192.168.0.15
ip dhcp excluded-address 192.168.0.17
ip dhcp excluded-address 192.168.0.50
ip dhcp excluded-address 192.168.0.63 192.168.0.68
ip dhcp excluded-address 192.168.0.200
ip dhcp excluded-address 192.168.0.202

Настройка пула адресов ДХСП
ip dhcp pool ololo
network 192.168.0.0 255.255.255.0
defaul-router 192.168.0.99
domain-name ololo.local
dns-server 192.168.0.99 8.8.8.8
import all
end

???Пока не пойму что есть это???:
interface fa4
ip address 192.168.0.99 255.255.255.0
no shutdown
end

Поднимаем WAN interface
int fastethernet4
ip address (Ip-инет провайдера) 255.255.255.240
no shutdown
end

включаем нат на ВАН
int fastethernet4
ip nat outside
exit

включаем нат на LAN
int vlan1
ip nat inside
exit

Настраиваем лист доступа для описания правила выхода в интернет(я так понимаю что здесь прописываются адреса ПК, у которых будет доступ в интернет)
ip access-list extended NAT
permit ip 192.168.0.0 0.0.0.255 any
exit

включаем доступ в интернет
ip nat inside source list NAT interface Fastethernet4
overload

Настраиваем VPN доступ


Задействуем модель аутентификации, авторизации и учета ААА
Router(config)#
Router(config)# aaa new-model
Router(config)# aaa authentication login userauthen local
Router(config)# aaa authorization network groupauthor local


Создаем политику с приоритетом 1, которая будет использоваться при подключении клиентов, и входим в режим конфигурации ISAKMP.
Определяем группу Diffie-Hellman, указываем алгоритмы хэш-функции и шифрования, а также пул динамического назначения IP-адресов.
Router(config)#
Router(config)# crypto isakmp policy 1
Router(config-isakmp)# authentication pre-share
Router(config-isakmp)# group 2
Router(config-isakmp)# hash md5
Router(config-isakmp)# encryption 3des
Router(config)# crypto isakmp client configuration address-pool local easy-vpn-group-dynpool

Создаем групповую политику IKE, содержащую атрибуты для удаленных клиентов. Указываем имя группы (логин), пароль, первичный сервер имен, домен, пул, маску сети, дополнительно можно указать WINS-сервер. А также разрешаем клиенту работу в его локальной сети на время работы VPN-туннеля.
Router(config)#
Router(config)# crypto isakmp client configuration group groupauthor
Router(config-isakmp-group)# key **********
Router(config-isakmp-group)# dns 192.168.0.254
Router(config-isakmp-group)# domain copmany.ru
Router(config-isakmp-group)# pool easy-vpn-group-dynpool
Router(config-isakmp-group)# include-local-lan
Router(config-isakmp-group)# netmask 255.255.255.0
Router(config-isakmp-group)# acl VPN-SPLIT
Router(config-isakmp-group)#
Router(config)#

Далее определяется список выполняемых операций (transform - изменений) для установки подлинности данных, конфиденциальности и сжатия.
Router(config)#
Router(config)# crypto ipsec transform-set rtpset esp-des esp-md5-hmac
Router(config)#

Создаем динамическую криптокарту rtp с порядковым номером 100, указываем transform-set rtpset и RRI (Reverse Route injection) чтобы вешать маршруты на удаленные сети.
Router(config)#
Router(config)# crypto dynamic-map rtp 100
Router(config-crypto-map)# set transform-set rtpset
Router(config-crypto-map)# reverse-route
Router(config)#
Применяем метод поиска ключей (IKE-запросы) для установления подлинности и разрешений группы. Настраиваем маршрутизатор для ответов на запросы удаленных клиентов.
Router(config)#
Router(config)# crypto map rtp client authentication list userlist
Router(config)# crypto map rtp isakmp authorization list authgroup
Router(config)# crypto map rtp client configuration address respond
Router(config)#

Создаем профиль криптокарты:
Router(config)#
Router(config)# crypto map rtp 100 ipsec-isakmp dynamic rtp
Router(config)#

Ведение журнала подключений:
Router(config)#
Router(config)# crypto logging session
Router(config)#

Создаем пул адресов для группы VPN-клиентов:
Router(config)#
Router(config)# ip local pool easy-vpn-group-dynpool 10.10.1.2 10.10.1.5
Router(config)#

Конфигурирование сетевых интерфесов: назначаем криптокарту (включить VPN-сервер), входящий и исходящий интерфейсы для процесса трансляции сетевых адресов NAT.
Router(config)# interface FastEthernet 4
Router(config-if)# ip address (что здесь прописывать) 255.255.255.0
Router(config-if)# ip nat outside
Router(config-if)# crypto map rtp
Router(config)#

Router(config)# interface Vlan 1
Router(config-if)# ip address 192.168.0.99 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# ip tcp adjust-mss 1408
Router(config-if)#

Исключаем VPN-трафик из процесса NAT между внутренней подсетью 192.168.0.0/24 и удаленной 10.10.1.0/24 (VPN-клиенты):
Router(config)#
Router(config)# ip access-list extended NAT
Router(config-ext-nacl)# deny ip 192.168.0.0 0.0.0.255 10.10.1.0 0.0.0.255
Router(config-ext-nacl)# permit ip 192.168.0.0 0.0.0.255 any
Router(config-ext-nacl)#

Router(config)#
Router(config)# ip nat inside source list NAT interface fastethernet 4 overload
Router(config)#

Router(config)#
Router(config)# ip access-list extended VPN-SPLIT
Router(config-ext-nacl)# permit ip 192.168.0.0 0.0.0.255 any
Router(config)#

Router(config)#
Router(config)# ip route 0.0.0.0 0.0.0.0 Fastethernet 4
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
23.07.2019, 10:28
Ответы с готовыми решениями:

Настройка VPN на Cisco 871
Добрый вечер. Настроил cisco 871 роутером. Настроил VPN подключение к виндовому серверу, коннект...

Начальная настройка cisco 871
Здравствуйте. Попала мне в руки железка Cisco 871. Решил я попробовать сделать из нее роутер...

Настройка роутером cisco 871
Добрый вечер господа. Я тут решил разобраться в этой железке, и столкнулся с некоторыми...

Настройка Cisco 871-k9 ADSL как VPN клиент
Здравствуйте! С cisco столкнулся впервые, попалась в руки на халяву железка Cisco 871-k9 adsl. ...

0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
23.07.2019, 10:28

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Ищется IOS на Cisco 871
Родина в опасности! Камрады, поделитесь IOS на Cisco 871. Если можно то Latest:...

cisco 871. Разделение Vlan
На данном девайсе 1 шт. WAN и 4 порта в Vlan. Возможно ли: сделать 4 разных Vlan (FE0 это Vlan...

cisco 871 ppp подключение к прову
Доброго времени суток. В общем проблема, не поднимается канал между провайдером и циской ...

cisco 871 и поддержка Extended VLAn
Здравствуйте! Встал вопрос о создании VLAN с номером 18XX, причем при вводе стандартной команды с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.