0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
1

Не происходит ping между компьютерами из разных VLAN

23.11.2022, 18:50. Показов 296. Ответов 14

Здравствуйте, подскажите пожалуйста, почему не происходит ping между компьютерами из разных VLAN ?

show run из Router0:
Кликните здесь для просмотра всего текста
Код
Router>enable
Router#show run
Building configuration...

Current configuration : 981 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524261B-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.4.1 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.8.1 255.255.255.0
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.12.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


show run из Switch0:
Кликните здесь для просмотра всего текста
Код
Switch>enable
Switch#show run
Building configuration...

Current configuration : 1371 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface FastEthernet0/4
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end


show run из Switch1:
Кликните здесь для просмотра всего текста
Код
Switch>enable
Switch#show run
Building configuration...

Current configuration : 1347 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end


show run из Switch2:
Кликните здесь для просмотра всего текста
Код
Switch>enable
Switch#show run
Building configuration...

Current configuration : 1347 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
23.11.2022, 18:50
Ответы с готовыми решениями:

Почему не проходит ping между компьютерами расположенных в разных VLAN, соединённых маршрутизаторами?
Доброго времени суток, коллеги! Почему у меня не не пингуются одни ПК из одного Vlan 10 во Vlan 20...

Роутер Huawei AR200-s. Проходит ping между ПК, подключенных к портам разных Vlan
Здравствуйте, уважаемые эксперты. Помогите, пожалуйста, разобраться. Вопрос (проблема) в...

Соединение между компьютерами в разных локальных сетях
Всем привет! Знаю сокеты, как происходит подключение. Но все примеры, что я встречал,...

новичку. Cisco 891, пользователи в разных VLAN, пинги между ними ходят, но расшаренные папки, общие принтеры недоступны
Доброго дня, прошу подсказать. есть пользователи в разных VLAN, пинги между ними ходят, но...

14
NoNaMe
23.11.2022, 19:55
  #2
 Комментарий модератора 
Приложите схему, очень тяжело понять что, к чему подключенно.
0
0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
23.11.2022, 20:37  [ТС] 3
NoNaMe,
Миниатюры
Не происходит ping между компьютерами из разных VLAN  
0
Модератор
Эксперт по компьютерным сетям
1137 / 535 / 99
Регистрация: 10.06.2009
Сообщений: 2,131
23.11.2022, 22:29 4
А не могли-бы вы выложить проект из студии в которой строили?
0
Эксперт по компьютерным сетям
10528 / 6726 / 1789
Регистрация: 25.12.2012
Сообщений: 28,532
24.11.2022, 08:21 5
на компах и принтаках шлюзы указаны?

со свитчей покажите
Код
sh vlan
0
0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
24.11.2022, 14:15  [ТС] 6
NoNaMe,
Цитата Сообщение от NoNaMe Посмотреть сообщение
А не могли-бы вы выложить проект из студии в которой строили?
Вложения
Тип файла: rar 3.rar (57.1 Кб, 3 просмотров)
0
0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
24.11.2022, 14:21  [ТС] 7
insect_87,
Цитата Сообщение от insect_87 Посмотреть сообщение
на компах и принтаках шлюзы указаны?
Да, указаны.
Цитата Сообщение от insect_87 Посмотреть сообщение
со свитчей покажите
show vlan из Switch0:
Код
Switch>enable
Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gig0/1
                                                Gig0/2
10   VLAN0010                         active    
20   VLAN0020                         active    
30   VLAN0030                         active    Fa0/4, Fa0/5
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
show vlan из Switch1:
Код
Switch>enable
Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gig0/1
                                                Gig0/2
10   VLAN0010                         active    Fa0/2
20   VLAN0020                         active    Fa0/3, Fa0/4, Fa0/5
30   VLAN0030                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
show vlan из Switch2:
Код
Switch>enable
Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gig0/1
                                                Gig0/2
10   VLAN0010                         active    Fa0/3
20   VLAN0020                         active    Fa0/2, Fa0/4, Fa0/5
30   VLAN0030                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
0
Модератор
Эксперт по компьютерным сетям
1137 / 535 / 99
Регистрация: 10.06.2009
Сообщений: 2,131
24.11.2022, 14:42 8
Не настроена маршрутизация на Router0.
Цитата Сообщение от xsTLL Посмотреть сообщение
!
interface Vlan1
no ip address
shutdown
!
Маловато будет если на нём должны маршрутизироваться сети.

Добавлено через 2 минуты
Я опускаю ip helper-address так как не знаю кто айпишники выдаёт.
Как пример:
Код
!
interface Vlan40
 ip address 172.20.4.1 255.255.255.128
 no ip route-cache
!
0
0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
24.11.2022, 14:57  [ТС] 9
NoNaMe, то есть нужно настроить VLAN 1 ?
0
Модератор
Эксперт по компьютерным сетям
1137 / 535 / 99
Регистрация: 10.06.2009
Сообщений: 2,131
24.11.2022, 16:09 10
xsTLL, необходимо настроить вланы на маршрутизацию
0
0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
24.11.2022, 16:14  [ТС] 11
NoNaMe, то есть создать все эти же VLAN как на коммутаторах, только на маршрутизаторе?
0
Эксперт по компьютерным сетям
10528 / 6726 / 1789
Регистрация: 25.12.2012
Сообщений: 28,532
24.11.2022, 17:04 12
Цитата Сообщение от NoNaMe Посмотреть сообщение
Маловато будет если на нём должны маршрутизироваться сети.
Цитата Сообщение от xsTLL Посмотреть сообщение
то есть создать все эти же VLAN как на коммутаторах, только на маршрутизаторе?
не, не
не надо там ничего, более того и не получится это сделать, если на роутере нет свитчевого модуля

у вас саб-интерфейсы на роутере - тут все нормально

с компьютеров пинг до шлюзов идет
покажите с компа с адресом 192.168.8.Х

Код
ipconfig 
ping 192.168.8.1
ping 192.168.12.1

не открывается ваш cpt-файл в версии 8.1.1. Какая у вас версия?
1
0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
24.11.2022, 17:20  [ТС] 13
insect_87,
Цитата Сообщение от insect_87 Посмотреть сообщение
не открывается ваш cpt-файл в версии 8.1.1. Какая у вас версия?
8.2.0
Миниатюры
Не происходит ping между компьютерами из разных VLAN   Не происходит ping между компьютерами из разных VLAN  
0
Эксперт по компьютерным сетям
10528 / 6726 / 1789
Регистрация: 25.12.2012
Сообщений: 28,532
24.11.2022, 19:10 14
Лучший ответ Сообщение было отмечено xsTLL как решение

Решение

Почему у вас адрес 192.168.4.8?
А не 192.168.8.4 скажем?


С адресами напутали
1
0 / 0 / 0
Регистрация: 09.09.2022
Сообщений: 48
24.11.2022, 19:32  [ТС] 15
insect_87, Спасибо большое, сработало
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
24.11.2022, 19:32
Помогаю со студенческими работами здесь

Cisco packet tracer настройка маршрутизации между двумя виртуальными сетями Vlan 10 и Vlan 20
Доброго времени суток! Помогите решить задание. Есть небольшая сеть, в ней находятся 2 роутера....

Маршрутизация между vlan и сетью без vlan
Была у нас раньше сеть(192.168.0.0) без vlanov,предприятие расширялось и со временем пришлось...

Не проходит ping меду vlan в IPsec ISAKMP VPN
Здравствуйте коллеги! В лабораторной работе мне поставлена задача организовать IPsec ISAKMP Site to...

Не проходит ping меду vlan в IPsec ISAKMP VPN
Прошу, пожалуйста, ответьте мне в этой теме, я не знаю, что мне делать...

Клиент и сервер на разных компьютерами не соединяются
На одном компьютере клиент соединяется с сервером, но на разных компьютерах не удается установи...

Vlan на разных итерфейсах
Здравствуйте. Есть микрот на котором на eth2 успешно работает несколько vlan'ов. Нужно скажем...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru