Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.94/17: Рейтинг темы: голосов - 17, средняя оценка - 4.94
Pat123
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 10
1

Не могу поменять внешний IP

07.08.2012, 18:08. Просмотров 3292. Ответов 10
Метки нет (Все метки)

Было настроенно вот так:

R1#show startup-config
Using 3444 out of 262136 bytes
!
! Last configuration change at 16:12:14 russia Thu Mar 15 2012 by Login
! NVRAM config last updated at 17:45:24 russia Thu Mar 15 2012 by Login
! NVRAM config last updated at 17:45:24 russia Thu Mar 15 2012 by Login
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
no service dhcp
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
logging buffered 4096
enable secret 5 $1$aJQd$d18SOfNdjbYk2a1Jp5vOj1
!
aaa new-model
!
!
aaa authentication login default local enable
!
!
!
!
!
aaa session-id common
!
clock timezone russia 5 0
ip source-route
!
!
!
ip vrf internet
rd 65002:80
route-target export 65002:80
route-target import 65002:80
!
!
!
ip cef
no ip domain lookup
ip domain name MT
ip name-server vrf internet 84.254.192.5
ip name-server vrf internet 84.254.219.1
no ipv6 cef
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO891-K9 sn FCZ1540C1M2
!
!
vtp mode transparent
username admin privilege 15 password 7 15270718162B2D2D273F30365D
username Login password 7 00311F12165A0D0F002D495A47
!
!
vlan 2
name INET
!
ip ssh time-out 60
!
!
!
!
interface FastEthernet0
description downlink_LAN
switchport access vlan 2
switchport mode trunk
no ip address
!
interface FastEthernet1
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet2
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet3
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet4
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet5
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet6
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet7
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet8
description Vimpelcom
ip vrf forwarding internet
ip address 84.254.193.181 255.255.255.252
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
description LAN_MGT
ip address 10.1.25.247 255.255.255.0
ip virtual-reassembly in
!
interface Vlan2
description Inet
ip vrf forwarding internet
ip address 84.254.219.1 255.255.255.240
!
interface Async1
no ip address
encapsulation slip
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip dns view vrf internet default
ip route 10.1.25.0 255.255.255.0 10.1.25.254
ip route vrf internet 0.0.0.0 0.0.0.0 84.254.193.182
!
access-list 22 permit 10.1.25.0 0.0.0.255
access-list 22 remark mgt_admin
!
!
!
!
!
snmp-server community public1 RO
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
banner login ^C
UGMK Tumen border router Internet Cisco 891
^C
!
line con 0
password 7 046E07121D204A47061500035C
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
access-class 22 in
transport input telnet
!
ntp master 7
ntp update-calendar
ntp server vrf internet 194.190.168.1 prefer
ntp server vrf internet 91.226.136.138
end




Теперь нужно менять IP адреса. Сменил на циске необходимые данные, получилось вот так:

R1#sh run
Building configuration...

Current configuration : 3408 bytes
!
! Last configuration change at 18:53:33 russia Tue Aug 7 2012 by Admin
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
no service dhcp
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
logging buffered 4096
enable secret 5 $1$aJQd$d18SOfNdjbYk2a1Jp5vOj1
!
aaa new-model
!

R1#sh run
Building configuration...

Current configuration : 3408 bytes
!
! Last configuration change at 18:53:33 russia Tue Aug 7 2012 by Admin
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
no service dhcp
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
logging buffered 4096
enable secret 5 $1$aJQd$d18SOfNdjbYk2a1Jp5vOj1
!
aaa new-model
!
!
aaa authentication login default local enable
!
!
!
!
!
aaa session-id common
!
clock timezone russia 5 0
ip source-route
!
!
!
ip vrf internet
rd 65002:80
route-target export 65002:80
route-target import 65002:80
!
!
!
ip cef
no ip domain lookup
ip domain name MT
ip name-server vrf internet 194.85.128.10
ip name-server vrf internet 194.85.129.80
no ipv6 cef
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO891-K9 sn FCZ1540C1M2
!
!
vtp mode transparent
username admin privilege 15 password 7 15270718162B2D2D273F30365D
username Login password 7 00311F12165A0D0F002D495A47
!
!
vlan 2
name INET
!
ip ssh time-out 60
!
!
!
!
interface FastEthernet0
description downlink_LAN
switchport access vlan 2
switchport mode trunk
no ip address
!
interface FastEthernet1
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet2
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet3
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet4
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet5
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet6
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet7
description Internet
switchport access vlan 2
no ip address
spanning-tree portfast
!
interface FastEthernet8
description Vimpelcom
ip vrf forwarding internet
ip address 79.104.34.3 255.255.255.224
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
description LAN_MGT
ip address 10.1.25.247 255.255.255.0
ip virtual-reassembly in
!
interface Vlan2
description Inet
ip vrf forwarding internet
ip address 84.254.219.1 255.255.255.240
!
interface Async1
no ip address
encapsulation slip
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip dns view vrf internet default
ip route 10.1.25.0 255.255.255.0 10.1.25.254
ip route vrf internet 0.0.0.0 0.0.0.0 79.104.34.1
!
access-list 22 permit 10.1.25.0 0.0.0.255
access-list 22 remark mgt_admin
!
!
!
!
!
snmp-server community public1 RO
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
banner login ^C
UGMK Tumen border router Internet Cisco 891
^C
!
line con 0
password 7 046E07121D204A47061500035C
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
access-class 22 in
transport input telnet
!
ntp master 7
ntp update-calendar
ntp server vrf internet 194.190.168.1 prefer
ntp server vrf internet 91.226.136.138
end

В результате циско не видит сеть 79,104,34,1 и не пингует её, а из этой сети она видна и прекрасно пингуется.


R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.25.0/24 is directly connected, Vlan1
L 10.1.25.247/32 is directly connected, Vlan1



Сломал уже всю голову. Остается надежда только на совет
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.08.2012, 18:08
Ответы с готовыми решениями:

Как отредактировать внешний вид, поменять бекграунд, добавить рисунки?
посоветуйте пожалуйста, два дня бьюсь. Купили сайт на джумле, хотела поменять внешний вид. ХТМЛ -...

Как поменять внешний вид курсора со стрелки на своё изображение?
Подскажите вариант, пишу небольшую игру, необходимо чтобы в одной из форм курсор менялся со...

Не могу открыть внешний отчет
Не могу открыть внешний отчет с расширением .erf. Конфигуратор пишет "Внешний отчет не может быть...

Не могу подключить внешний файл js
server.js var http =require('http'); var fs =require('fs'); new http.Server(function (req,...

10
makvador
70 / 59 / 0
Регистрация: 07.07.2012
Сообщений: 195
07.08.2012, 21:43 2
Создайте отдельный VLAN и назначте на него новый IP адрес, а не напрямую на порт:

conf t
vl 3
exit
inter vlan3
ip addr 79.104.34.3 255.255.255.224
exit
inter fa 0/8
sw acc vl 3
0
Pat123
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 10
08.08.2012, 07:43  [ТС] 3
Непонял почему нельзя напрямую, если до этого всё работало, но попробовал через новый ВЛан, от этого ничего не изменилось. Снаружи пинг идет, она наружу не пингует.

Добавлено через 1 минуту
Cisco 891
0
makvador
70 / 59 / 0
Регистрация: 07.07.2012
Сообщений: 195
08.08.2012, 08:39 4
Вы проверяете Ping до 79.104.34.0/27 непосредственно с маршрутизатора или из других сетей (10.1.25.0/24 и 84.254.219.0/28)? Должны ли ваши подсети маршрутизироваться напрямую, тоесть необходимости в NAT нет? Для чего используется VRF?
0
Pat123
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 10
08.08.2012, 09:28  [ТС] 5
makvador, Проверяю непосредственно с маршрутизатора, пинга нету.
Сейчас накидаю схемку чтоб было понятнее.
http://dc133.file.qip.ru/img/G-QqqBA...1%8B%D0%B9.jpg
Пользователи идут на сервера и только оттуда наружу
0
makvador
70 / 59 / 0
Регистрация: 07.07.2012
Сообщений: 195
08.08.2012, 10:05 6
Узел в сети 79.104.34.0/27 который вы пингуете должен отвечать на пинги, вы это проверяли (например напрямую в обход маршрутизатора)?
0
Pat123
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 10
08.08.2012, 10:14  [ТС] 7
Да, задал вопрос своему провайдеру. Сказали должен. Но в любом случае там ничего не пингуется. Ни один интернет сервер
0
makvador
70 / 59 / 0
Регистрация: 07.07.2012
Сообщений: 195
08.08.2012, 10:23 8
Скорее всего проблема в том, что у вас используется VRF и default route задан в одной из виртуальных таблиц. Попробуйте временно сделать:

conf t
ip ro 0.0.0.0 0.0.0.0 79.104.34.1
И проверить связь ещё раз.
0
Pat123
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 10
08.08.2012, 11:19  [ТС] 9
Попробовал. не работает =(
0
makvador
70 / 59 / 0
Регистрация: 07.07.2012
Сообщений: 195
08.08.2012, 11:32 10
Уберите временно VRF с внешних интерфейсов:

conf t
inter vlan2
no ip vrf forw
inter vlan3
no ip vrf forw
inter fa 0/8
no ip vrf forw
0
Pat123
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 10
09.08.2012, 09:20  [ТС] 11
До работы утром доберусь - попробую. пока не могу.

Добавлено через 17 часов 30 минут
makvador, Спасибо! помогло! пинг начал проходить
0
09.08.2012, 09:20
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.08.2012, 09:20

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Не могу остановить внешний жесткий диск
Не могу остановить внешний винчестер. Выскакивает окно "Устройство ... не может быть остановлено...

Не могу создать внешний HDD загрузочным
Всем привет. есть внешний HDD Transcend StoreJet 500gb. пытался сделать из него загрузочный диск....

Не могу подключиться к серверу через внешний ip
не могу подключить программу "Архивный фонд" через внешний ip адрес, хотя через внутренний все...

Не могу подключить внешний файл javascript
Добрый день. Подскажите в чем может быть проблема? Код в html работает: <script...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.