Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.65/23: Рейтинг темы: голосов - 23, средняя оценка - 4.65
1 / 1 / 0
Регистрация: 16.04.2012
Сообщений: 104
1

Привязка мак-адреса к ip cisco 1841

21.11.2012, 12:05. Просмотров 4312. Ответов 3
Метки нет (Все метки)


имеестся 1841 который раздаёт инет, гдето 20-30 пользователей....
каждому айпи соответствует мак...
в 1841 порезана скорость для каждого айпи....
нужно что бы пользователи не могли под чужими айпи заходить в инет....



вот некоторый конфиг

!
version 12.4
!
ip dhcp pool 192.168.0.20
host 192.168.0.20 255.255.255.0
client-identifier 0100.19db.dc27.6d
dns-server 192.168.0.1
default-router 192.168.0.1
client-name test
!
!
ip name-server 212.1.хх.хх
ip name-server 212.1.хх.хх
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
duplex auto
speed auto
traffic-shape group 152 512000 7936 7936 1000
!
interface FastEthernet0/1
ip address 176.192.18.46 255.255.255.252
ip nat outside
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 176.192.18.45
ip dns server
!
ip http server
ip nat pool INET 176.192.18.46 176.192.18.46 netmask 255.255.255.252
ip nat source list 101 interface FastEthernet0/1 overload
ip nat inside source list INET_ACL interface FastEthernet0/1 overload
!
ip access-list extended INET_ACL
permit ip 192.168.0.0 0.0.0.255 any
i
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
access-list 152 permit ip any host 192.168.0.20
!
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
21.11.2012, 12:05
Ответы с готовыми решениями:

Cisco 1841 смена IP адреса
Добрый день! У меня 2 канала по BGP. Один из провайдеров поменял IP адрес, как мне поменять его в...

Привязка МАК-адреса к VLAN QTECH QSW-2700
возможно ли привязать определённый мак адрес к определённому VLAN? например к L2 комутатору на 1-ый...

Cisco 1841
Перерыл кучу информации но так и не нашел ничего стоящего.Вообщем люди знающие тут, надеюсь...

Cisco 1841
Добрый день. Я столкнулся с некоторой проблемой.. Необходимо заменить Интернет шлюз на одном из...

3
5 / 5 / 1
Регистрация: 10.09.2012
Сообщений: 78
23.11.2012, 15:50 2
Вот тебе пример создания DHCP с привязкой ip к маку

ip dhcp excluded-address 192.168.1.6
!
ip dhcp pool Client1
host 192.168.1.2 255.255.255.248
client-identifier 0100.c0b7.5c04.36
client-name COMP1
default-router 172.20.1.22
dns-server 8.8.8.8 8.8.4.4
lease infinite
!
ip dhcp pool Client1
host 192.168.1.3 255.255.255.248
client-identifier 0100.c0b7.5c04.37
client-name COMP2
default-router 172.20.1.22
dns-server 8.8.8.8 8.8.4.4
lease infinite
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.248
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
lease 0 0 10
!

Добавлено через 4 минуты
Sorry, default-router 172.20.1.22 для клиентов 1 и 2 не верные. Надо поменять на 192.168.1.1
Главное, чтобы у тебя общая сеть, т.е. те ip, что не привязаны к маку в конфиге обрабатывалась последней, т.е. когда получат ip те, чьи маки прописаны в dhcp, оставшиеся клиенты получать ip из общего пула ( если это не нужно, можно просто убрать)
0
1 / 1 / 0
Регистрация: 19.11.2012
Сообщений: 14
23.11.2012, 16:13 3
Цитата Сообщение от LinboG Посмотреть сообщение
Вот тебе пример создания DHCP с привязкой ip к маку

ip dhcp excluded-address 192.168.1.6
!
ip dhcp pool Client1
host 192.168.1.2 255.255.255.248
client-identifier 0100.c0b7.5c04.36
client-name COMP1
default-router 172.20.1.22
dns-server 8.8.8.8 8.8.4.4
lease infinite
!
ip dhcp pool Client1
host 192.168.1.3 255.255.255.248
client-identifier 0100.c0b7.5c04.37
client-name COMP2
default-router 172.20.1.22
dns-server 8.8.8.8 8.8.4.4
lease infinite
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.248
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
lease 0 0 10
!

Добавлено через 4 минуты
Sorry, default-router 172.20.1.22 для клиентов 1 и 2 не верные. Надо поменять на 192.168.1.1
Главное, чтобы у тебя общая сеть, т.е. те ip, что не привязаны к маку в конфиге обрабатывалась последней, т.е. когда получат ip те, чьи маки прописаны в dhcp, оставшиеся клиенты получать ip из общего пула ( если это не нужно, можно просто убрать)
причем тут это?? ты считаешь, что при наличии DHCP нельзя выставить статический айпишник компу?

Добавлено через 1 минуту
статические арпы не выход?

Добавлено через 6 минут
если коммутатор есть - пропиши acl на каждый интерфейс
0
5 / 5 / 1
Регистрация: 10.09.2012
Сообщений: 78
24.11.2012, 14:24 4
Извиняюсь, не дочитал вопрос
Да, написать можно acl, разрешить тем, кому нужно
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
24.11.2012, 14:24

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Роутер Cisco 1841
каким модулем можно увеличить функционал устройства ? для получения интерфейса gigabit

Cisco 1841 виртуальный интерфейс
Здравствуйте! Подскажите, кто знает. Есть Cisco 1841, естественно 2 порта. 1 интерфейс - в...

Настройка маршрутизатора Cisco 1841
в общем название темы говорящее. притащили - положили на стол - сказали "настроить NAT и...

Ограничение трафика Cisco 1841
Здравствуйте! В локальной сети имеется сервер который отвечает за IP телефонию, работает он на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.