Форум программистов, компьютерный форум, киберфорум
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/8: Рейтинг темы: голосов - 8, средняя оценка - 4.50
Эксперт по компьютерным сетям
277 / 277 / 25
Регистрация: 02.08.2012
Сообщений: 1,232
1

Проброс портом с заменой порта и адреса отправителя

26.10.2013, 18:56. Просмотров 1644. Ответов 10
Метки нет (Все метки)

Добрый день, коллеги.
У меня возникла проблема с подменой адресов и портов. Суть вопроса описал в топологии ниже.

Проброс портом с заменой порта и адреса отправителя


Перепробовал различные махинации с static+nat, подскажите как сделать данную трансляцию.

PIX Cisco , версия софта 8.0
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
26.10.2013, 18:56
Ответы с готовыми решениями:

Проброс порта на IOS 12.4 c указанием адреса источника
Здравствуйте.Помогите пожалуйста. На шлюзе есть один белый IP(смотрит в интернет) назовем его WAN...

Подмена адреса отправителя email-a PHPMailer
Здравствуйте, уважаемые форумчане. Однажды нашел для себя лёгкий способ отправлять мыло, с помощью...

Raw socket подмена ip адреса отправителя
Задача такая надо отправить пакет с другим ip адресом отправителя. Подскажите как это сделать?...

Проброс порта!!!
Всем привет!!! Подскажите кто знает: Есть сервер 2003 на нем стоит Traffic Inspector Нужно...

10
5 / 5 / 1
Регистрация: 14.07.2012
Сообщений: 64
28.10.2013, 07:02 2
А второй интернет для чего? Через него никак?
Два роутера и пикс, значит три проброса, верно? 3389 можно сделать только на последнем.
(я только начал разбираться в этом, так что могу ошибаться)
0
Эксперт по компьютерным сетям
277 / 277 / 25
Регистрация: 02.08.2012
Сообщений: 1,232
28.10.2013, 08:54  [ТС] 3
ltyxbr
Нет, не правильно.
0
Эксперт по компьютерным сетям
4678 / 2653 / 826
Регистрация: 03.11.2009
Сообщений: 8,331
Записей в блоге: 3
01.11.2013, 12:34 4
двойной нат, пример:

Проброс портом с заменой порта и адреса отправителя


Код
ciscoasa# show run

hostname ciscoasa

interface Ethernet0/1
 nameif inside
 security-level 99
 ip address 13.13.13.3 255.255.255.0 

interface Ethernet0/2
 nameif outside
 security-level 0
 ip address 23.23.23.3 255.255.255.0 

access-list 123 extended permit ip any any 

global (inside) 20 interface
global (outside) 10 interface
nat (inside) 10 15.15.15.0 255.255.255.0
nat (outside) 20 access-list 123 outside

route inside 15.15.15.0 255.255.255.0 13.13.13.1
проверка:

Код
R2#ping 23.23.23.3 rep 1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 23.23.23.3, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 76/76/76 ms
R2#
Код
R5#
*Mar  1 23:14:40.266: IP: tableid=0, s=13.13.13.3 (FastEthernet0/1), d=15.15.15.5 (FastEthernet0/1), routed via RIB
*Mar  1 23:14:40.266: IP: s=13.13.13.3 (FastEthernet0/1), d=15.15.15.5 (FastEthernet0/1), len 100, rcvd 3
*Mar  1 23:14:40.270: IP: tableid=0, s=15.15.15.5 (local), d=13.13.13.3 (FastEthernet0/1), routed via FIB
*Mar  1 23:14:40.270: IP: s=15.15.15.5 (local), d=13.13.13.3 (FastEthernet0/1), len 100, sending
R5#

теперь нужно подделать под свой случай
1
Эксперт по компьютерным сетям
4678 / 2653 / 826
Регистрация: 03.11.2009
Сообщений: 8,331
Записей в блоге: 3
01.11.2013, 14:08 5
на статике то же самое должно работать так:
Код
static (inside,outside) interface 15.15.15.5
static (outside,inside) 13.13.13.3 23.23.23.2
Добавлено через пару минут
если с tcp:
Код
static (inside,outside) tcp interface 23 15.15.15.5 23
static (outside,inside) interface 23.23.23.2
1
Эксперт по компьютерным сетям
277 / 277 / 25
Регистрация: 02.08.2012
Сообщений: 1,232
01.11.2013, 14:20  [ТС] 6
Jabbson, Спасибо буду конструировать дальше)
0
Эксперт по компьютерным сетям
4678 / 2653 / 826
Регистрация: 03.11.2009
Сообщений: 8,331
Записей в блоге: 3
01.11.2013, 16:04 7
Цитата Сообщение от MonaxGT Посмотреть сообщение
Jabbson, Спасибо буду конструировать дальше)
всегда пожалуйста
0
Иван19902012
01.11.2013, 16:18
  #8

Не по теме:

скажите а это тоже какая то cisco-вская программа наподобие Packet Tracer на рисунке?

0
Jabbson
01.11.2013, 16:32
  #9

Не по теме:

нет, это не цисковская программа, это GNS3

0
Иван19902012
01.11.2013, 16:35
  #10

Не по теме:

понятно, просто не нашел там иконку ноутбука

а откуда к ней брать образы?

0
Jabbson
01.11.2013, 16:39     Проброс портом с заменой порта и адреса отправителя
  #11

Не по теме:

оттуда же, откуда и к реальным железкам, так как это одни и те же образы.

0
01.11.2013, 16:39
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
01.11.2013, 16:39
Привет! Вот еще темы с ответами:

Проброс порта
Добрый день! Подскажите по настрйоке - есть сервер с ип 192.168.10.94, на нем установлена служба...

Проброс порта
для чего и в какой ситуации нужно делать проброс порта??Почему когда передаешь данный по tcp на...

Проброс порта
Добрый день уважаемые форумчане! Подскажите, как настроить проброс портов из локальной сети в...

проброс порта
всем привет, я здесь новенький, ситуация: наконецто жизнь столкнула меня с Cisco, давно хотел...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.