Форум программистов, компьютерный форум, киберфорум
С++ для начинающих
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/4: Рейтинг темы: голосов - 4, средняя оценка - 5.00
5 / 5 / 0
Регистрация: 20.03.2011
Сообщений: 180
1

Не могу написать функцию

17.05.2011, 12:12. Показов 635. Ответов 8
Метки нет (Все метки)

Помогите сделать данное задание
Написать функцию возведения в квадрат каждого элемента матрицы (N, M), использовать ее для массива целых и вещественных чисел.

Необходимо соблюсти условия перечисленные ниже.
1. Ввод исходных данных и вывод результата на экран производить в основной программе, решение задачи осуществлять в созданной функции.
2. Не применять индексированных переменных для доступа к элементам массивов, а использовать разыменование указателей.
3. Вызывать функции через указатель на нее и обычным образом.
4. Использовать прием перегрузки функций.

Я сделал наполовину помогите мне разобраться с функцией matrixsqr я не могу понять как она работает


C++
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include <stdio.h>
#include <stdlib.h>
#include <iostream.h>
#include <conio.h>
void matrixsqr(int **a, int N, int M) // Интовая версия
{ 
    
 int *p, **r; // Указатель
 for (r=a+N-1; r>=a; --r) // Цикл со счётчиком указаетльного типа, перебираем все сктроки матрицы
    {
        for (p=*r+M-1; p>=*r; --p) // Цикл со счётчиком указаетльного типа, перебираем все элементы строки матрицы
        {
        *p=*p*(*p); // Возведение в квадрат умножением.
        }
    }
}
int main()
{
        clrscr();
        cout<<"Enter n:"<<endl;
        int n;
        cin>>n;
        cout<<"Enter m:"<<endl;
        int m;
        cin>>m;
 
        int** M=new int*[n];
        int i;
        for(i=0; i<n; i++)
        {
                M[i]=new int[m];
        }
 
        int j;
        randomize();
        for(i=0; i<n; i++)
        {
                for(j=0; j<m; j++)
                {
                        M[i][j]=random(100)-50;
                        cout<<M[i][j]<<" ";
                }
                cout<<endl;
        }
      matrixsqr(M, n, m);
      for(i=0; i<n; i++)
        {
                for(j=0; j<m; j++)
                {
                  cout<<M[i][j]<<" ";
                }
          cout<<endl;
        }
                return 0;
}
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
17.05.2011, 12:12
Ответы с готовыми решениями:

не могу разобраться как написать функцию сортировки и исправить функцию добавления в стек
#include &lt;iostream&gt; #include&lt;Windows.h&gt; using namespace std; struct NE{ int x; NE...

Не могу найти ошибку. Нужно написать функцию обмена значениями для 2 целых чисел. Вот мой код
#include &quot;stdafx.h&quot; #include &lt;stdio.h&gt; #include&lt;iostream&gt; using namespace std; void F(int a,...

Не могу написать функцию
Помогите решить функцию, или хотя бы саму функцию как прописать в делфи ...

не могу написать функцию!
дана матрица А(n*n).Построить вектор,каждый элемент которого равен количеству равных элементов в...

8
Эксперт С++
1067 / 846 / 60
Регистрация: 30.04.2011
Сообщений: 1,659
17.05.2011, 12:57 2
Вот так попробуй:
C++
1
2
3
4
5
6
7
8
9
10
11
12
void matrixsqr(int **a, int N, int M) // Интовая версия
{ 
        
 int *p, **r; // Указатель
 for (int i=0; i < N; ++i) // Цикл со счётчиком, перебираем все строки матрицы
        {
                for (int j=0; j < M; ++j) // Цикл со счётчиком, перебираем все элементы строки матрицы
                {
                  a[i][j] = a[i][j]*a[i][j]; // Возведение в квадрат умножением.
                }
        }
}
0
5 / 5 / 0
Регистрация: 20.03.2011
Сообщений: 180
17.05.2011, 13:06  [ТС] 3
Мне надо именно через указатели а не индексирование
0
3083 / 2404 / 255
Регистрация: 11.03.2009
Сообщений: 5,444
17.05.2011, 14:07 4
Для динамических двумерных массивов меняешь
C++
1
arr[i][j]
на
C++
1
*(*(arr+i)+j)
1
5 / 5 / 0
Регистрация: 20.03.2011
Сообщений: 180
17.05.2011, 14:48  [ТС] 5
да я уже разобрался да можно делать как вы kazak, предложили. а не подскажете в данном примере как через указатели выделить динамическую память
0
Эксперт С++
1067 / 846 / 60
Регистрация: 30.04.2011
Сообщений: 1,659
17.05.2011, 14:51 6
Цитата Сообщение от .Malek. Посмотреть сообщение
да я уже разобрался да можно делать как вы kazak, предложили. а не подскажете в данном примере как через указатели выделить динамическую память
У тебя в проге правильно выделено.
0
5 / 5 / 0
Регистрация: 20.03.2011
Сообщений: 180
17.05.2011, 14:52  [ТС] 7
я имею ввиду без индексирования i и g
0
3083 / 2404 / 255
Регистрация: 11.03.2009
Сообщений: 5,444
17.05.2011, 14:55 8
Дык,
C++
1
2
3
4
5
6
int** M=new int*[n];
int i;
for(i=0; i<n; i++)
{
   *(M+i)=new int[m];
}
1
5 / 5 / 0
Регистрация: 20.03.2011
Сообщений: 180
17.05.2011, 18:16  [ТС] 9
А подскажите почему во втором for мы используем *r со звездочкой т.е. это операция получения значения? зачем она тут нужна
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
17.05.2011, 18:16

Не могу правильно написать функцию
=ЕСЛИ(A2&lt;=0,4;A2^A2;ЕСЛИ(A2&lt;0,8;EXP(SIN(A2)));ЕСЛИ(A2&gt;=0,8;TAN(A2)-LN(ABS(COS(A2))))) Что я тут...

Не могу нормально написать функцию
=ЕСЛИ(A2&lt;0,4;COS(КОРЕНЬ(SIN(A2^2+0,1))));ЕСЛИ(A2&lt;=0,6;EXP(LN(A2)+SIN(A2)));(1/TAN(A2+0,1))^2

Не могу правильно написать функцию
Как правильно ее написать в excel??...

Написать функцию не могу понять этот язык!
Задание такое : ФАМИЛИЯ ИМЯ ОТЧЕСТВО написано в верхнем регистре. Написать функцию, которая будет...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru