Форум программистов, компьютерный форум, киберфорум
С++ под Linux
Войти
Регистрация
Восстановить пароль
 
В астрале
Эксперт С++
8033 / 4790 / 655
Регистрация: 24.06.2010
Сообщений: 10,562
1

Обновление дистрибутива debian со stretch на buster

18.06.2021, 01:55. Показов 1573. Ответов 0
Метки нет (Все метки)

При обновлении дистра (пришлось обновить и другие либы до последней версии, например gcc-11, g++-11, boost-1.74, ... из stable/testing/exp) начали получать рандомные ошибки линковки (из разряда либы линкуются и неважно в каком порядке, но все равно ошибка линковки или при работе сервисов segflt (без логов)/bad_alloc в рандомных местах). Все репы в CI (форки и наши примерно 50+ штук) смигрированны на бустер. Может ли быть проблема в ABI несовместимости? Я подозреваю что да, но не вижу варианта чтобы либы были собраны меньшим libc/libstdc++, чем наименьший, а у libc/libstdc++ есть обратная совместимость насколько я вижу по гуглу.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
18.06.2021, 01:55
Ответы с готовыми решениями:

Orange Pi PC 2 Debian Buster - сыпятся ошибки
Сыпятся ошибки типа таких, и похожие. Sep 1 21:38:43 gwh kernel: http: syscall 278 ...

Mysql ест всю память Ram (debian buster 10)
Привет Поставил на виртуалку debian 10 и установил mysql (InnoDB). Через free -m видно, что Ram...

E: Неудовлетворённые зависимости (Debian Gnome Stretch)
Недавно появилась ошибка "Неудовлетворенные зависимости" при использовании apt-get в терминале....

C++ SFML для Code::Blocks Debian Gnome Stretch
При выполнении программы с использованием SFML выводится окно терминала вместо создания окна и...

0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
18.06.2021, 01:55

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Запуск .exe приложений через mono из оболочки (Debian Stretch Gnome)
Когда я только поставил на компьютер Debian, я установил mono-complete для запуска .exe программ,...

Не могу поставить софт (Anjuta 2 Glade 2) из iso дистрибутива Debian 6
Уважаемые форумчане! Такая проблема: Не получается поставить программы из дистрибутива...

Обновление пакета libstdc++6 в Debian 7
Стоит Debian 7. Одна жизненно важная программа (плагин для SAMP сервера) требует "GLIBCXX 3.4.19" в...

Buster вышел
Собственно сабж. Попробовал, от 9.9 мало чем отличается. Появилось много драйверов на вайфайные...

Игра Money Buster считается 3D или 2D игрой?
Игра Money Buster считается 3D или 2D игрой?

Реализовать зеркалирование пакетов TCP на Raspbian Buster
Приветствую всех! Имеется две малинки, на каждой установлен onvif сервер (по сути каждая...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.