Форум программистов, компьютерный форум, киберфорум
Debian, Kali Linux, Raspbian
Войти
Регистрация
Восстановить пароль
 
15 / 22 / 7
Регистрация: 18.02.2018
Сообщений: 116
1

Amdgpu под glibc < 2.29

04.06.2021, 01:02. Показов 178. Ответов 0
Метки нет (Все метки)

Доброй ночи.

Пытаюсь поставить amdgpu, но для него нужен glibc >= 2.29. Мой дист поддерживает только glibc <= 2.28-10. Пересобирать эту штуку я даже не мыслю. Интересует каким способом можно понизить amdgpu до версии, требующую меньший glibc.

Зависимостей, относительно, немного:

Код
libgbm1-amdgpu: 
└ libc6 (>= 2.29) but 2.28-10 is installed
 
libllvm11.0-amdgpu: 
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libgcc-s1 (>= 3.4) which is a virtual package and is not provided by any available package

mesa-amdgpu-omx-drivers:
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libgcc-s1 (>= 3.4) which is a virtual package and is not provided by any available package
└ libx11-xcb1 (>= 2:1.6.9) but 2:1.6.7-1+deb10u1 is installed and it is kept back

mesa-amdgpu-vdpau-drivers: 
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libgcc-s1 (>= 3.4) which is a virtual package and is not provided by any available package
└ libx11-xcb1 (>= 2:1.6.9) but 2:1.6.7-1+deb10u1 is installed and it is kept back
 
libegl1-amdgpu-mesa:
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libx11-xcb1 (>= 2:1.6.9) but 2:1.6.7-1+deb10u1 is installed and it is kept back

mesa-amdgpu-va-drivers:
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libgcc-s1 (>= 3.4) which is a virtual package and is not provided by any available package
└ libx11-xcb1 (>= 2:1.6.9) but 2:1.6.7-1+deb10u1 is installed and it is kept back

libxatracker2-amdgpu:
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libgcc-s1 (>= 3.4) which is a virtual package and is not provided by any available package

libgl1-amdgpu-mesa-dri:
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libgcc-s1 (>= 3.4) which is a virtual package and is not provided by any available package

libdrm2-amdgpu: 
└ libc6 (>= 2.29) but 2.28-10 is installed

libgl1-amdgpu-mesa-glx: 
└ libc6 (>= 2.29) but 2.28-10 is installed
└ libx11-xcb1 (>= 2:1.6.9) but 2:1.6.7-1+deb10u1 is installed and it is kept back
По-видимому, придётся обходить не только libc6.

Как заинсталлить amdgpu и его друзей?

Код
$ uname -r
5.10.10
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
04.06.2021, 01:02
Ответы с готовыми решениями:

fim и amdgpu
Здравствуйте! У меня не работает fim (framebuffer image viewer) на машине без X-ов. Видеодрайвер...

Amdgpu рандомно работает не под root
Ребят всем привет, пожалуйста подскажите, поставил себе на основной пк 12 фряху, накатил kde5 и...

glibc detected
Хочется узнать, что конкретно означает эта ошибка (glibc detected). Где-то я на забугорных форумах...

Не собиратеся glibc-2.13
Всем привет. Второй день не могу собрать glibc-2.13 Выдает: make -r PARALLELMFLAGS=&quot;&quot;...

0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
04.06.2021, 01:02

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Pthread_mutex_lock в ядре glibc
Кто хорошо разбирается в glibc помогите, пожалуйста. Нужно показать в файле pthread_mutex_lock.c 1)...

TCP сокеты в glibc
Пользуюсь сокетами, как со стороны клиентов, так и со стороны серверов, не могу понять вот чего:...

Glibc не выполняет make (LFS)
Добрый день всем жителям! собираю LFS 6.8 по родному английскому хэндбуку. столкнулась вот с такой...

Установка библиотек GLIBC >=2.14 на CentOS 6.6
Понадобилось на сервере (CentOS 6.6 x64) запустить программу, написанную на Qt 5.4 (компилировал...

gcc & glibc testsuite
Есть в gcc и glibc так называемый testsuite. Как их правильно использовать? Как интерпретировать?...

Установить патч на glibc 2.2.5 в AstraLinux
При установке ПО (в Astra Linux) возникла ошибка libcrypto.so.10: symbol __libc_enable_secure,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.