Форум программистов, компьютерный форум, киберфорум
Жесткие диски, HDD
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.97/62: Рейтинг темы: голосов - 62, средняя оценка - 4.97
0 / 0 / 0
Регистрация: 17.12.2007
Сообщений: 3
1

IDE хард работает только в PIO режиме после установки SATA Hdd

17.12.2007, 15:08. Просмотров 11544. Ответов 8
Метки нет (Все метки)


День Добрый!!

Очень надеюсь на вашу помощь! Я прикупил себе новый хард - WD 320GB SATA2. До этого у меня стоял Seagate Barracuda 120GB IDE. Вместе работать они никак не хотят.

Рассказывая всё по порядку - вытащил IDE, поставил новый SATA, разбил/отформатировал, поставил на него систему. Вставил обратно IDE, указал загрузку с нового SATA, загрузил винды, скопировал информацию с IDE, отформатировал, всё вроде бы впорядке - только всё это проиходило жутко медленно. Сначала не придал этому большого значения, но потом начало раздражать. С помощью тестов выяснил, что у меня оба харда работают в PIO режиме, причём старый выдаёт 2 mb/s а новый 10 mb/s. Путём долгих усилий, перевёл в Device Manager новый хард на SATA режим, получив 70 мб/с в среднем. IDE хард тем не менее прочно засел в PIO режиме и не хочет переходить в UDMA. Заметил так же, что если включить оба харда, система грузиться намного медленнее чем если работает только SATA. Любой совет по тому, как мне заставить IDE хард нормально работать, будет на вес золота. Из того что я уже пытался:

- в биосе лазил, там всё стоит как авто режиме
- пробывал переставить IDE хард на другой контроллер где стоит по дефолту DVD привод, работающий в UDMA - эффекта никакого, хард перешёл в PIO.
- пробывал убивать драйвера и переставлять их заного
- пробывал убивать винды и переставлять всё заного - инсталяция виндов с подключенным IDE хардом грузится заметно медленнее и при попытки поставить систему, он либо видет IDE как диск C:, либо, если поставить на Slave, то видет партицию SATA как диск C:, готов ставить на неё винды, но хочет изначально отфарматить IDE хард, т.к. ему типо нужно туда что-то скопировать (что? зачем? может в этом моя проблема - надо не вытаскивать IDE хард, а позволить ему туда скопировать что ему надо?)
- менял джампера IDE харда с Cable Select на Slave, пытался загружать IDE хард как Рrimary Master так и как Primary/Secondary Slave.

Материнка у меня MSI Neo4 K8N (1.0) на чипсете nForce 4.

Посоветуйте что-нибудь пожалуйста - не хочится выкидывать 120gb..
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
17.12.2007, 15:08
Ответы с готовыми решениями:

Компьютер категорически перестал видеть жесткий SATA после установки IDE диска.
так вот раньше стоял SATA и работал нормально сейчас установил IDE и комп категорически перестал...

HDD (IDE) после разгона перестал работать в UDMA режиме
Здравствуйте, после разгона перестал грузиться диск, доходит до POST-code 0078 и всё. Но если...

Перенос CentOS 6 со старого IDE HDD на новый SATA HDD
Здравствуйте. Сейчас в компьютере стоит CentOS 6 на IDE HDD. Нужно её перенести на новый HDD SATA....

После установки Linux на один хард, винда перестала видеть другой хард
У меня два жестких диска, на одном было два раздела, в одном из которых стоит винда. От второго...

8
белый @ пушистый
2093 / 547 / 16
Регистрация: 13.07.2007
Сообщений: 1,890
17.12.2007, 22:07 2
да уж... ситуация у вас вполне обыденная, к сожалению...
это конфликт устройств... если бы вы взяли SATA тоже Barrakud'у, скорее всего (95%), у вас бы не было сейчас проблем...
решением этого вопроса заниматься пробовал сам - ничего не вышло... со знакомыми специалистами не консультировался - решили тогда вопрос иначе - поменяли винчестер на винт такой же марки...
щас запишу себе куда-нибудь узнать у коллег насчёт этого вопроса - как узнаю - отпишу...
от вас интересует один вопрос - та же как и я решить проблему вам нельзя? коли винчестер новый - заменить в магазине...
0
Гость
17.12.2007, 22:37 3
Спасибо за ответ. Конфликт устройств - это плохо, но, конечно, многое объясняет.

Что касается вернуть в магазин - не выход. Хард брался с дилерского склада и они не примут его обратно..

"щас запишу себе куда-нибудь узнать у коллег насчёт этого вопроса - как узнаю - отпишу..."

Спасибо ещё раз - буду ждать чуда!
белый @ пушистый
2093 / 547 / 16
Регистрация: 13.07.2007
Сообщений: 1,890
18.12.2007, 22:12 4
к сожалению, человек, к которому я обратился с такой проблемой не встречался вовсе... причём я к нему обращаюсь крайне редко - когда совсем уж ни как самому...
остаётся 2 варианта - может кто-то другой напишет...
а так же - порыться в инете...
0
Администратор
79857 / 48420 / 244
Регистрация: 10.04.2006
Сообщений: 13,125
18.12.2007, 22:50 5
Цитата Сообщение от zidanee
- пробывал убивать винды и переставлять всё заного - инсталяция виндов с подключенным IDE хардом грузится заметно медленнее и при попытки поставить систему, он либо видет IDE как диск C:, либо, если поставить на Slave, то видет партицию SATA как диск C:, готов ставить на неё винды, но хочет изначально отфарматить IDE хард, т.к. ему типо нужно туда что-то скопировать
Очевидно, глюки или недоработки чипсета.
0
0 / 0 / 0
Регистрация: 17.12.2007
Сообщений: 3
19.12.2007, 09:52  [ТС] 6
Цитата Сообщение от Дмитрий-Нск Посмотреть сообщение
к сожалению, человек, к которому я обратился с такой проблемой не встречался вовсе... причём я к нему обращаюсь крайне редко - когда совсем уж ни как самому...
остаётся 2 варианта - может кто-то другой напишет...
а так же - порыться в инете...
Хех, уже вроде всё облазил, как в ру-нете, так и за рубежом. Мне тут знакомый посоветовал - вроде у него была похожая проблема - создать RAID0 массив из этих двух хардов, вроде должно помочь. Правда другой источник сказал, что это всё фигня.. Кому верить?

Вообще я начал склоняться к идее продать за копейки старый IDE, добавить немного и взять ещё один SATA WD..
0
Администратор
79857 / 48420 / 244
Регистрация: 10.04.2006
Сообщений: 13,125
19.12.2007, 10:18 7
Цитата Сообщение от zidanee
Вообще я начал склоняться к идее продать за копейки старый IDE, добавить немного и взять ещё один SATA WD..
Лучше это, чем танцы с бубном
0
0 / 0 / 0
Регистрация: 17.12.2007
Сообщений: 3
19.12.2007, 13:59  [ТС] 8
Цитата Сообщение от mik-a-el Посмотреть сообщение
Лучше это, чем танцы с бубном
Хмм.. А вот этого я, кстати, ещё не пробывал.. Вариант..
0
0 / 0 / 0
Регистрация: 04.01.2008
Сообщений: 18
04.01.2008, 06:12 9
Попробуй сделать только один активный раздел. С ведомого просто удали его, возможно решение которое принимает биос о загрузке не полностью решается в Винде. Пробуй, не сдавайся. Я сталкивался с похожими конфликтами. Проверь установку драйвера под SATA, может новенький подкинь. Драйвер нужен одозначно
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
04.01.2008, 06:12

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

HDD не работает в ACHI и IDE. Только в RAID
Собрал комп. HDD снял с ноутбука. При попытке иницилизирования выдает ошибку 3rd Master Hard disk...

Внешний HDD работает только в безопасном режиме
Собственно сабж.В безопасном режиме внешний хдд работает прекрасно.В обычном режиме не работает не...

В диспетчере устройств отсутствуют SATA-контроллеры в режиме IDE
Приветствую Хочу использовать Windows XP x64 в качестве дополнительной системы. Железо у меня...

Винчестер SATA III работает в режиме SATA II
Не могу понять что происходит. Купил винчестер нового поколения SATA III (Western Digital Blue 1TB...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.