Форум программистов, компьютерный форум, киберфорум
Linux: загрузчики (Grub, Grub2, LiLo)
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
3 / 7 / 4
Регистрация: 11.01.2018
Сообщений: 86
1

Не становится GRUB, или дело в настройках биоса?

08.02.2021, 21:11. Просмотров 1048. Ответов 9

Доброго времени суток!

Долгое время использовал на ноутбуке параллельно две ОС: Windows 10 и Lubuntu. Использовал и горя не знал.
Но однажды произошёл сбой питания, слетел режим SATA-контроллера и системы пришлось переустанавливать. С виндой, как и всегда, проблем не возникает: всё прекрасно установилось, только образ я уже брал другой, более новый; а вот с линуксом всё оказалось почему-то не так просто.
Лубунту я ставлю ту же самую, что и была, только, вероятно, по-другому разбиваю диск. В подробностях перед стартом установки расписано, что загрузчик станет на такой-то диск. Однако после установки системы, после сообщения вроде "Everything is done" и перезагрузки машины, Grub не отображается, а винда по прежнему запускается автоматически.

В ноутбуке стоит одно устройство SSD. На данный момент (перед установкой) для Windows стоит 4 раздела:
  • EFI System (100 МБ, FAT32);
  • Система (100 ГБ, NTFS);
  • Рекавери (505 МБ, NTFS);
  • Раздел для данных (200 ГБ, NTFS);

Для линукса я выделяю три новых во время процедуры подготовки к установке:
  • Root (20 ГБ, ext4, /);
  • Swap (24 ГБ, swap);
  • Home (~132 ГБ, ext4, /home);

По содержанию разделов после установки можно сделать вывод, что система стала, но GRUB я всё равно не вижу, а следовательно - никак не могу запустить Lubuntu.
Допускаю, что проблема в настройках БИОСа, но для установки этого дистрибутива требуется прежде запустить его с флешки, с чем проблем не возникает. Legacy Support включена.

Подскажите, по какой причине может не запускаться загрузчик? Может, я как-то неправильно делю диск для установки системы?
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.02.2021, 21:11
Ответы с готовыми решениями:

Совместим ли проц?Или дело в прошивке биоса?
Всем привет. У меня материнка Асус М3А (версия биоса 1206(новейшая)). Стоял процессор Атлонх2 5600+...

В настройках биоса AMD Bios AWARD нужно ставить hybrid или нормал?
В настройках биоса нужно ставить hybrid или нормал? Так же как расставлять %core? Amd x4 Phenom II

Пропал жесткий диск в настройках биоса нет
Работал за компьютером внезапно завис. Перезагрузил ."Reboot and Select proper Boot device or...

Нужен совет по настройках биоса Vesa Bios Exstetion ver.2
Всем добрый день! Помогите пожалуйста разобраться: Есть старый комп с win95 (материнка...

9
Эксперт HardwareЭксперт WindowsАвтор FAQ
7090 / 2588 / 412
Регистрация: 14.04.2011
Сообщений: 6,290
09.02.2021, 15:31 2
Ноутбук случайно не Acer?
Если нет, то первое, что я бы предложил сделать, это загрузиться с установочного носителя Lubuntu, смонтировать раздел EFI, например так

Код
sudo mount /dev/sdX /mnt   - где Х это буква EFI раздела
и посмотреть, есть ли в паке EFI папка Ubuntu. Если папки Ubuntu нет, то значит GRUB не установился.
Если папка Ubuntu есть (GRUB установлен), то зайти в BIOS и в разделе, где меняется приоритет загрузочных устройств посмотреть есть ли запись Ubuntu. Если есть, то поставить её на первое место в загрузке и сохранить изменения.

Если GRIB установлен и запись Ubuntu в BIOS есть и стоит на первом месте, то в BIOS посмотреть параметр Fast boot и если он есть и включен, то отключить и сохранить изменения.
Так же очень желательно в 10-ке отключить гибернацию, для этого открыть командную строку от имени администратора и выполнить

Код
powercfg -h off
0
3 / 7 / 4
Регистрация: 11.01.2018
Сообщений: 86
09.02.2021, 16:58  [ТС] 3
Андрей1224, Благодарю.
Нет, ноутбук Lenovo ideapad 720S Touch-15IKB, прошу прощения, что упустил это в описании проблемы.

Цитата Сообщение от Андрей1224 Посмотреть сообщение
посмотреть, есть ли в паке EFI папка Ubuntu
Как Вы и советовали, загрузился с флешки и взглянул на содержимое папки EFI.
Удивительно, но в ней есть только папки Boot и Microsoft, хотя при установке никаких сообщений о проблемах с установкой загрузчика я не наблюдал.
То же самое подтвердила WinPE.

Выходит, GRUB'a нет, но как тогда правильно выйти из ситуации?

Заметил ещё кое-что любопытное:
Линукс показывает, что так же есть ещё один раздел, который не отображается в винде. Он занимает всего 16 МБ, а файловая система unknown, соответственно, я не могу посмотреть его содержимое.
0
Эксперт HardwareЭксперт WindowsАвтор FAQ
7090 / 2588 / 412
Регистрация: 14.04.2011
Сообщений: 6,290
09.02.2021, 18:44 4
Цитата Сообщение от rt_Keen Посмотреть сообщение
Выходит, GRUB'a нет, но как тогда правильно выйти из ситуации?
Правильно установить Linux. Может пригодится, вот здесь начиная с пункта№5 Установка Убунту под Вин 10. Или поискать в интернете "установка Ubuntu в UEFI режиме".

Цитата Сообщение от rt_Keen Посмотреть сообщение
Линукс показывает, что так же есть ещё один раздел, который не отображается в винде. Он занимает всего 16 МБ, а файловая система unknown, соответственно, я не могу посмотреть его содержимое.
Это специальный раздел от Windows, он так и должен "выглядеть" как Вы описали. Вообщем этот раздел не трогать, с ним всё нормально.
1
3 / 7 / 4
Регистрация: 11.01.2018
Сообщений: 86
09.02.2021, 23:45  [ТС] 5
Андрей1224, чтож, я перепроверил, спасибо, но ставил я всё-таки правильно, на сколько я понял.

Однако я, кажется, обнаружил корень проблемы, но всё ещё не знаю как её решить:
Дело в том, что по какой-то причине разделы диска на моей машине называются совсем не "sdaX", a "nvme0n1pX", чему я не придавал ровно никакого значения до момента Вашего совета на счёт поиска папки Ubuntu в EFI.

После небольшого ресёрча я остался в растерянности и со знанием того, что из-за этого часто случаются проблемы с линуксом, как например описано здесь, на Хабре.

Моя ситуация во время установки выглядит так:
Кликните здесь для просмотра всего текста
Не становится GRUB, или дело в настройках биоса?


Нашёл также такую тему на AskUbuntu.
Сделал как предлагали, но boot-repair отказывается выполнять любые задания с таким сообщением:
Кликните здесь для просмотра всего текста
Не становится GRUB, или дело в настройках биоса?

В то время вот все настройки загрузки в БИОСе:
Кликните здесь для просмотра всего текста
Не становится GRUB, или дело в настройках биоса?


Что я делаю не так? Я в принципе могу поставить граб на этот диск без дополнительных переустановок винды?
Или может линукс мне с этой машины никак не запустить?
0
Эксперт по компьютерным сетямЭксперт NIX
12129 / 7012 / 708
Регистрация: 09.09.2009
Сообщений: 27,500
10.02.2021, 10:17 6
Цитата Сообщение от rt_Keen Посмотреть сообщение
boot-repair отказывается выполнять любые задания с таким сообщением
и каков результат после того, как вы проделали то, что он вам "сообщает"?
1
Эксперт HardwareЭксперт WindowsАвтор FAQ
7090 / 2588 / 412
Регистрация: 14.04.2011
Сообщений: 6,290
10.02.2021, 14:09 7
Лучший ответ Сообщение было отмечено rt_Keen как решение

Решение

Цитата Сообщение от rt_Keen Посмотреть сообщение
Дело в том, что по какой-то причине разделы диска на моей машине называются совсем не "sdaX", a "nvme0n1pX"
Всё нормально. У Вас NVMe SSD диск, поэтому разделы так называются. Главное, что установщик видит Ваш SSD.

Систему Вы устанавливаете не правильно.
Систему устанавливаете х64? Если да, то с большой долей вероятности, установочная флешка записана не правильно.
Предлагаю
1. В BIOS в Boot mode отключить Legacy support (этот параметр виден на Вашей фотке BIOS), сохранить изменения F10. Это позволит избежать загрузки в не правильном режиме.
2. Если Ваша флешка не загрузиться после отключения Legacy support, то её нужно перезаписать, чтобы она была UEFI загрузочной.
3. Во время установки, когда дойдёте до раздела Partitions, в самом верху окна слева от названия SSD должно быть написано UEFI (верхняя строчка должна начинаться UEFI).
4. Для раздела /dev//nvme0n1p1 нужно указать точку монтирования /boot/efi. Это EFI раздел размером 100 МБ. Этот раздел не форматировать.
5. В сводной (суммарной) информации по установке, как на Вашем скрине в посте №5, внизу, должен присутствовать раздел /dev//nvme0n1p1 с точкой монтирования /boot/efi. Если всё так, то можно продолжить установку и после установки должен будет появиться GRUB.

К работе boot-repair отношусь оочень осторожно и никогда не предлагаю им пользоваться, но разумеется какждый решает сам, какой инструментарий использовать.
1
3 / 7 / 4
Регистрация: 11.01.2018
Сообщений: 86
11.02.2021, 01:08  [ТС] 8
Андрей1224, искренне Вам благодарен.

Сделал в точности по Вашим рекомендациям, использования Boot Repair избежал. Вместо этого просто полностью переустановил систему с новой загрузочной флешки.

Честно говоря, я всё ещё поражен фактом, что в прошлый раз обошлось совсем без таких неожиданностей, а сейчас пришлось потанцевать с бубном. Однако пока всё стало так, как должно и это вполне удовлетворительный результат.
0
Эксперт HardwareЭксперт WindowsАвтор FAQ
7090 / 2588 / 412
Регистрация: 14.04.2011
Сообщений: 6,290
11.02.2021, 09:56 9
Цитата Сообщение от rt_Keen Посмотреть сообщение
Честно говоря, я всё ещё поражен фактом, что в прошлый раз обошлось совсем без таких неожиданностей,
Есть у меня подозрение-предположение, что в прошлый раз системы были установлены не в UEFI режиме, об этом говорят некоторые моменты в Вашей теме, поэтому было проще.
Очень рад, что у Вас всё получилось без дополнительных танцев с бубном.
1
5 / 9 / 0
Регистрация: 18.11.2017
Сообщений: 26
16.02.2021, 12:07 10
Добавить репозиторий
Код
sudo add-apt-repository ppa:yannubuntu/boot-repair
Обновить пакеты и установить boot-repair.
Код
sudo apt update && apt install -y boot-repair
Запустить
Код
boot-repair.
И дальше он сам всё сделает.

А ты когда раньше две ОС использовал, отключал ли ты Secure Boot в UEFI и включал ли legacy boot?
Если да, то эта настройка могла сбиться и вернутся на стандартные параметры. Проверь. Винде десять то по фиг, она хорошо с UEFI работает, а вот Grub загрузчик с UEFI мудренно прописывать. boot-repair должен помочь, попробуй.
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
16.02.2021, 12:07

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

При установке новой видяхи пропадает изображение, монитор становится серым или синим, или красным
Приобрёл новую видяху, rx570 4 gb ARMOR, ставлю её в пк, происходит что то странное, типа пропадает...

Непонятно в чем дело или в видеокарте или в мониторе
Здраствуйте, недавно у меня произошел инцедент шнур питания монитора вылетел компьютер глюкнул ,...

Здоровье глаз. Как теперь выбрать монитор? Глянец или матовый, или в чем можеть быть дело?
Друзья, добрый день. Закупили на работу новые мониторы LG 27MP57HQ (IPS, без ШИМ). Начали...

GRUB или LILO?
Уважаемые форумчане! Я пишу свою операционную систему, и у меня вопрос: какой загрузчик для ОСи...

Как grub-install в uefi grub записывает
Доброго времени суток! Собственно, сабж. Я пишу программу, которая записывает загрузчик в...

Дано число в двоичном виде. Умножить его на 16. результат перевернуть следующим образом: нулевой разряд становится седьмым, 1-ый становится 6-ым и т
Дано число в двоичном виде. Умножить его на 16. результат перевернуть следующим образом: нулевой...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.