180 / 55 / 9
Регистрация: 22.04.2011
Сообщений: 466
1

GParted. Установить последнюю версию программы на Kubuntu 18.04 LTS

19.02.2020, 02:42. Показов 496. Ответов 8

Доброго времени!
Подскажите как осуществить.
Из стандартного репозитория скачивается версия GParted 0.30.0-3ubuntu2.
На сайте разработчика крайняя версия данной программы уже куда более свежая. И даже на сайте Ubuntu есть версия 1.0.0-0.1.
В Linux Mint 19.3 так же видел эту более свежую предустановленную версию программы.
Вопрос в том, как установить свежую версию GParted (не тестинг) на Kubuntu 18.04 LTS, чтобы при этом подтянулись все необходимые зависимости.
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
19.02.2020, 02:42
Ответы с готовыми решениями:

Как установить последнюю версию Firefox, не обновляя старую версию?
Для удаленной работы применяется цифровая подпись, но она работает только в Firefox не выше 51-й...

Как установить последнюю версию matplotlib
Как установить последнюю версию матплотлиба?

Установить версию программы
Привет народ, Подскажите плиз где и как в QT Creator установить версию собранной программы? В VC...

Какую версию нужно выбрать в Virtual Box для Kubuntu ?
Я скачал дистрибутив Kubuntu. Мне нужно установить ОС на виртуалку. В самом начале в Virtual Box...

8
Эксперт NIX
1883 / 621 / 150
Регистрация: 14.01.2013
Сообщений: 2,887
19.02.2020, 17:16 2
В Кубунту есть свой Диспетчер разделов от KDE. Живёт в системных тулзах. Или в терминале sudo partitionmanager
0
180 / 55 / 9
Регистрация: 22.04.2011
Сообщений: 466
19.02.2020, 17:39  [ТС] 3
Kubuntovod, он не столь удеобен как GParted.
0
Эксперт NIX
1883 / 621 / 150
Регистрация: 14.01.2013
Сообщений: 2,887
19.02.2020, 18:11 4
Тогда Вам туда дорога - GParted sources. Качать, читать, компилить ...
0
180 / 55 / 9
Регистрация: 22.04.2011
Сообщений: 466
20.02.2020, 16:25  [ТС] 5
Цитата Сообщение от Kubuntovod Посмотреть сообщение
Тогда Вам туда дорога - GParted sources. Качать, читать, компилить ...
Ну а пошагово можно?
0
Эксперт NIX
1883 / 621 / 150
Регистрация: 14.01.2013
Сообщений: 2,887
20.02.2020, 20:21 6
Это так просто не расскажешь. Обычно происходит так. Скачиваются исходники, распаковываются, читается либо read.me, либо INSTALL. В данном пакете второй вариант. Там описан рецепт приготовления. Открываем терминал, переходим в папку с исходниками и вводим ./configure
На каком-то этапе спотыкаемся.
configure: error: Your intltool is too old. You need intltool 0.36.0 or later.
Bash
1
2
3
4
$ aptitude search intltool
p   intltool                                                                    - Utility scripts for internationalizing XML                                           
p   intltool-debian                                                             - Help i18n of RFC822 compliant config files                                      
$ sudo apt install intltool
Опять пытаемся сконфигурять:
./configure
Снова облом:
configure: error: *** libparted not found.
Bash
1
2
3
4
5
6
7
8
9
10
11
$ aptitude search libparted
v   libparted                                                                   -                                                                                      
v   libparted:i386                                                              -                                                                                      
p   libparted-dev                                                               - disk partition manipulator - development files                                       
p   libparted-dev:i386                                                          - disk partition manipulator - development files                                       
i A libparted-fs-resize0                                                        - disk partition manipulator - shared FS resizing library                              
p   libparted-fs-resize0:i386                                                   - disk partition manipulator - shared FS resizing library                              
p   libparted-i18n                                                              - disk partition manipulator - i18n support                                            
i A libparted2                                                                  - disk partition manipulator - shared library                                          
p   libparted2:i386                                                             - disk partition manipulator - shared library                                          
$ sudo apt install libparted-dev
./congigure

И так далее. Когда сконфигурирует, делаем:
Bash
1
make
Затем:
Bash
1
sudo make install
0
89 / 75 / 16
Регистрация: 18.08.2016
Сообщений: 341
22.02.2020, 20:47 7
Цитата Сообщение от parnyagan Посмотреть сообщение
На сайте разработчика крайняя версия данной программы уже куда более свежая
И какой в этом смысл?! Прежде чем программа попадет в репу. Ее еще тестируют и указывают на разные баги и недочеты. Вы же, что называется: лезете поперек Батьки в пекло! Ладно если бы использовали для тестирования, но учитывая как вы собираете программу из траболла. Крайне сомневаюсь в ваших способностях как программиста! Вангую, скоро появится вопрос: собрал такую-то программу это отвалиось, это не пашет, а это вообще посылает! Граждане линуксоиды спасайте ИМХО
0
Эксперт NIX
1883 / 621 / 150
Регистрация: 14.01.2013
Сообщений: 2,887
23.02.2020, 07:34 8
Цитата Сообщение от useroot Посмотреть сообщение
Вангую, скоро появится вопрос: собрал такую-то программу это отвалиось, это не пашет, а это вообще посылает!
Не факт. Много раз собирал из исходников Midnight Commander. Если что-то и отваливалось, так только то, что сами авторы либо убрали, либо поглубже засунули. Т.е. в репы в таком же виде всё и попадало, в будущем. Если только так хитро собрать, чтобы что-то отвалилось или посылало, но это надо обладать завидным талантом.
0
180 / 55 / 9
Регистрация: 22.04.2011
Сообщений: 466
24.02.2020, 02:48  [ТС] 9
Цитата Сообщение от useroot Посмотреть сообщение
И какой в этом смысл?! Прежде чем программа попадет в репу. Ее еще тестируют и указывают на разные баги и недочеты
Это че получается она в Минт 19.3 попала как тестовая? Я просто ее там видел, когда с дистрами эксперементировал.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
24.02.2020, 02:48

Как установить Linux kubuntu?
Народ я кароче первый раз пытаюсь поставить эту операционку... Ну так вот, меня ввела в ступор...

Как установить Kubuntu 16.04 на VMware 12.1 ?
Другие версии (cinnamon, mate) ставятся без проблем. А эта (KDE) никак - сразу с диска запускается...

Установить Apache 2.2.17 на Ubuntu 10.04 LTS
установил Ubuntu 10.04 LTS - апрель 2010 скачал httpd-2.2.17.tar.gz и пытаюсь установить и...

Установить WiFi-драйвер (HP 250 G4) в Kubuntu 16.04
Установил на свой ноут, HP 250 G4, Kubuntu 16.04. MBR-установка. Вай-фай адаптер сам собой не...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.