50 / 50 / 3
Регистрация: 27.09.2011
Сообщений: 449
1

Изучаю ROS

04.01.2019, 19:37. Показов 916. Ответов 11

Здравствуйте,
еще три месяца назад о Микротик я знал только одно: под этой маркой продается там что-то из сетевого оборудование, в спартанском дизайне, и вроде как из категории "не для всех"))
Но стали возникать задачи, в условии которых уже имеется устройство Mikrotik. В первый раз это прям панику вызвало!))
Сейчас мне очень интересно, что это и как этим пользоваться. А самое главное, как оно мне поможет облегчить жизнь себе и людям.
В связи с этим взял в личное пользование, а точнее для изучения (чтоб всегда практика под рукой была), RB750Gr3. Выбрал именно его исходя из уже имеющегося опыта и с пониманием того, что меня ждет в ближайшем будущем на парочке проектах.

Изучал ветку эту, пару страниц осилил, не знакомые термины и не понятные фразы для меня объяснял Гугл
Благодаря этой процедуре нашлось много очень интересных статей на хабр'е, которые мне объяснили не только что-то новое, но и понял косяки в прошлых своих деяниях)) Теперь еще больше мотивации понять что к чему, чтобы не пороть касяков больше)

Здесь хочу вопросы задавать, чтобы пинали в верном направлении))

Добавлено через 6 минут
Немного философии из жизни..
После прочтения двух страниц вопросов и ответов о Микротиках, первая мысль: Какого фига операторы связи (ну тех, что я видел последние два месяца на местах) ставят кучу оборудоания однотипного, когда тут написано, что можно справиться одним роутером?!
Т.е. простой пример:
та же школа, в которой я помогал построить сеть локальную из имеющегося оборудования (создавал тут пару тем). Там же дело закончилось тем, что приехал "спец" от провайдера, и вместо того, чтобы настроить свой (уже стоявший в школе) микротик 951Ui-2HnD на нужные услуги, после того как я его нагло сбил и приспособил, он отобрал этот, поставил такой же новый (но не настроенный), прилепил рядом еще один LTE-модем, еще один такой же микротик, чтобы уже ДРУГой оператор приехал через день (тоже отобрав своё старое оборудование, которое я тоже пристроил) и на него свою wifi-точку повесил тупо, но сделав вид, что прям что-то очень сложное прилепили и важно.. В итоге куча разеток занято, куча проводов, и нифига толком не работает. А самый прикол, что концов не найти, ни паролей, ни настроек, ни объяснений зачем оно всё налеплено.
Благодаря темам тут, я понимаю, что одного 951Ui-2HnD хватило бы на два отдельных канала связи (в нашем примере это два LTE-модема). И на их разделение по сетям, ну и для создания собственно этих пары сетей! Вроде как специалист этот должен обладать нужными знаниями, чтобы настроить это всё в "поле" с нуля за пол часика, а то и быстрее. Или я сильно много жду от этого оборудования?))
И такую же картину видел в прошлом месяце в паре других контор. Где-то спутниковая связь, где-то LTE и даже ADSL, но смысл один - никто не парится настройкой Микротиков. Я не могу понять нафига они тогда там нужны?! Если можно в три раза дешевле взять маршрутер любого нормального вендора, который вообще настраивать не надо и будет в таком же духе всё работать.
Возможно дело в удаленном управлении.. но судя по той школе, это нифига не получается у "спеца".. в какой-то геммор превращается решение проблем..
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
04.01.2019, 19:37
Ответы с готовыми решениями:

Удаленно подключаться к ROS на устройствах Mikrotik
Здравствуйте, хочу winbox'ом подключаться к устройствам, которые живут где-то далеко. Сейчас...

Wine и Diablo 3 RoS
Всем привет. Пытаюсь запустить Diablo 3 RoS в Ubuntu, с помощью Wine и Playonlinux. Battle.net...

Стоит ли докупать Diablo 3 RoS
Прокачал танка вара в Diablo 3. Чтобы играть на уровне сложности выше Обычная рекомендуют...

Изучаю с++
Я начал учить с++ до этого выучил php,js. Но есть пару вопросов например создание папки с помощью...

11
Эксперт по компьютерным сетям
3354 / 1831 / 387
Регистрация: 17.10.2015
Сообщений: 7,922
04.01.2019, 22:19 2

Если честно, за 2 года юзания микротиков, меня тоже уже неоднократно посещала именно такая же мысль: зачем мучаться с кучей настроек, если обязательно гдето "прое...шь" какую-нибудь галочку и не будешь понимать почему не работает. Ведь можно взять зюхель или др. рутер и он, для дома - для семьи будет пахать как миленький.

Я эти мысли отгоняю, т.к. строя то или иное правило, ставя соответствующие галочки и прописывая все возможные ограничения в правиле, ты просто понимаешь как именно работает это правило. Т.е. конкретно что оно делает на аппаратном или программном уровне.

Вспоминаю очень давнешние уроки по алгоритмам.
Задача: Ученик из класса должен вытереть школьную доску. Нужно расписать алгоритм действий.
1) Ученик должен встать из-за стола
2) Пройти до доски
3) Взять с полки доски тряпочку (перед этим нужно еще описать, что он должен поднять одну из рук)
4) Подойти к умывальнику
5) Открыть кран воды (опять же описать какой рукой и какой кран и в какую сторону крутить)
6) Проверить течет ли вода? Если Да, то
а) смочить тряпку и выжать ее
б) закрыть кран
Если нет, то........
вобщем и т.д.

Вот такими алгоритмами ты просто понимаешь как выполняется тот или иной процесс.
Вот в микротике, настраивая те или иные действия ты просто понимаешь КАК оно работает.

Это моё ИМХО!!!
1
50 / 50 / 3
Регистрация: 27.09.2011
Сообщений: 449
05.01.2019, 06:45  [ТС] 3
Вопрос номер раз.

Дома GPON терминал "HUAWEI 8245" от РТ, маршрутизатор XIAOMI MI3 и теперь еще rb750gr3.

Ветки ниже навели на мысль сделать терминал мостом, поднять на микротик PPPOE, а Ксяоми будет точкой доступа 5Гц.

Вопрос: Надо сделать так, чтобы микротик переподключался к оператору, когда видит выданный серый ip.
Т.е. у нас такой прикол у РТ: когда у них проблемы, выдают ip на 5. и на 10., на них инет либо с низкой скоростью, либо работает не стабильно вообще. Ну и соответственно обычно как только начинает что-то тупить, лезешь в терминал, видешь серый ip, перезагружаешь и так может до трех-четырех раз быть, пока не выдадут ip на 77., тогда норм.
Знаю, что по таким же проблемам с LTE свистками в разных кастомных прошивках используют скрипты, которые наблюдают и перезагружают свисток вовремя.
Тут в ветке тоже про скрипты читал. Но не понимаю, где брать или как писать, пока в это не лез (не читал). Возможно есть способ уже готовый в РоутерОС.

Добавлено через 1 час 14 минут
Есть момент,
когда микротик раздавал свои стандартные адреса 192.168.88.хх, то принтер, подключенный к Xiaomi Mi 3 по USB, не появляется в сети. Есть специальная утилита для поиска принтера, подключенного к прошивкам Падаван (или Асус), она тоже не находит ни принтер, ни устройство (xiaomi).
Если заменить адреса внутри сети на 192.168.1.хх , то всё отлично работает, как и ранее в связке с другими маршрутизаторами или отдельно.
Возможно это где-то уже описано.
0
Эксперт по компьютерным сетям
3354 / 1831 / 387
Регистрация: 17.10.2015
Сообщений: 7,922
05.01.2019, 08:31 4
Цитата Сообщение от Leks3117 Посмотреть сообщение
Надо сделать так, чтобы микротик переподключался к оператору, когда видит выданный серый ip.
как то раз натыкался в сети на скрипт, который проверял тип ip-адреса и выполнял соответствующие действия. Можещь нашего криптописателя NoNaMe попросить за чашку пива написать.

Цитата Сообщение от Leks3117 Посмотреть сообщение
Если заменить адреса внутри сети на 192.168.1.хх , то всё отлично работает
на счет этого - ХЗ
0
853 / 308 / 41
Регистрация: 16.05.2014
Сообщений: 2,392
11.01.2019, 10:23 5
Цитата Сообщение от Leks3117 Посмотреть сообщение
Какого фига операторы связи (ну тех, что я видел последние два месяца на местах) ставят кучу оборудоания однотипного, когда тут написано, что можно справиться одним роутером?!
Т.е. простой пример:
та же школа, в которой я помогал построить сеть локальную из имеющегося оборудования (создавал тут пару тем). Там же дело закончилось тем, что приехал "спец" от провайдера, и вместо того, чтобы настроить свой (уже стоявший в школе) микротик 951Ui-2HnD на нужные услуги, после того как я его нагло сбил и приспособил, он отобрал этот, поставил такой же новый (но не настроенный), прилепил рядом еще один LTE-модем, еще один такой же микротик, чтобы уже ДРУГой оператор приехал через день (тоже отобрав своё старое оборудование, которое я тоже пристроил) и на него свою wifi-точку повесил тупо, но сделав вид, что прям что-то очень сложное прилепили и важно.. В итоге куча разеток занято, куча проводов, и нифига толком не работает. А самый прикол, что концов не найти, ни паролей, ни настроек, ни объяснений зачем оно всё налеплено.
У провайдеров выездные "админы" совсем не админы, а техники по подключению, которые зачастую слабо разбираются дальше, чем заученные типовые конфигурации данного провайдера. И даже если такой техник будет разбираться, то тратить кучу времени на одно подключение на разбор клиентской конфигурации - совершенно не выгодно для провайдера. Для провайдера нужно в максимально быстрые сроки подключить клиента, а не разбираться в том, что нагородил клиент и пытаться как то встроиться в его конфигурацию.

Цитата Сообщение от Leks3117 Посмотреть сообщение
Вроде как специалист этот должен обладать нужными знаниями, чтобы настроить это всё в "поле" с нуля за пол часика, а то и быстрее.
Выездной техник легко может не разбираться в этом на уровне "настроить за полчаса".

Цитата Сообщение от Leks3117 Посмотреть сообщение
никто не парится настройкой Микротиков. Я не могу понять нафига они тогда там нужны?!
Скорее всего за универсальность. То есть не нужно подбирать под разные типы подключения разное оборудование. Можно взять микротик и быть уверенным что его можно настроить под любой тип подключения. И если завтра этому клиенту придется накрутить конфиг чуть сложнее чем стандартный базовый, то не надо будет менять железку.
1
50 / 50 / 3
Регистрация: 27.09.2011
Сообщений: 449
23.09.2019, 15:40  [ТС] 6
Здравствуйте,

1. Можно ли взять ТД, например Mikrotik SXTsq Lite5, и сделать из нее роутер?)

Изучаю ROS


На мысль наводит вот этот режим из Быстрых настроек. Для чего надо:
Пример один: ТД, которая база, получает от провайдера IP, как роутер, далее делает свою обычную работу - создает мост. ТД такая же на прием, далее например ТД в доме, если не нужны провода, или роутер тот же хап лайт. Так то в быту ничего не требуется сверхъестественного, должно же ее (Mikrotik SXTsq Lite5) ресурсов хватить быть домашним роутером и мостом одновременно?)

2. Инжекторы POE от Микротик подойдут любому другому оборудованию POE? Или нет?

Я тут давече хотел ТД Zyxel (какую-то там облачную) повесить нормально на потолок по среди класса, чтоб розетку не делать там же, прицепил инжектор микротик, а оно ниче не происходит.. Это я потом узнал, что данная ТД младшая в модельном ряду, и она только от адаптера живет. Но всё же интересно на будущее))

3. Как-то тут описывал проблему с коммутаторами Eltex MES1124M и ТД Микротик. Это когда подключаешь точку доступа в порт коммутатора, а этот порт отрубается, пока не дернешь коммутатор из розетки.
Я где-то читал что-то непонятное, о том, что у микротика POE какое-то "особенное" и надо обратный обжим применять.. Это бред? или если не бред, то что конкретно можно попробовать? Надо как-то подружить эти штуки, чтобы не применять между ними маршрутизатор.
0
50 / 50 / 3
Регистрация: 27.09.2011
Сообщений: 449
23.09.2019, 16:30  [ТС] 7
и еще,
кроме как для 3G\LTE модемов, как-то еще можно задействовать USB порт на Микротик? На hex например, или hap ac lite

Добавлено через 6 минут
в первом вопросе затупил!))) получается это надо на принимающей точке делать) Ну как вариант если потащит, не использовать в доме роутер, а например коммутатор простой, и также сэкономить.

Добавлено через 17 минут
Надо было короче мне сначала подумать хорошо, а потом уже писать первый вопрос))) точнее не писать! Там видимо надо просто лицуху Левел 4 купить и всё будет))
0
Модератор
Эксперт по компьютерным сетям
1109 / 511 / 91
Регистрация: 10.06.2009
Сообщений: 2,044
23.09.2019, 21:15 8
Просто настраивать RouterOS приятнее и удобнее, чем OpenWRT. Так ещё и RouterOS в разы стабильнее, чем открытые платформы. Когда-то у меня стоял D-Link DIR300 на DD-WRT, а за тем и на OpenWRT.
Цитата Сообщение от xeonz Посмотреть сообщение
У провайдеров выездные "админы" совсем не админы.
Когда-то давно работал на одного провайдера выездным специалистом. Точно могу сказать, что всего 30% сотрудников действительно разбираются, остальные просто техники. Тот минимум, что техник должен решить от провайдера они делают. А вот хотелки которые есть, и не входят в регламент, эти 70% сотрудников даже делать не станут. Есть места где Я встречал маршрутизатор на FreeBSD. На настройку потратишь на 20минут больше, но клиент-то доволен.

Добавлено через 26 минут
Leks3117, можно взять и т.д. в роль маршрутизатора. Ресурсов хватит для тривиальных задач.
Инжекторы подходят к любому оборудованию. Они привязанны к стандартам.
Да с некоторыми элтексами только кросовер помогает. На некоторых возможно просто прошивку обновить.

Добавлено через 2 часа 47 минут
Цитата Сообщение от Leks3117 Посмотреть сообщение
Надо сделать так, чтобы микротик переподключался к оператору, когда видит выданный серый ip.
Bash
1
2
3
4
5
6
7
8
9
10
:local interface ether1-pppoe
:local SASip [:toarray "100.64.0.0/10, 10.0.0.0/8, 127.0.0.0/8, 192.168.0.0/16"]
:local interfaceip [/ip address get value-name=address number=[find interface=$interface]]
:foreach i in=$SASip do={
  :if ($interfaceip in $i) do={
    /interface pppoe-client disable $interface
    :delay 10
    /interface pppoe-client enable $interface
  }
}
1
50 / 50 / 3
Регистрация: 27.09.2011
Сообщений: 449
24.09.2019, 05:52  [ТС] 9
NoNaMe, всё понятно, спасибо) буду пробовать.

Вчера попробовал из Mikrotik SXT Lite5 сделать роутер. Есть еще Mikrotik LHG 5 , подключу ее на прием, посмотрю на результат, маленький экзамен для себя)))

Не по теме:

Если бы не ваша помощь и других не равнодушных (форумы, видеоролики) фиг бы когда пришел прогресс в наш край!)) так наверное по всей стране всё к лучшему двигается.



Добавлено через 3 часа 40 минут
получилось вроде бы, долго тупил почему инета нет, про NAT забыл..

Сравнил характеристики LHG 5, SXT lite, SXTsq с роутером hap lite, который в быту отлично вывозит. По идее производительность одинаковая. Осталось придумать как это использовать для экономии не в ущерб.
0
50 / 50 / 3
Регистрация: 27.09.2011
Сообщений: 449
27.09.2019, 15:34  [ТС] 10
Цитата Сообщение от Leks3117 Посмотреть сообщение
Как-то тут описывал проблему с коммутаторами Eltex MES1124M и ТД Микротик. Это когда подключаешь точку доступа в порт коммутатора, а этот порт отрубается, пока не дернешь коммутатор из розетки.
Я где-то читал что-то непонятное, о том, что у микротика POE какое-то "особенное" и надо обратный обжим применять.. Это бред? или если не бред, то что конкретно можно попробовать? Надо как-то подружить эти штуки, чтобы не применять между ними маршрутизатор.
История получила продолжение))
Выше писал, что хотел настроить точку доступа Роутером. Ну вот, снова мост надо было помочь сделать. Взял SXTsq Lite5, настроил роутером базу, с первого раза даже интернет заработал))) порадовался за себя)) Пошли с представителем провайдера вешать. Я ему предложил потратить время чутка и проверить будет ли отваливаться порт на их вездесущих "Элтексах" или нет, если напрямую в него воткнем точку (без прокладки в виде маршрутизатора копеешного). Ну он и не отвалился!))) Т.е. прошивку не трогали коммутатора (нам туда и доступа нет), кросс не попробовал даже. Разница с предыдущими тремя экспериментами только в режиме работы ТД.
0
Эксперт по компьютерным сетям
3354 / 1831 / 387
Регистрация: 17.10.2015
Сообщений: 7,922
27.09.2019, 16:28 11
Цитата Сообщение от Leks3117 Посмотреть сообщение
Взял SXTsq Lite5, настроил роутером базу
у Lite уровень лицензии 3 (т.е. только точка-точка) Зачем роутером настраивать? Этот девайс со своей лицензией будет работать только с одним устройством.
0
50 / 50 / 3
Регистрация: 27.09.2011
Сообщений: 449
28.09.2019, 02:28  [ТС] 12
Цитата Сообщение от romsan Посмотреть сообщение
Зачем роутером настраивать?
Чтобы экономить на устройствах. Там не нужно чтобы к ней подключались беспроводные клиенты. Ее задача по прежнему передать сигнал на станцию. Но теперь она "обманывает" дурной коммутатор оператора. А раньше приходилось ставить "прокладку" в виде Mercusys MW301R или его дешевых собратьев. Итог: тыща рублей экономии и одной розеткой в шкафу меньше занимается, чему все очень рады))
А точка получает ip от коммутатора, и выдает ip станции и роутеру за ней. Вот и вся работа по сути.

А вообще можно ведь за станцией теперь вешать коммутатор простой неуправляемый за 500-800р и всё)) нужен вифи? пускай цепляют ТД в помещении. Не нужен? провода в устройства. Тут село, народ копейки считать умеет. Потому хорошо, что это оборудование так умеет работать, я очень рад
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
28.09.2019, 02:28

Изучаю Yii
изучаю Yii,меняя сайт построенный на yii. там стили прописаны в хеде, не включены, а...

Изучаю AsynkTask
Пытаюсь через AsynkTask получить get запрос и вывести объекты из ссылки. Но судя по логам сервера...

Изучаю Пхп
узучаю пхп и меня начали мучать сомнения смогу ли осилить....у всех все сразу получалось?? дают...

изучаю классы
Начал изучать класс. Вот использую коструктор, но не пойму где ошибка. файл.h #include...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.