Форум программистов, компьютерный форум, киберфорум
Mikrotik
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
NoNaMe
Модератор
Эксперт по компьютерным сетям
1054 / 459 / 85
Регистрация: 10.06.2009
Сообщений: 1,956
Завершенные тесты: 1
1

NAT Преобразование сетевых адресов

30.08.2019, 18:42. Просмотров 1012. Ответов 1

Всем известно понятие NAT (Network address translation) Преобразование сетевых адресов. Давайте разберёмся подробнее.
Самый задаваемые вопрос про NAT это NAT Hairpinning и NAT Loopback

NAT Reflection - относится к возможности доступа к внешним услугам из внутренней сети с использованием внешнего IP-адреса, так же, как если бы клиент находился в Интернете.
Классический пример:
Bash
1
2
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
NAT Loopback - классический проброс порта с применением NAT Hairpinning. Вы заходите на ваш внешний IP адрес, а на самом деле на локальное устройство находящяяся в той-же сети.
Bash
1
2
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=80 in-interface-list=WAN protocol=tcp to-addresses=192.168.0.3
NAT Hairpinning - то-же самое что NAT Loopback, но мы находимся в другой сети (В отдельной от сервиса к которому хотим получить доступ), и не можем взаимодействовать с сетью кроме как через маршрутизатор.
Bash
1
2
3
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=80 in-interface-list=HairPin protocol=tcp to-addresses=192.168.0.3
add action=masquerade chain=srcnat comment="NAT Hairpinning" protocol=tcp src-port=80 src-address=192.168.0.3
NAT Traversal - это набор возможностей, позволяющих сетевым приложениям определять, что они находятся за устройством, обеспечивающим NAT.
Bash
1
2
/ip firewall nat
add action=netmap chain=dstnat dst-port=3389 in-interface-list=WAN protocol=tcp to-addresses=192.168.0.3
И так прошу вашей помощи в дополнении вышеуказанных понятий.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.08.2019, 18:42
Ответы с готовыми решениями:

Преобразование сетевых адресов NAT
Доброго времени суток, возникла проблема при настройке NAT/PAT на маршрутизаторе. Прикрепил файл с...

Файл преобразования сетевых адресов
Форумчане! Подскажите, пожалуйста, какой файл в 64-разрядной версии Windows 7 Professional SP1...

NAT\NAPT-Определение факта использования транслятора адресов
Здрасте всем. Ситуация: нужно установить беспроводной маршрутизатор для раздачи интернета в малой...

2008R2 NAT + настройка пула адресов, резервирование ip, статический маршрут
Добрый день, Сервер 2008 R2 std Работает как шлюз, две сетевые. Одна смотрит в интернет, вторая...

1
NeoMatrix
Модератор
Эксперт NIX
6052 / 1607 / 94
Регистрация: 24.05.2011
Сообщений: 11,653
Записей в блоге: 6
31.08.2019, 02:01 2
NAT - работа через шлюз. Через маршрутизатор, в общем.
Работает эта технология примерно вот так.
Для сервера во внешней сети и клиента в локальной:
Клиент обращается к серверу во внешней сети, например к 1.2.3.4, имея адрес в локальной 192.168.1.2 и WAN-адрес маршрутизатора 123.123.123.123
Маршрутизатор принимает пакет, читает адрес отправителя 192.168.1.2, адрес получателя 1.2.3.4 , подставляет в поле "отправитель" значение 123.123.123.123 и отправляет его в WAN интерфейс. Кроме этого вносит в таблицу NAT два значения 192.168.1.2 и 1.2.3.4.
Пакет приходит в 1.2.3.4
1.2.3.4 принимает пакет и видит в поле "отправитель" значение 123.123.123.123, обрабатывает пакет и отправляет ответ (актуально для протокола TCP) на 123.123.123.123
Маршрутизатор принимает входящий пакет на WAN-интерфейсе от 1.2.3.4 и, находя в вышеозначенной таблице эту пару значений, заменяет отправитель 1.2.3.4 на 192.168.1.1, а получатель 123.123.123.123 на 192.168.1.2, а затем отправляет пакет в LAN-интерфейс.
Таким образом, маршрутизатор постоянно во всех проходящих через него (LAN-WAN и обратно) пакетах заменяет значения отправитель и получатель на собственные 192.168.1.1 для LAN и 123.123.123 для WAN
Для случая "клиент во внешней, сервер во внутренней сетях" происходит всё ровно то же самое, но в обратную сторону и, для обеспечения работоспособности и безопасности маршрутизатору требуется знать, на котором из LAN-IP находится сервер, а посему, для которого из LAN-IP требуется открыть доступ по какому из портов.
"Порт" подразумевает здесь - к какому типу приложений относятся предназначаемые серверу пакеты. Это могут быть WEB страницы, POP3 и SMTP контент электронной почты, FTP контент файл-сервера и т.д. Каждый контент предназначается конкретному приложению на сервере. И, соответственно, все эти типовые приложения пронумерованы: WEB - 80 порт, POP3 на 110, SMTP на 25, IMAP (ещё один почтовый протокол) на 143 портах и т.д.
Маршрутизатор учитывает это и, например, если ваш WEB-сервер находится на 192.168.1.3, а почтовый сервер на 192.168.1.15, но, при этом, пакеты отправляемые клиентом на WAN на 192.168.1.15 идут по протоколу HTTP (то бишь, предназначаются 80 порту), а пакеты на 192.168.1.2 идут по протоколу FTP (порт 21), то эти пакеты будут потеряны и в LAN не попадут, потому что в таблице NAT на данных LAN-IP эти порты не открыты.

Вообще же, если вы понимаете механизм работы маршрутизатора, то, КМК, у вас не должно возникнуть существенных трудностей для настройки NAT.
Сложности, в принципе, могут возникнуть только в том, как должно взаимодействовать с данным конкретным маршрутизатором. Но это, к сожалению, я вам прояснить однозначно не могу, ибо это зависит от модели и ОСи на маршрутизаторе, что выражается в таких нюансах. как синтаксис командной строки (команд, отправляемых в маршрутизатор) или графический интерфейс. В остальном, логика работы с ними одинакова.
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.08.2019, 02:01

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Сбор MAC-адресов сетевых принтеров с использованием SnmpGet
Добрый день! Возникла потребность сбора по сети mac-адресов принтеров, найденный готовый скрипт...

Как построить дерево всех достижимых сетевых адресов?
Здравствуйте. Хотелось бы узнать как построить список достижимых адресов и для них получить все...

Сети - статическое преобразование NAT для своих внутренних сетей
Нужна помощь с решением теста, эта один из вопросов в нем. Оба маршрутизатора, R1 и R2,...

WPF: Не работают библиотеки Open.NAT, Mono.NAT
Доброго времени суток! Хочу витащить свой IP. У меня "серый ip". (кто не в курсе го в Википедию)...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.