Форум программистов, компьютерный форум, киберфорум
Mikrotik
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
0 / 0 / 0
Регистрация: 10.02.2020
Сообщений: 101
1

настройка vlan через bridge

10.02.2020, 10:02. Просмотров 867. Ответов 8
Метки нет (Все метки)


Есть vlan name=con id = 10. Этот vlan должен быть на 3 интерфейсах ethernet допустим. Для этого:
/interface bridge: add name=br_vlan10-system vlan-filtering=yes
/interface vlan: add name=system vlan-id=10 interface=br_vlan10-system

Теперь в этот bridge добавляем те самые 3 интерфейса ethernet. Я правильно понял?

И еще вопрос. Допустим на этих интерфейсах ethrnet в каждом свой отдельный vlan кроме этого vlan(id=10):
ethernet1: name=vlan100 interface=ethernet1 vlan-id=100
ethernet2: name=vlan200 interface=ethernet2 vlan-id=200
ethernet3: name=vlan300 interface=ethernet3 vlan-id=300

То есть 1 vlan(id=10) общий. И на каждом свой отдельный еще.

Для этих отдельных vlan тоже надо bridge делать?

Добавлено через 24 минуты
И еще если таких общих vlan допустим 2. id=10 и id=20
Для этих 2 общих надо 1 bridge делать или для каждого свой?
Если для каждого свой делать то не получается 1 интерфейс добавить на несколько bridge
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
10.02.2020, 10:02
Ответы с готовыми решениями:

Настройка модема в bridge mode.
Проблема заключается в следующем. На компьютере с Windows 7 LAN модем работает в режиме моста. IP...

Настройка Vlan
Добрый день. что-та не могу разобраться с вланами, подскажите пожалуйста. допустим есть DIR-615...

VLAN создание и настройка
Заранее извиняюсь если такая тема уже была. Прошу дать ссыль на информацию по созданию и настройке...

Настройка элементарного VLAN
Я еще совсем новичок, нужна помощь! Задача - настроить VLAN на Zyxel Keenetic Lite c с прошивкой...

8
7 / 6 / 1
Регистрация: 07.02.2020
Сообщений: 46
10.02.2020, 12:52 2
Это инструкции для Cisco. Можете ли вы указать свой роутер и дать картину настроек.
0
0 / 0 / 0
Регистрация: 10.02.2020
Сообщений: 101
10.02.2020, 13:58  [ТС] 3
ProblemSolver, у меня не роутер а маршрутизатор. SRC328-24P-4S+RM
0
Модератор
Эксперт по компьютерным сетям
1096 / 498 / 91
Регистрация: 10.06.2009
Сообщений: 2,019
10.02.2020, 18:11 4
poihgvc, опишите подробнее задачу. Вы хотите маршрутизировать или быть просто свитчём?
0
0 / 0 / 0
Регистрация: 10.02.2020
Сообщений: 101
10.02.2020, 23:14  [ТС] 5
NoNaMe, маршрутизировать. К mikritik подключены коммутаторы d-link. Всего 9 подсетей 172.20.0.0/16 - 172.29.0.0/16.
На скрине список vlan на каждый интерфейс. Я сделал через bridge но сомневаюсь что правильно все сделал, а проверить нет возможности.
И еще стоит ли vlan в моем случае реализовывать через чип коммутации switch или не будет существенной разницы между switch и bridge(в плане нагрузки на цп)
0
Миниатюры
настройка vlan через bridge  
0 / 0 / 0
Регистрация: 10.02.2020
Сообщений: 101
10.02.2020, 23:17  [ТС] 6
ether10 и ether11 это 172.20.0.0/16 на 2 интерфейса
0
Эксперт по компьютерным сетям
3445 / 1264 / 213
Регистрация: 23.06.2009
Сообщений: 4,467
11.02.2020, 18:58 7
вот здесь с картинками и кусками конфига, посмотрите
0
Эксперт по компьютерным сетям
3009 / 1710 / 362
Регистрация: 17.10.2015
Сообщений: 7,395
11.02.2020, 23:14 8
Цитата Сообщение от poihgvc Посмотреть сообщение
у меня не роутер а маршрутизатор
а это разве не одно и то же?
0
Эксперт по компьютерным сетям
8394 / 5625 / 1396
Регистрация: 25.12.2012
Сообщений: 23,855
13.02.2020, 11:55 9
1. Block Diagram

2. конфигурация L2

Код
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface bridge port
add bridge=bridge1 interface=ether1 hw=yes
add bridge=bridge1 interface=ether2 hw=yes
add bridge=bridge1 interface=ether3 hw=yes
add bridge=bridge1 interface=ether4 hw=yes
add bridge=bridge1 interface=ether5 hw=yes
add bridge=bridge1 interface=ether6 hw=yes
add bridge=bridge1 interface=ether7 hw=yes
add bridge=bridge1 interface=ether8 hw=yes
add bridge=bridge1 interface=ether9 hw=yes
add bridge=bridge1 interface=ether10 hw=yes
add bridge=bridge1 interface=ether11 hw=yes
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11 vlan-ids=10
add bridge=bridge1 tagged=bridge1,ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11 vlan-ids=110
add bridge=bridge1 tagged=bridge1,ether10,ether11 vlan-ids=120
add bridge=bridge1 tagged=bridge1,ether1 vlan-ids=121
add bridge=bridge1 tagged=bridge1,ether2 vlan-ids=122
add bridge=bridge1 tagged=bridge1,ether3 vlan-ids=123
add bridge=bridge1 tagged=bridge1,ether4 vlan-ids=124
add bridge=bridge1 tagged=bridge1,ether5 vlan-ids=125
add bridge=bridge1 tagged=bridge1,ether6 vlan-ids=126
add bridge=bridge1 tagged=bridge1,ether7 vlan-ids=127
add bridge=bridge1 tagged=bridge1,ether8 vlan-ids=128
add bridge=bridge1 tagged=bridge1,ether9 vlan-ids=129
add bridge=bridge1 tagged=bridge1,ether10 vlan-ids=200
add bridge=bridge1 tagged=bridge1,ether11 vlan-ids=210
add bridge=bridge1 tagged=bridge1,ether1 vlan-ids=211
add bridge=bridge1 tagged=bridge1,ether2 vlan-ids=212
add bridge=bridge1 tagged=bridge1,ether3 vlan-ids=213
add bridge=bridge1 tagged=bridge1,ether4 vlan-ids=214
add bridge=bridge1 tagged=bridge1,ether5 vlan-ids=215
add bridge=bridge1 tagged=bridge1,ether6 vlan-ids=216
add bridge=bridge1 tagged=bridge1,ether7 vlan-ids=217
add bridge=bridge1 tagged=bridge1,ether9 vlan-ids=219
add bridge=bridge1 tagged=bridge1,ether2,ether3,ether4,ether5,ether6,ether7,ether10,ether11 vlan-ids=411
add bridge=bridge1 tagged=bridge1,ether8 vlan-ids=2801
add bridge=bridge1 tagged=bridge1,ether8 vlan-ids=2802
3. конфигурация L3

Код
/interface vlan
add interface=bridge1 name=bridge1_vlan10 vlan-id=10
add interface=bridge1 name=bridge1_vlan110 vlan-id=110
........

/ip address
add address=X.X.X.X/X interface=bridge1_vlan10 
add address=X.X.X.X/X interface=bridge1_vlan110 
........
4.
Всего 9 подсетей
Всего подсетей столько же, сколько и VLAN. VLAN у вас явно больше 9.
Каждая VLAN - изначально отдельная подсеть, просто вы можете не поднимать в какой-либо VLAN L3-интерфейс на микротике (см п.3) и не задавть ему адрес, а тупо гонять VLAN на втором уровне между портами (см. п.2).
Чтобы vlan маршрутизировались на микротике (intervlan routing), должен быть поднят L3-интерфейс этих VLAN (см. п3)

5.
И еще стоит ли vlan в моем случае реализовывать через чип коммутации switch или не будет существенной разницы между switch и bridge(в плане нагрузки на цп)
на wiki mikrotik есть даже рекомендации по настройке VLAN для свитчей CRS3xx series, CRS1xx/CRS2xx series, а так же иных устройств со встроенным switch-чипом, и без него
и как вы можете заметить, свитчи CRS3xx series рекомендуется настраивать через bridge - vlan
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
13.02.2020, 11:55

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь или здесь.

Настройка VLAN на EdgeSwitch 24-250
На микротике RB3011 настроена гостевая сеть на Vlan20 через бридж. Соответственно на тарелке UniFi...

Настройка тегированного и нетегированного VLAN
Доброго времени суток! Имеем: Dlink DGS-1210-52. На нем настроены три Vlan 1 - дефолтный, 41 -...

Настройка Vlan на Dir 100
Добрый день друзья! Объясните пожалуйста что делаю не так... Пытаюсь настроить VLAN на DIR 100...

Mikrotik настройка интернета на Vlan
Здравствуйте. Есть MikroTik RB750r2, в первый порт воткнут интернет, во второй порт кабель к...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.