0 / 0 / 0
Регистрация: 24.03.2022
Сообщений: 16
1

l2tp+ipsec как сделать так чтобы клиенты видели друг друга?

21.09.2022, 10:22. Показов 345. Ответов 5

Здравствуйте! У меня на Miktotik настроен l2tp+ipsec, сотрудники подключаются и видят офисную сеть. При подключении клиенту выдается IP адрес 10.10.1.ххх. Клиенты пингуют шлюз 10.10.1.1 но не видят друг друга. Можно ли сделать так чтобы была связь и между клиентами? В OpenVPN для этого была настройка client-to-client, а как в Mikrotik?
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
21.09.2022, 10:22
Ответы с готовыми решениями:

Как соединить два канал интернета чтобы они видели друг друга?(Компьютеров)
У меня на предприятии есть 2 белые IP интернета, на один из них установлено все наше локалные сеть...

как настроить чтобы два компа друг друга видели
мне маршутизатор устоновили d-link dir300 , блин ковырялся в сетевом окружении ,пробовал...

Как сделать так, чтобы 2 сервера друг друга видели
всем привет, уважаемые форумчане! ситуация такова: ранее 2 сервера стояли в одном офисе. где-то...

Как сделать чтобы блоки не видели друг друга?
Написал скрипт, который вставляет блоки разных размеров, цветов и с различными выравниваниями и...

Как сделать чтобы подсети под управлением NAT видели друг друга?
Добрый день. Есть 3 филиала с ip адресами: 1. 10.105.54.12 2. 10.105.195.1 3. 10.105.233.1...

5
Эксперт по компьютерным сетям
10436 / 6655 / 1753
Регистрация: 25.12.2012
Сообщений: 28,235
21.09.2022, 13:56 2
у обоих клиентов основной шлюз в туннель?
0
0 / 0 / 0
Регистрация: 24.03.2022
Сообщений: 16
21.09.2022, 16:39  [ТС] 3
Нет, основной шлюз не менял, он родной от провайдера чтобы трафик ходил не через ВПН. Для работы с сетью офиса добавлен маршрут:
Код
route add -p 192.168.9.0 mask 255.255.255.0 10.10.1.хх
где 192.168.9.0 - сеть офиса, а 10.10.1.хх - IP клиента
Чтобы направить запросы от 10.10.1.3 к 10.10.1.4, я добавил маршрут:
Код
route add 10.10.1.0 mask 255.255.255.0 10.10.1.1
и я вижу по tracert что запрос уходит на шлюз 10.10.1.1 (т.е. на микротик) но дальше не идет.
Складывается ощущение что либо микротик не знает по сеть 10.10.1.хх (что странно) либо на микротике не хватает еще какой-то маршрутизации
0
Эксперт по компьютерным сетям
10436 / 6655 / 1753
Регистрация: 25.12.2012
Сообщений: 28,235
22.09.2022, 10:31 4
на mikrotik покажите из new terminal
Код
ip firewall export compact
Цитата Сообщение от JMLabs Посмотреть сообщение
Чтобы направить запросы от 10.10.1.3 к 10.10.1.4, я добавил маршрут:
Код
Выделить код
route add 10.10.1.0 mask 255.255.255.0 10.10.1.1
у обоих клиентов?

на клиентах брандмауэр выключен? антивируса нет никакого? сетевой экран антивируса так же может блокировтаь ICMP и все остальной на вход
0
0 / 0 / 0
Регистрация: 24.03.2022
Сообщений: 16
22.09.2022, 16:27  [ТС] 5
Вот правила

Код
/ip firewall address-list
add address=77.88.8.8 list=host-remote
add address=8.8.8.8 list=host-remote
add address=192.168.9.0/24 comment="main lan" list=lan
add address=10.10.5.0/24 comment=vpn list=lan
add address=192.168.11.0/24 comment="vlan 101" list=lan
/ip firewall filter
add action=accept chain=input comment="accept e/r" connection-state=established,related
add action=accept chain=input comment="accept icmp" protocol=icmp
add action=accept chain=input comment="accept dstnat" connection-nat-state=dstnat
add action=accept chain=input comment="accept l2tp" dst-port=1701,500,4500 in-interface=bridge-wan protocol=udp
add action=accept chain=input comment="accept ipsec" protocol=ipsec-esp
add action=drop chain=input comment="drop all input" in-interface=bridge-wan
add action=drop chain=forward comment="drop invalid" connection-state=invalid
add action=accept chain=forward comment="accept e/r" connection-state=established,related
add action=accept chain=forward in-interface=bridge-wan
add action=accept chain=forward comment="accept dst-nat" connection-nat-state=dstnat connection-state=""
add action=accept chain=forward comment="accept from local" in-interface=bridge-local
add action=accept chain=forward comment="accept from vlan 11" in-interface=bridge_11
add action=accept chain=forward comment="accept wan bridge" in-interface=bridge-wan
add action=accept chain=forward comment="accept vpn to wan" in-interface=all-ppp out-interface=bridge-wan
add action=accept chain=forward comment="accept vpn to lan" in-interface=all-ppp out-interface=bridge-local
add action=accept chain=forward comment="accept vpn to vlan" in-interface=all-ppp out-interface=bridge_11
add action=drop chain=forward comment="drop any"
/ip firewall nat
add action=src-nat chain=srcnat comment="lan masquerade" out-interface=bridge-wan src-address-list=lan to-addresses=85.14.17.242
/ip firewall service-port
set sip sip-timeout=5m
Цитата Сообщение от insect_87 Посмотреть сообщение
у обоих клиентов?
да, у обоих.
Антивирусов нет, файрвол отключен
0
Эксперт по компьютерным сетям
10436 / 6655 / 1753
Регистрация: 25.12.2012
Сообщений: 28,235
23.09.2022, 08:59 6
создайте правило:
Код
/ip firewall filter
add action=accept chain=forward comment="accept vpn to vlan" in-interface=all-ppp out-interface=all-ppp
и поставьте его выше правила:
Код
add action=drop chain=forward comment="drop any"
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
23.09.2022, 08:59
Помогаю со студенческими работами здесь

Как сделать так, чтобы круги не залезали друг на друга
Здравствуйте, собрав информацию по всему интернету - получил что-то вот такое: <!DOCTYPE html>...

Как сделать так, чтобы разные файлы могли видеть друг друга?
Есть 2 формы. Одна вызывает другую. Есть класс, который подключается к 1-ой форме. Но когда я...

Сделать так чтобы буквы не налазили друг на друга
uses crt, GraphABC; Const Image_1='fox.bmp'; {Фон додатка} // Image_2='1.bmp'; ...

Я не могу сделать так, чтобы 3 цвета сменяли друг друга по очереди
Здравствуйте, у меня получилось сделать только 2 цвета. вот код: public void Start() {...

Сделать так, чтобы объекты по бокам экрана расставлялись рандомно, но на расстоянии друг от друга
Привет. Работаю в Unity. Мне нужно сделать так, чтобы объекты по бокам экрана расставлялись...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru