Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.88/8: Рейтинг темы: голосов - 8, средняя оценка - 4.88
0 / 0 / 0
Регистрация: 04.03.2014
Сообщений: 2
1

Генерация ПИН-кодов по определенным условиям

04.03.2014, 10:32. Просмотров 1579. Ответов 4
Метки нет (Все метки)


Необходимо сгенерировать 100 тыс. 12-значных ПИН-кодов по следующей маске: ППППRRХХХХХХ, где:
ПППП – префикс (например 2014);
RR – защитный код по определенному алгоритму разницы сумм четных и нечетных цифр номера ХХХХХХ;
ХХХХХХ – порядковое число от 000001 до 100000.
Помогите, кто может! Уже всю голову сломал.
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
04.03.2014, 10:32
Ответы с готовыми решениями:

Данные в таблице по определенным условиям
Доброго всем дня. Возникла следующая проблема. Есть таблица с определенными столбцами по контролю...

Выборка из одного листа на другой по определенным условиям
Здравствуйте, помогите пожалуйста сделать выборку данных из одного листа на другой по определенным...

Геопозиционирование по определенным условиям
Принципиальная реализуемость следующего: Мобильное приложение, позволяющее отбирать пользователей...

Сформировать список по определенным условиям
Имеются метеоданные о среднемесячной температуре по всем месяцам в ряде стран (Англия. Германия,...

__________________
Помогаю в написании курсовых работ и дипломов здесь.
4
3374 / 2075 / 680
Регистрация: 02.11.2012
Сообщений: 5,432
04.03.2014, 11:52 2
вариант:
в А1
Код
=ТЕКСТ(СТРОКА();"000000")
в В1 формула массива
Код
=ТЕКСТ(ABS(СУММ(--ЕСЛИ(ОСТАТ(ПСТР(A1;СТРОКА($1:$6);1);2)=0;ПСТР(A1;СТРОКА($1:$6);1);0))-СУММ(--ЕСЛИ(ОСТАТ(ПСТР(A1;СТРОКА($1:$6);1);2)=1;ПСТР(A1;СТРОКА($1:$6);1);0)));"00")
в С1
Код
=СЦЕПИТЬ("2014";B1;A1)
т.к. ограничения эксель то остаток кодов нужно нужно делать в соседнем столбце с корректировкой формул
1
5610 / 2923 / 587
Регистрация: 23.11.2010
Сообщений: 9,709
04.03.2014, 12:01 3
Лучший ответ Сообщение было отмечено Denik705 как решение

Решение

Мой вариант
1
Вложения
Тип файла: rar ПИН.rar (96.9 Кб, 23 просмотров)
0 / 0 / 0
Регистрация: 04.03.2014
Сообщений: 2
04.03.2014, 12:15  [ТС] 4
ОГРОМНОЕ СПАСИБО!
0
5683 / 891 / 298
Регистрация: 25.02.2011
Сообщений: 1,268
Записей в блоге: 1
05.03.2014, 18:16 5
одной формулой, без доп.столбцов:
Код
=2014&ТЕКСТ(ABS(СУММПРОИЗВ(ОСТАТ(0&ПСТР(СТРОКА();{1;2;3;4;5;6};1);10)*(-1)^ОСТАТ(ОСТАТ(0&ПСТР(СТРОКА();{1;2;3;4;5;6};1);10);2)));"00")&ТЕКСТ(СТРОКА();"000000")
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
05.03.2014, 18:16

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь или здесь.

Выбрать/отсеять записи по определенным условиям
есть 2 таблицы - товар и характеристики как оставить товар с выбранными...

Обработка данных в таблицах по определенным условиям
Доброго времени суток! Прошу помочь с со следующим вопросом: Есть таблица A, в ней n строк и 4...

Поиск значений в таблице по определенным условиям
Всем привет, есть большая таблица со столбцами объект, дата, отклонение и столбцы 1,2,3 и...

Замена букв в тексте по определенным условиям
Здравствуйте! Задали написать программу, но довести ее до рабочего состояния у меня не получается ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.