0 / 0 / 0
Регистрация: 29.10.2013
Сообщений: 5
1

MS Excel 2010. Двойное условие

13.07.2014, 15:40. Показов 1462. Ответов 4
Метки нет (Все метки)

Здравствуйте!

Подскажите, пожалуйста, как выполнить двойное условие на суммирование.

У меня есть большая таблица,которая будет расти дальше и в которой 4 поля :

Таблица 1
МесяцНазначение Статья затрат Сумма
4 транспортные расходы траснпортные расходы по товару 300
4 хозрасходы хозрасходы 740
4 транспортные расходы траснпортные расходы по товару 1 000
4 прочие расходы прочие расходы 700

Чтобы каждый раз не собирать pivot и не сбивать ячейки, которые ссылаются на него, я хочу сделать свою сводную таблицу:

Таблица 2

НазначениеСтатья затрат456
 расходы по оплате оборудования (kz)   
 расходы на аренду и содержание зданий   
СМРстроительно-монтажные работы   
 расходы на ремонт основных средств   
 затраты на оплату труда   
транспортные расходытраснпортные расходы по товару   
 транспортные расходы оборудования   
 таможенные платежи по товару   
 таможенные платежи по оборудованию   
 услуги связи   
командировочные расходыкомандировочные расходы   
 расходы на рекламу   
хозрасходыхозрасходы   
 налоговые и прочие отчисления   
 оплата % за пользование кредитами банков   
 услуги банка   
 снятие наличной выручки   
 перевод денег   
прочие расходыпрочие расходы   

Где 4,5, 6 - это номер месяца

Так вот, как прописать формулу, которая будет суммировать скажем все "транспортные расходы" за 4 месяц из таблицы 1 для таблицы 2.

Это что-то наподобие принципа работы " Сводная таблица"
Вложения
Тип файла: xlsx пример с двойным условием.xlsx (34.1 Кб, 15 просмотров)
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
13.07.2014, 15:40
Ответы с готовыми решениями:

Вписать двойное условие ЕСЛИ
Помогите, пожалуйста, вписать двойное условие ЕСЛИ. Есть такое условие: Если если значение...

Переход в ячейку через двойное условие
Вопрос такой как построить слудующий макрос--- допустим есть две колонки выпадающих списков ---...

Excel 2010. Цвет заливки ячеек не переносится в Excel 2003
Добрый день! Закрасил ячейки в Excel 2010 стандартной палитрой по умолчанию. Открываю файл в...

Двойное условие
Доброго времени суток. Возникла такая проблема. Не могу сообразить как синтаксически правильно...

4
5770 / 3029 / 648
Регистрация: 23.11.2010
Сообщений: 10,098
13.07.2014, 15:51 2
Вариант
Код
=СУММПРОИЗВ($D$2:$D$200*($I2=$C$2:$C$200)*(J$1=$A$2:$A$200))
Но Обновлять Сводную все же проще
0
771 / 614 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
13.07.2014, 16:23 3
Ещё вариант.
Код
=СУММЕСЛИМН($D$2:$D$145;$A$2:$A$145;J$1;$C$2:$C$145;$I2)
Вложения
Тип файла: xlsx пример с двойным условием.xlsx (34.1 Кб, 19 просмотров)
0
5770 / 3029 / 648
Регистрация: 23.11.2010
Сообщений: 10,098
13.07.2014, 20:22 4
Добавила сводную согласно таблице
Вложения
Тип файла: xlsx пример с двойным условием.xlsx (39.6 Кб, 13 просмотров)
0
0 / 0 / 0
Регистрация: 29.10.2013
Сообщений: 5
14.07.2014, 08:44  [ТС] 5
Спасибо большое Вам!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
14.07.2014, 08:44

Двойное условие в while
Цикл do..while как сделать так чтоб работало двойное условие? пытался записать в разных вариантах...

Двойное условие в where
Подскажите как реализовать, есть запрос SELECT * FROM table WHERE author = 'writer' AND (title...

Двойное условие
Припустим есть $("input").change(function(){ //действие }); т.е. если изменились данные...

Двойное условие
Здравствуйте, можете подсказать, как объединить 2 скрипта: <Script Language="JavaScript"...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru