101 / 95 / 8
Регистрация: 07.08.2013
Сообщений: 299
1

Подсчет количества ячеек по сложному условию

03.06.2015, 11:44. Показов 2532. Ответов 4
Метки нет (Все метки)

Author24 — интернет-сервис помощи студентам
Собственно проблема такая:
Есть табличка в первом столбце названия серверов (Firewall1,2,3; DHCP1,2,3; Test server1,2,3), во втором их тип (DL380G8,DL380G7,DL380G5,DL380G4).
Как посчитать количество серверов, у которых в названии Firewall и DHCP и тип больше G5?

Через SUMIF(S) или COUNTIF(S) у меня что-то не получилось это реализовать. Т.е. не могу задать условие типа <>("*G5"&"*G4"&"*G3").

Спасибо.
Вложения
Тип файла: xlsx servers.xlsx (9.3 Кб, 10 просмотров)
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
03.06.2015, 11:44
Ответы с готовыми решениями:

Подсчёт количества видимых ячеек соответствующих определенному условию
Пытаюсь реализовать процентное соотношение ответов на вопросы. Необходимо реализовать фильтрацию по...

Подсчет ячеек по заданному условию
Добрый вечер! Помогите со следующей задачей: Имеется книга с двумя листами. Лист1 в столбце А...

Подсчет количества одинаковых ячеек
Здравствуйте. Подскажите, пожалуйста. Имеется 2 столбца с данными, 0 или 1, сгенерированных...

Подсчёт количества значений по условию
Подскажите, пожалуйста, где ошибка в формуле? Нужно посчитать количество значений в столбце D по...

4
6006 / 3200 / 717
Регистрация: 23.11.2010
Сообщений: 10,693
03.06.2015, 12:12 2
Вариант
Вложения
Тип файла: xlsx servers.xlsx (10.5 Кб, 9 просмотров)
0
101 / 95 / 8
Регистрация: 07.08.2013
Сообщений: 299
03.06.2015, 12:30  [ТС] 3
Fairuza, м... не работает.
Нужно считать не отдельно по каждому Firewall1, а количество всех Firewall*

Я не совсем корректный эксель сделал.
Вот корректный.
Вложения
Тип файла: xlsx servers.xlsx (10.0 Кб, 17 просмотров)
0
6006 / 3200 / 717
Регистрация: 23.11.2010
Сообщений: 10,693
03.06.2015, 13:11 4
Тогда такой вариант в Е1
Код
 =СУММПРОИЗВ((--ЕЧИСЛО(ПОИСК(D1&"*";$A$1:$A$11)))*(ПРАВСИМВ($B$1:$B$11;1)*1>5))
1
101 / 95 / 8
Регистрация: 07.08.2013
Сообщений: 299
03.06.2015, 14:56  [ТС] 5
Fairuza, спасибо, работает.
Вопрос: а как быть если в диапазоне будут пустые ячейки?
0
03.06.2015, 14:56
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
03.06.2015, 14:56
Помогаю со студенческими работами здесь

Подсчет количества записей по условию
Доброго времени суток уважаемые форумчане! Уже поднимал тему про подсчет количества записей по...

подсчёт количества ячеек в формате дата
Помогите с формулой: Нужно подсчитать количество ячеек, в которых введено время в формате...

Подсчет количества ячеек в диапазоне их значений
1. Подсчет количества ячеек в диапазоне их значений. Нужно посчитать, например, в файле в колонке С...

Подсчет количества ячеек из диапазона со временем
Здравствуйте, знатоки!!! Помогите, не могу сообразить, в столбце А дан набор длительностей разной в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2024, CyberForum.ru