0 / 0 / 0
Регистрация: 20.11.2013
Сообщений: 6
1

Поиск слова по 3 или более подряд совпадающих символов текстовой строки в списке с учетом регистра

06.07.2015, 16:57. Показов 1522. Ответов 2
Метки нет (Все метки)

Надо найти в таблице нужное слово и вывести его по 3 и более символам с учетом регистра.
Миниатюры
Поиск слова по 3 или более подряд совпадающих символов текстовой строки в списке с учетом регистра  
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
06.07.2015, 16:57
Ответы с готовыми решениями:

Ввод с клавиатуры произвольной текстовой строки длинной не более 50 символов и многократный подсчет числа
Ввод с клавиатуры произвольной текстовой строки длинной не более 50 символов и многократный подсчет...

Ввод с клавиатуры произвольной текстовой строки длиной не более 50 символов (использовать тип string[50]) и многократный
Ввод с клавиатуры произвольной текстовой строки длиной не более 50 символов (использовать тип...

Замена символов в строке с учетом регистра
В программе слоги с большой буквы ("Ма") при замене на цифры (11) меняются на те же слоги, но с...

Как организовать проверку пароля с учетом регистра символов
private void button1_Click(object sender, EventArgs e) { try { ...

2
5889 / 3115 / 684
Регистрация: 23.11.2010
Сообщений: 10,414
06.07.2015, 18:25 2
Лучший ответ Сообщение было отмечено Podkop как решение

Решение

Код
=ИНДЕКС(C2:C5;ПОИСКПОЗ("*"&F2&"*";C2:C5;0);1)
Добавлено через 7 минут
Попробуйте еще такую формулу массива
Код
=ИНДЕКС(C2:C5;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(НАЙТИ(F2;C2:C5));0);1)
1
0 / 0 / 0
Регистрация: 20.11.2013
Сообщений: 6
06.07.2015, 19:01  [ТС] 3
Спасибо большое! 1 Вариант самое то!!!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.07.2015, 19:01
Помогаю со студенческими работами здесь

Поиск буквы в строке с учётом регистра
Если есть какие-то идеи, плиз, хелп. Функция InStr ищет букву в слове, но без учёта регистра...

Удалить все слова из заданной строки длинной более k символов
Написать программу, которая удаляет все слова из заданной строки длинной более k ...

Выполнить перевод всех символов этой строки из верхнего регистра в нижний, а из нижнего регистра в верхний
1. Ввести множество, запись или строку с помощью клавиатуры. 2. Вывести на экран монитора исходную...

Текст, состоящий не более чем из 255 символов, разбить на строки длиной не более 50 символов в строке
Текст, состоящий не более чем из 255 символов, разбейте на строки длиной не более 50 символов в...

Вводим строку не более 40 символов и выводим в одномерный массив все слова этой строки
Вводим строку не более 40 символов и выводим в одномерный массив все слова этой строки

Удалить из строки слова, содержащие четное кол-во символов. Слова в строке разделены одним или несколькими пробелами. По
Удалить из строки слова, содержащие четное кол-во символов. Слова в строке разделены одним или...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru