Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
k_rothe
0 / 0 / 0
Регистрация: 03.01.2014
Сообщений: 64
1

Разделить данные в ячейках

06.09.2015, 21:51. Просмотров 997. Ответов 1
Метки нет (Все метки)

Здравствуйте, у меня есть список из 1000 почтовых адресов, выгрузка в excel не всегда корректна.
Как мне разделить почтовые адреса на 6 строчке на листе "есть" (отметил желтым), чтобы было как на листе "должно быть"?
e-mail.xlsx
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.09.2015, 21:51
Ответы с готовыми решениями:

Сопоставить данные в ячейках
Привет. Приложил файлик. Столбец А разные фразы, столбец B числовое значение. В столбце D те...

Не правильно объединяет данные в ячейках
Всем привет! Есть табличка с номером шва, у которого есть дефект, дефектов может быть сколько...

Нужно отсортировать правильно данные в ячейках от большего к меньшему по типу
нужен макрос для обработки столбца в таблице. Поставщик даёт состов товара. нужно отсортировтаь...

Как сменить формат в столбце оставив неизменными данные в ячейках этого столбца
Здравствуйте.Подскажите решение,формат всех ячеек столбца F "ч : м" в ячейках данные записаны в...

1
AlexM
2254 / 1605 / 658
Регистрация: 04.09.2015
Сообщений: 3,189
06.09.2015, 22:19 2
Лучший ответ Сообщение было отмечено chumich как решение

Решение

Формула массива
Код
=ИНДЕКС(есть!A$1:I$1000;НАИМЕНЬШИЙ(ЕСЛИ(есть!A$1:I$1000<>"";СТРОКА(есть!A$1:I$1000)*10+СТОЛБЕЦ(есть!A$1:I$1000));СТРОКА(A1))/10;--ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(есть!A$1:I$1000<>"";СТРОКА(есть!A$1:I$1000)*10+СТОЛБЕЦ(есть!A$1:I$1000));СТРОКА(A1))))
На листе "есть" текст по столбцам с разделителем точка с запятой.
Формула обработает таблицу в 1000 строк, до 9 адресов в строке.
Возможна медленная работа. Для ускорения нужен макрос.
1
Вложения
Тип файла: xls e-mail.xls (35.5 Кб, 12 просмотров)
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.09.2015, 22:19

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Как разделить данные по условию
Здравствуйте. Подскажите, пожалуйста, как можно рассортировать по кассирам (наверное лучше...

Разделить данные из столбцов в строки
Здравствуйте. Есть xml файл поставщика, в нем данные для каждого товара заданы таким способом. ...

Как разделить данные по строкам?
Здравствуйте! Есть файл в формате txt, в котором очень много блоков текста. Каждый такой блок...

Разделить данные из одного столбца в несколько
Есть набор данных (Пример данных.txt). Нужно разделить их по столбцам в excel в формате (Книга1)...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.