0 / 0 / 0
Регистрация: 05.01.2016
Сообщений: 6
1

Поиск пустых ячеек. Поиск ссылки на оригинальных значений для повторяющихся значений

01.02.2016, 00:00. Показов 1202. Ответов 3
Метки нет (Все метки)

Ребят, всем привет. В связи с тем, что firefox прекращает поддержку функции группы вкладок, пришлось их перебирать. И начали возникать трудности экселем.

В столбце A приводится название вкладки, в B приводится ссылка вкладки. Все это сгруппировано по группам вкладок, которые по умолчанию скрыты. И я хочу добавить защиту от дурака для удобства и быстроты работы в файле, а то ссылок несколько сотен.
1). Если я забуду добавить ссылку в столбец B, но имя все-таки занесу, хотелось бы, чтобы в строке группы вкладок (в строке группы вкладок в столбце B) это отображалось - то есть, чтобы писалось название вкладки, ссылку которой я пропустил. Попробовал решить это с помощью формулы
XML
1
=ЕСЛИ(ЕНД(ВПР("";B49:B59;1;ЛОЖЬ))= ИСТИНА;"все хорошо";ВПР("";A49:B59;1;ЛОЖЬ))
Но она игнорирует пустое значение, будто не воспринимает "" как за символ пустого значения.
2). Некоторые вкладки дублируются в разных группах вкладок, как сделать так, чтобы также в строке группы вкладок отображалось название группы вкладок, в которой эта вкладка была в первую очередь занесена, и сама вкладка.

Заранее спасибо.

Добавлено через 6 минут
P.S. почему-то не могу приложить файл - ни через значок скрепки, ни через функцию "управление вложений".
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
01.02.2016, 00:00
Ответы с готовыми решениями:

Поиск пустых значений
Я хочу найти значения в таблице где поле "Завершение" пустое. Выполняю такой запрос: SELECT...

Поиск пустых значений
Я совсем новичок в Дельфи, и не могу справиться с простейшей задачей, которая, скажем, в VB...

Поиск и пометка повторяющихся значений
Доброго дня, Господа ! Помогите мне, пожалуйста, определится с правильным подходом для реализации...

Запрос на поиск повторяющихся значений
Добрый день! В базе данных есть таблица детали. При выполнении разных заказов эти детали всё время...

3
0 / 0 / 0
Регистрация: 05.01.2016
Сообщений: 6
01.02.2016, 02:47  [ТС] 2
Вот сам файл.
Вложения
Тип файла: xlsx вкладки.xlsx (27.1 Кб, 4 просмотров)
0
2629 / 1329 / 255
Регистрация: 25.10.2010
Сообщений: 2,194
01.02.2016, 07:58 3
Формула массива
Код
=ЕСЛИ(СЧИТАТЬПУСТОТЫ(B3:B33)=0;"все хорошо";ИНДЕКС(A3:A33;ПОИСКПОЗ(ИСТИНА;ЕПУСТО(B3:B33);0)))
Можно просто Условным форматированием подкрашивать те строчки, где столбец В пустой
Вложения
Тип файла: xlsx вкладки.xlsx (27.6 Кб, 2 просмотров)
1
0 / 0 / 0
Регистрация: 05.01.2016
Сообщений: 6
02.02.2016, 15:57  [ТС] 4
А не подскажите, как еще сделать проверку на повторы. Правда, теперь уже понял, что через название ссылки это делать нельзя, так как иногда давал одно и тоже имя разным вкладкам. Так что надо делать это через сравнение ссылки - то есть проверять, есть ли уже в файле это ссылка, и если есть, то выдавать имя группы вкладок, где находится первое вхождение, и само название название повторяющейся ссылки, если нет - "повторов нет".
И можно это все вставить в вашу первую формулу, то есть чтобы формула проверяла и на пробелы, и на повторы сразу?
Заранее большое спасибо за помощь.
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
02.02.2016, 15:57

Поиск повторяющихся значений по dataGridView
Пишу курсовой проект с подключением MS Access базы, вывод таблицы производиться в dataGridView из...

Поиск наиболее повторяющихся значений
Добрый день. Есть таблица базы данных "Книги": код книги, автор, название, год издания, цена книги...

Поиск и индекс повторяющихся значений
Столнулся с такой проблемкой. Формула: индекс и поискпоз ищет на листе с таблицей оценку...

Поиск повторяющихся значений массива
Задача: Написать программу для поиска повторяющихся значений. Повторяющимся считается значение,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru