Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
0 / 0 / 0
Регистрация: 05.02.2016
Сообщений: 5
1

Сравнить значения в строке

05.02.2016, 20:39. Показов 585. Ответов 6
Метки нет (Все метки)

Добрый вечер. Совсем отвык от экселя, очень нужна помощь.
Имеется таблица, в которой в одной строке есть набор чисел. Нужно вывести к каждой строке кол-во разных значений в этой строке.
При этом ноль или игнорировать или считать за одно значение.
Пример в аттаче.
0
Вложения
Тип файла: xls Значения.xls (13.5 Кб, 10 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
05.02.2016, 20:39
Ответы с готовыми решениями:

Как сравнить значения ComboBox и листа ячейки, если одинаковые вывод сообщения, если разные сравнить с ячейкой ниже
Добрый день. Как сравнить значения ComboBox и значения ячейки на листе, если одинаковые вывод...

Как с помощью IndexOf выделить все слова в первой строке и сравнить их со словами во второй строке?
как с помощью IndexOf выделить все слова в первой строке и сравнить их со словами во второй строке,...

Сравнить значения
Почему-то дамп массива(на прикрепленной картинке) выдает string(48), когда на самом деле должен...

Сравнить значения
Помогите, пожалуйста, есть три функции, получаю из них ID документов и нужно сравнить эти...

6
5621 / 2931 / 590
Регистрация: 23.11.2010
Сообщений: 9,740
05.02.2016, 21:31 2
Вариант формулой массива с нулем
Код
=СУММ(1/СЧЁТЕСЛИ(A1:F1;A1:F1))
без нулей, тоже формула массива
Код
=СУММ(ЕСЛИ(A1:F1<>0;1/СЧЁТЕСЛИ(A1:F1;A1:F1)))
1
Вложения
Тип файла: xls Значения.xls (26.0 Кб, 7 просмотров)
0 / 0 / 0
Регистрация: 05.02.2016
Сообщений: 5
05.02.2016, 21:32  [ТС] 3
Спасибо за пример!
Все хорошо
0
5621 / 2931 / 590
Регистрация: 23.11.2010
Сообщений: 9,740
05.02.2016, 21:33 4
Формула массива - вводится Ctrl+Shift+Enter
0
0 / 0 / 0
Регистрация: 05.02.2016
Сообщений: 5
05.02.2016, 21:36  [ТС] 5
Прошу прощения, не доглядел.
Возможно не верно сразу описал условие. Бывают одинаковые значение в разных ячейках, их надо считать разными (т.е. как в желтой таблице в примере).
Как вариант, подойдет вариант, вывести кол-во ячеек в строке, в которых отличные от нуля значения.
Еще раз прошу прощения за неосмотрительность
0
5621 / 2931 / 590
Регистрация: 23.11.2010
Сообщений: 9,740
05.02.2016, 22:04 6
Тогда просто
Код
=СЧЁТЕСЛИ(A1:F1;"<>0")
1
0 / 0 / 0
Регистрация: 05.02.2016
Сообщений: 5
05.02.2016, 22:11  [ТС] 7
Fairuza, большое вам спасибо, меня очень выручил этот простой вариант
Хочется выслать вам бутылочку пива в качестве благодарности
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
05.02.2016, 22:11

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Сравнить количество букв в строке
program my_text; uses crt; var a,b:string; L:integer; begin clrscr; writeln('Введи первую...

Как сравнить слова в строке
Как сравнить слова в строке? (СИ)

Сравнить значения в поле.
Привет. Пишу дипломный проект. Появилась нужда сравнить значения в полях. На псевдо-коде...

Оператор If, сравнить 2 значения
Помогите пожалуйста, у меня не получается сравнить 2 значения, вот код:...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.