0 / 0 / 0
Регистрация: 22.11.2012
Сообщений: 43
1

Условие и перенос результата в новую ячейку

08.02.2016, 02:11. Показов 1668. Ответов 3
Метки нет (Все метки)

Добрый вечер!
Не могу придумать решение к задаче, даже каких либо соображений нет, надеюсь на вашу помощь.
Есть столбик значений которые идут через определенный шаг (например 20) и при достижение заданного значения (например 80) оно вычиталось и сложение продолжается. Оно не циклично вычитается только один раз. Как сделать так что бы при выполнении условия( при достижении числа больше 80 оно вычиталось) в ячейке Б начинался новый счёт с таким же шагом что и в первом. Ниже для наглядности схематическая таблица и формула для столбца А( при достижение числа больше 80 вычитание 80 )
Код
=ЕСЛИ(A1<$B$1;A1+$B$2;ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;">"&($B$1-$В$2))>1;A1+$B$2;A1-$B$1))
А. Б. В.
1 10. 20
2 30. 80
3 50
4 70
5 10. 20
6 30 40
7 50 60
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
08.02.2016, 02:11
Ответы с готовыми решениями:

Нумерация полученного результата и его последующий перенос в соответствующую ячейку
Здравствуйте, подскажите пожалуйста, каким образом можно перенести нумерацию (назовем это места в...

Вывод результата в ячейку по значению
Всем доброго времени суток! :) Помогите сделать вывод результата (кол-во пропусков по месяцам) при...

Добавить название столбца в соседнюю ячейку от результата
Добрый день! Нужно добавить название столбца в соседнюю ячейку от минимального/максимального...

Поиск значения в диапазоне ячеек и вывод результата в ячейку
Доброго времени суток!!! Поиск не помог мне, решил создать тему. Исходные данные: есть 2...

3
112 / 20 / 19
Регистрация: 25.01.2016
Сообщений: 37
08.02.2016, 07:47 2
Лучший ответ Сообщение было отмечено DoK64 как решение

Решение

Получилось вот такое сложное условие:
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A3;">"&($B$1-$B$2))>0;ЕСЛИ(ИЛИ(B2="";И(B2=20;B1=80));ЕСЛИ(A3<A2;20;"");B2+$B$2);"")
Оно проверяет было ли выполнение условия и вычитание. Если не было, то ячейка B остается пустой.
Если было выполнение условия и вычитание, то далее формула выясняет и выполняет следующее:
1) Если предыдущая ячейка была пустой или предыдущими ячейками были начальные данные (B1=80 и B2=20), то в ячейку ставится значение "20"
2) Если в предыдущих ячейках уже началось заполнение столбца B, то заполнение продолжится.
Во вложении файл с примером данной формулы
Вложения
Тип файла: xlsx Книга1.xlsx (8.9 Кб, 9 просмотров)
1
0 / 0 / 0
Регистрация: 22.11.2012
Сообщений: 43
08.02.2016, 22:22  [ТС] 3
NatalySky, у меня только вопрос по одной части формулы не смог сам разобраться , могли бы пожалуйста разъяснить .
Код
ЕСЛИ(ИЛИ(B5="";И(B5=20;B4=80));ЕСЛИ(A6<A5;20;"");B5+$B$2);"")
интересует момент
Код
И(B5=20;B4=80)
Спасибо за понимание.
0
112 / 20 / 19
Регистрация: 25.01.2016
Сообщений: 37
09.02.2016, 02:13 4
Код
И(B5=20;B4=80)
Данный фрагмент функции нужен только при таком примере:
А. Б.
50. 80
70. 20
10. 20
30. 40
Сначала я проверяла только то, чтобы предыдущая ячейка B была пустая
Код
B5="";
Но в данном примере получалось так, что предыдущая ячейка была не пустая, и формула начинала к предыдущей ячейке прибавлять "20". И получалось вот так:
А. Б.
50. 80
70. 20
10. 40
30. 60
Но это не правильно, поэтому я стала проверять также, чтобы предыдущими двумя ячейками не были начальные условия, т.е. B1=80, B2=20. Теперь функция проверяет так: если предыдущая ячейка B была пустой или предыдущими двумя значениями B были (B1=80 И B2=20), то ставим 20. Если предыдущая ячейка B не была пустой или предыдущими двумя значениями B не были начальные условия, то тогда в столбце B выполняем нужные действия.
Возможно, в Вашем конкретном случае такой пример и не встретится, но проверку я добавила.
Вот такая логика
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
09.02.2016, 02:13

Извлечение из ячеек одного из параметров c переносом результата в отдельную ячейку v. 2
Добрый вечер! подскажите пожалуйста формулы, как можно извлечь нужные коды из ячеек, которые...

Извлечение из ячеек одного из параметров c переносом результата в отдельную ячейку
Всем привет. Нашел на форуме более менее подходящую формулу, но возникла проблема. В конечном...

Переход в ячейку через двойное условие
Вопрос такой как построить слудующий макрос--- допустим есть две колонки выпадающих списков ---...

Перенос данных в нужную ячейку
Добрый день, нужна ваша помощь. Есть 2 книги, в первой два столбца (артикул и штрихкод) столбец...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru