Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.62/34: Рейтинг темы: голосов - 34, средняя оценка - 4.62
0 / 0 / 1
Регистрация: 29.08.2014
Сообщений: 14
1

Вычислить сколько дней до дня рождения

19.03.2016, 09:32. Просмотров 6491. Ответов 17
Метки нет (Все метки)

в одну ячейку дату любую вписываем ,в другой день рождение и в третьей сколько дней осталось до дня рождения чтобы выводилось. если количество дней до дня рождения меньше чем после то выводить сколько до осталось , если количество дней после дня рождения меньше чем до , то выводить сколько дней прошло после него
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
19.03.2016, 09:32
Ответы с готовыми решениями:

Посчитать сколько дней осталось дня рождения
Несколько дней ломаю голову с этим чудом. Нужно подсчитать сколько осталось...

Определить, сколько дней осталось до дня рождения
Всем привет. Не могу решать задачу. "Заданы день и месяц рождения, а так же текущий день, месяц и...

Определить, сколько дней осталось до дня рождения
1) задача. Ввести дату рождения и текущую дату. Определить сколько дней осталось до др....

Сколько дней прошло со дня Вашего рождения?
Сколько дней прошло со дня Вашего рождения?

17
5433 / 2796 / 530
Регистрация: 23.11.2010
Сообщений: 9,246
19.03.2016, 09:57 2
т.е. выясняем прошел ДР или еще только будет?
0
0 / 0 / 1
Регистрация: 29.08.2014
Сообщений: 14
19.03.2016, 10:05  [ТС] 3
Если дней после дня рождения меньше чем до , то выводить после и наоборот также

Добавлено через 5 минут
Количество дней до или после нужно
0
769 / 612 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
19.03.2016, 10:33 4
1. Если дата дня рождения в А1 и нужно узнать сколько осталось на сегдняшную дату
Код
=ЕСЛИ(СЕГОДНЯ()<ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A1);ДЕНЬ(A1));ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A1);ДЕНЬ(A1))-СЕГОДНЯ();ДАТА(ГОД(СЕГОДНЯ())+1;МЕСЯЦ(A1);ДЕНЬ(A1))-СЕГОДНЯ())&" дн."
2. Если дата дня рождения в А2, другая дата в В2
Код
=ЕСЛИ(B2<ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A2);ДЕНЬ(A2));ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A2);ДЕНЬ(A2))-ДАТА(ГОД(B2);МЕСЯЦ(B2);ДЕНЬ(B2));ДАТА(ГОД(СЕГОДНЯ())+1;МЕСЯЦ(A2);ДЕНЬ(A2))-ДАТА(ГОД(B2);МЕСЯЦ(B2);ДЕНЬ(B2)))&" дн."
0
769 / 612 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
19.03.2016, 10:58 5
Эта формула считает, если день рождение еще не наступил, то сколько дней осталось до дня рождения, если прошел то сколько дней прошло после дня рождения.
Код
=ЕСЛИ(B3<ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A3);ДЕНЬ(A3));ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A3);ДЕНЬ(A3))-ДАТА(ГОД(B3);МЕСЯЦ(B3);ДЕНЬ(B3));B3-ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A3);ДЕНЬ(A3)))&" дн."
1
Вложения
Тип файла: xlsx день_рождения.xlsx (8.1 Кб, 22 просмотров)
5579 / 860 / 285
Регистрация: 25.02.2011
Сообщений: 1,218
Записей в блоге: 1
19.03.2016, 12:19 6
Вариант
3
Вложения
Тип файла: xlsx ДР.xlsx (10.1 Кб, 27 просмотров)
2314 / 1648 / 679
Регистрация: 04.09.2015
Сообщений: 3,324
19.03.2016, 16:48 7
Формула Михаила чуть короче
Код
=ВПР(182;(ДЕНЬ(A2)&-МЕСЯЦ(A2)&-ГОД(B2)+{1:0:-1})-B2;1)
2
1143 / 807 / 400
Регистрация: 23.03.2015
Сообщений: 2,735
19.03.2016, 17:04 8
Цитата Сообщение от AlexM Посмотреть сообщение
Формула Михаила чуть короче
и правильней....
0
2314 / 1648 / 679
Регистрация: 04.09.2015
Сообщений: 3,324
19.03.2016, 17:05 9
Цитата Сообщение от Narimanych Посмотреть сообщение
и правильней....
Чем?
0
1143 / 807 / 400
Регистрация: 23.03.2015
Сообщений: 2,735
19.03.2016, 17:11 10
У AleksSid нужно добавить "=" вот сюда
1 =ЕСЛИ(B3=<ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ

Добавлено через 58 секунд
AlexM,
поробуйте в вашем файле поставить одинаковые даты
0
2314 / 1648 / 679
Регистрация: 04.09.2015
Сообщений: 3,324
19.03.2016, 17:20 11
Цитата Сообщение от Narimanych Посмотреть сообщение
поробуйте в вашем файле поставить одинаковые даты
Попробовал. Формула Михаила и укороченная считает одинаково и правильно. Формулу AleksSid я не смотрел.
0
1143 / 807 / 400
Регистрация: 23.03.2015
Сообщений: 2,735
19.03.2016, 17:30 12
Цитата Сообщение от AlexM Посмотреть сообщение
Формула Михаила и укороченная
укороченная и есть формула "m-ch"
0
2314 / 1648 / 679
Регистрация: 04.09.2015
Сообщений: 3,324
19.03.2016, 19:31 13
Цитата Сообщение от Narimanych Посмотреть сообщение
укороченная и есть формула "m-ch"
Ну да. На одну функцию меньше + заменил одну, а в остальном не отличается.

Добавлено через 1 час 56 минут
еще короче
Код
=ВПР(182;(ТЕКСТ(A2;"Д.М")&-ГОД(B2)+{1:0:-1})-B2;1)
0
5579 / 860 / 285
Регистрация: 25.02.2011
Сообщений: 1,218
Записей в блоге: 1
19.03.2016, 21:40 14
Цитата Сообщение от AlexM Посмотреть сообщение
еще короче
Алексей, можно еще на символ сократить: {1:0:-1}-ГОД(B2)
0
14927 / 6328 / 1721
Регистрация: 24.09.2011
Сообщений: 9,977
19.03.2016, 23:49 15
Если строго по заданию, можно еще символ сократить
Код
=МИН(ABS((ТЕКСТ(A2;"Д.М")&{1:0:-1}-ГОД(B2))-B2))
1
2314 / 1648 / 679
Регистрация: 04.09.2015
Сообщений: 3,324
20.03.2016, 01:25 16
Казанский, Формат ячейки так не работает. Отрицательные значения нужны для формата.
0
0 / 0 / 1
Регистрация: 11.11.2019
Сообщений: 70
26.06.2020, 20:39 17
AlexM, Приветствую, а как рассчитать кол-во дней до дня рождения исходя из текущей даты не вписывая определённой ? Т.е. дата например 01.03.1998 нужно рассчитать кол-во дней до дня рождения исходя из текущей даты
0
2314 / 1648 / 679
Регистрация: 04.09.2015
Сообщений: 3,324
27.06.2020, 07:13 18
OverNiko, вместо В2 напишите СЕГОДНЯ()
Но в этой теме задача немного другая. Определить сколько прошло или сколько осталось дней.
Если вам это не подходит откройте новую тему и приложите файл-пример с разными датами ДР
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
27.06.2020, 07:13

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Определить, сколько дней осталось до вашего дня рождения
Доброе время суток!!! Помогите с решение задания: Определить сколько дней осталось до вашего...

Заданы день и месяц рождения, а также текущие день, месяц и год. Определить, сколько дней осталось до дня рождения
заданы день и месяц рождения, а также текущие день, месяц и год. Определить, сколько дней осталось...

Программа определяет сколько дней от текущей даты осталось до нового года и дня рождения
Программа определяет сколько дней от текущей даты осталось до нового года и дня рождения ,текущую...

Функция, принимающая на вход дату рождения и текущую дату, и вычисляющая число дней до дня рождения
помогите сделать работу по с++ Создать функцию, которая принимает на вход дат рождения и текущую...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
18
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.