0 / 0 / 0
Регистрация: 13.09.2016
Сообщений: 9
1

Суммировать элементы массива, расположенные до первого четного числа. Суммировать все нечетные элементы и <11

01.11.2016, 06:33. Показов 1604. Ответов 2

1. Нужно вычислить сумму массива до первого четного с помощью формул Excel
Не удается модернизировать формулу, пока она вычисляет значение первого четного элемента(см скрин):
Код
=СМЕЩ(C4;ПОИСКПОЗ(;ЕСЛИ(ОСТАТ(C4:C14;2)=0;);)-1;0)
2. Также требуется суммировать все нечетные элементы массива, а также которые меньше <11
Формула вроде логичная, но где-то косяк, внутри проверки на нечетность полагаю(скрин 2):
Код
=СУММЕСЛИМН(C4:C14;C4:C14;"<11";C4:C14;"ЕНЕЧЁТ(C5)")
3. Наконец, необходимо посчитать по формуле P=(a+1)^2 *(a+2)^2 *...*(a+n)^2
a и n дано соотвественно
Вот это ваще хз как формулой можно.

Сделал всё в VBA, а вот с формулами проблема, надеюсь на вашу помощь.
Заранее благодарен.
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Миниатюры
Суммировать элементы массива, расположенные до первого четного числа. Суммировать все нечетные элементы и <11   Суммировать элементы массива, расположенные до первого четного числа. Суммировать все нечетные элементы и <11  
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
01.11.2016, 06:33
Ответы с готовыми решениями:

Суммировать элементы массива, расположенные на позициях кратных трем
Задания по ассемблеру дали.. если не сложно поставьте пару комментов суммировать элементы...

Суммировать элементы матрицы, возвеси в квадрат каждое число и снова суммировать
Всем привет! Предположим, есть некий массив 10 на 10, ну то есть 100 чисел. Эти числа такие...

Суммировать положительные элементы, расположенные между минимумом и максимумом
Это - задача из раздела &quot;C для начинающих&quot;. Применительно к Haskell, я формулирую ее так: Дан...

Выделить отрицательные элементы массива расположенные после первого четного элемента
Вывести на экран одномерный массив, раскрасив в нем желтым цветом отрицательные элементы ...

2
15037 / 6364 / 1726
Регистрация: 24.09.2011
Сообщений: 9,976
01.11.2016, 09:26 2
Лучший ответ Сообщение было отмечено TheYak73 как решение

Решение

TheYak73, с картинками туда: https://www.cyberforum.ru/photoshop/
Здесь нужен файл xls.

Добавлено через 4 минуты
Цитата Сообщение от TheYak73 Посмотреть сообщение
посчитать по формуле P=(a+1)^2 *(a+2)^2 *...*(a+n)^2
Формула массива (ввод Ctrl+Shift+Enter, отображается в фигурных скобках)
Код
=ПРОИЗВЕД((A1+СТРОКА(ДВССЫЛ("1:"&B1)))^2)
a=A1, n=B1
1
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
01.11.2016, 10:51 3
Лучший ответ Сообщение было отмечено TheYak73 как решение

Решение

Формула массива для первой
Код
=СУММ(C4:ИНДЕКС(C4:C14;ПОИСКПОЗ(1;ОСТАТ(C4:C14+1;2);)-1))
Добавлено через 15 минут
Формула массива для второй задачи
Код
=СУММ((ОСТАТ(C4:C14;2)>-(C4:C14<11))*C4:C14)
1
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
01.11.2016, 10:51

Суммировать элементы первого столбца или всей матрицы
Если в 1 столбце есть элементы не равные 0, то суммировать элементы первого столбца. В противном...

Суммировать все нечётные целые числа в диапазоне, который введёт пользователь с клавиатуры
Условие Необходимо суммировать все нечётные целые числа в диапазоне, который введёт...

Суммировать элементы массива
Суммировать элементы массива А для которых сумма индексов нечетна

Суммировать положительные элементы массива
Помогите, пожалуйста. Только начинаю, не могу ещё разобраться. Нужно суммировать положительные...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.