0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
1

Подсчет количества шестерок и вывод суммы в отдельную ячейку

04.11.2016, 12:27. Показов 868. Ответов 19
Метки нет (Все метки)

Всем привет, подскажите как сделать при помощи VBA так чтобы подсчитывало количество шестерок и выводило сумму в отдельную ячейку. То есть шестерку оно должно видеть как единицу. Лист Microsoft Excel.xlsx
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
04.11.2016, 12:27
Ответы с готовыми решениями:

Поиск слов в тексте по количеству символов и вывод значения в отдельную ячейку
Добрый день! Задача состоит в следующем, в ячейках есть текст в котором есть слова состоящие из...

Подсчёт суммы и занесение результата в ячейку
Помогите доделать код, чтобы считывал и выводил общий результат, с полей "Сумма", в ячейку рядом с...

Поиск, подсчет количества и суммы
Для массива целых чисел определить разность между суммой элементов с нечетными номерами и суммой...

Подсчёт суммы n-го количества матриц
нужно написать программу для подсчёта суммы n-го количества матриц

19
771 / 614 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
04.11.2016, 13:10 2
Решение формулой.
Код
=СЧЁТЕСЛИ(A1:D2;6)
0
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
04.11.2016, 13:16 3
Решение VBA
Visual Basic
1
2
3
Sub VBA()
iCount = Evaluate("COUNTIF(A1:D2,6)")
End Sub
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
04.11.2016, 15:08  [ТС] 4
не подсчитывает количество шестерок

Добавлено через 28 минут
надо чтобы ответ выводило в ячейку выделенную красным
0
15038 / 6362 / 1726
Регистрация: 24.09.2011
Сообщений: 9,971
04.11.2016, 15:09 5
fansuper, подсчитывает. Еще варианты
Visual Basic
1
2
[F1]=worksheetfunction.CountIf([A1:D2],6)
[F1]=[COUNTIF(A1:D2,6)]
В ячейке F1 сделайте разный цвет заливки и цвет шрифта, а то ничего не увидите
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
04.11.2016, 15:35  [ТС] 6
Казанский, а как сделать чтобы сразу подсчитывало при удалении шестерки, без постоянного запуска кода
0
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
04.11.2016, 16:33 7
Цитата Сообщение от fansuper Посмотреть сообщение
чтобы сразу подсчитывало при удалении шестерки
код в модуле листа
Visual Basic
1
2
3
4
5
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Range("A1:D2"), Target) Is Nothing Then
       [F1] = [COUNTIF(A1:D2,6)]
End If
End Sub
или
Visual Basic
1
2
3
4
5
Private Sub Worksheet_Change(ByVal Target As Range)
Application.EnableEvents = False
[F1] = [COUNTIF(A1:D2,6)]
Application.EnableEvents = True
End Sub
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
04.11.2016, 16:49  [ТС] 8
я извиняюсь, не могу понять как запустить
0
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
04.11.2016, 17:34 9
Со вторым кодом
Вложения
Тип файла: xls Лист Microsoft Excel_02.xls (31.0 Кб, 11 просмотров)
1
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
15.11.2016, 17:19 10
Цитата Сообщение от fansuper Посмотреть сообщение
подскажите как сделать при помощи VBA ..... Только все это без макросов чисто в VBA
Это как?
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
15.11.2016, 18:15  [ТС] 11
Сделать циклом есле это возможно, есле вносятся изменения то при переходе в следующую ячейку пересчитывало.
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
15.11.2016, 18:18  [ТС] 12
вот к примеру как я здесь делал
Вложения
Тип файла: rar Рапорт Заготовка№4.rar (77.4 Кб, 3 просмотров)
0
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
15.11.2016, 19:01 13
Как считаете шестерки не нашел.
Цитата Сообщение от fansuper Посмотреть сообщение
примеру как я здесь делал
У вас в файле невероятного размера макрос написанный на VBA. При открытии файла система безопасности спрашивает Включить или не включать макросы в файле. А вы говорите, что сделали без макросов, только на VBA.
Рекомендую считать шестерки формулой
Код
=СЧЁТЕСЛИ(N49:AC50;6)
Эта формула для ячейки AS49. После вставки формулы протяните ее вниз.
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
15.11.2016, 20:02  [ТС] 14
Спасибо конечно но формулой я знаю как сделать, мне так не подходит
0
15038 / 6362 / 1726
Регистрация: 24.09.2011
Сообщений: 9,971
15.11.2016, 23:33 15
fansuper, аналог этой формулы циклом
Visual Basic
1
2
3
4
5
n=0
for each x in range("N49:AC50").value
  if x=6 then n=n+1
next
'n - число шестерок
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
16.11.2016, 10:12  [ТС] 16
А можно еще добавить чтобы результат выводило в ячейку F1
0
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
16.11.2016, 21:29 17
Visual Basic
1
range("F1")=n
0
Заблокирован
16.11.2016, 21:44 18
Выбирайте-
Visual Basic
1
2
3
4
[f1]=n
range("f1")=n
cells(1,"f")=n
cells(1,6)=n
0
Почетный модератор
Эксперт по компьютерным сетямЭксперт Windows
28028 / 15757 / 977
Регистрация: 15.09.2009
Сообщений: 67,758
Записей в блоге: 78
16.11.2016, 22:01 19
fansuper, не плодите темы по одному и тому же вопросу.
0
0 / 0 / 0
Регистрация: 08.10.2016
Сообщений: 30
16.11.2016, 22:17  [ТС] 20
Последний вопрос, чтобы мне опускаться вниз и оно подсчитывало остальные две строки и выводило для них результат отдельно, как это сделать. И при этом есле я удалю шестерку оно сразу пресчитывало.
Вложения
Тип файла: xls Лист Microsoft Excel_02.xls (29.0 Кб, 2 просмотров)
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
16.11.2016, 22:17

Поиск, подсчет количества и суммы
. Данные о температуре воздуха и количестве осадков за декаду апреля хранятся в массивах....

Подсчет файлов в папке и вывод значения в ячейку
Здравствуйте! Есть макрос, который в подсчитывает количество файлов, находящихся в заданной папке. ...

Подсчет суммы заранее неизвестного количества ячеек
Здравствуйте. Есть задача такая: Необходимо из листа АСУТПиМ перенести на лист МатерХРиГСМ данные...

Поиск, подсчет количества и суммы элементов массива
В одномерном массиве A(10) вычислить количество отрицательных элементов, меньших чем -k.


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.