Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.57/7: Рейтинг темы: голосов - 7, средняя оценка - 4.57
13 / 13 / 5
Регистрация: 24.04.2013
Сообщений: 147
Записей в блоге: 1
1

Посчитать количество непустых ячеек

12.12.2016, 09:33. Показов 1418. Ответов 3
Метки нет (Все метки)

Добрый день!
Нужно посчитать количество непустых ячеек (содержащих число) каждому региону.
Пример во вложении.
Вроде бы элементрарно, но что-то я застопарился)))
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Вложения
Тип файла: xlsx пример.xlsx (10.8 Кб, 8 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
12.12.2016, 09:33
Ответы с готовыми решениями:

Как посчитать заданное количество непустых ячеек по указанным параметрам
Здравствуйте, уважаемые! Помогите определиться с формулой подсчёта. Имеется, например, график,...

Подсчитать количество непустых ячеек
Я лузер. Пытаюсь создать такую формулу: необходимо подсчитать количество непустых ячеек-тут мне...

Выстраивание непустых ячеек
Здравствуйте! У меня есть ряд ячеек, раскиданных по листу, которые я выстраиваю в виде одного...

Посчитать количество цветных ячеек
добрый день! есть 2 столбца ячейки в них закрашены 4 цветами (причем, некоторые из них...

3
1850 / 1172 / 189
Регистрация: 27.03.2009
Сообщений: 4,511
12.12.2016, 09:39 2
Код
=СЧЁТЕСЛИМН($A:$A;$E1;$B:$B;">0")
1
771 / 614 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
12.12.2016, 16:13 3
Еще вариант.
Код
=СУММПРОИЗВ((A$1:A$19=E2)*(B$1:B$19>0))
0
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
12.12.2016, 19:54 4
AleksSid, эта формула посчитает и ячейку с "нет", т.е. результат на единицу больше.
Вариает с формулой массива
Код
=СЧЁТ(1/(A$1:A$19=E1)/B$1:B$19)
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
12.12.2016, 19:54

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Подсчитать среднее значение непустых ячеек
Как подсчитать среднее значение диапазона ячеек, чтобы среднее считалось по количеству не пустых...

Как посчитать количество ячеек по двум параметрам
Помогите пожалуйста! Мне нужно посчитать количество ячеек по двум параметрам: пол и возраст....

Подсчёт непустых ячеек во всём столбце и особый диапазон
Добрый вечер, уважаемые, два важных вопроса к вам по Экселю, ответа не нашёл. 1. Есть функция...

Подсчет непустых ячеек столбца с определенными значениями в другом столбце
Доброго всем дня! Не нашел подходящего ответа на форуме, поэтому решил задать вопрос. Хочу...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.