0 / 0 / 0
Регистрация: 19.03.2017
Сообщений: 20
1

Нумерологический квадрат Пифагора, нужны формулы

21.03.2017, 22:11. Показов 6910. Ответов 4
Метки нет (Все метки)

Нужны формулы для нумерологического квадрата Пифагора

Задача1: в ячейке необходимо: 2 умножить на число из другой ячейки от 1 до 31, при этом именно на первую цифру из этого числа. Например число 31, то необходимо 2х3=6, а если число 07, тогда 2х7=14 (то есть если 0, то мы его пропускаем и умножаем на вторую цифру).

Задача2: подсчитать сумму цифр из числа, например дано число 25, нужну формула 2+5=7

Задача3: Необходимо, чтобы из определенных ячеек (А1,A2,A3,B1,B2,B3,B4) в другую ячейку копировались нужные совпадающие цифры. В первую ячейку копировались все единицы, во вторую двойки и тд. Дано - А1=23, A2=13, A3=07, B1=14, B2=16, B3=27, B4=08 Нужно в С1=111, С2=22, С3=33, С4=4, С5="нет" (так как пятерок нет), С6=6, С7=77, С8=8, С9=нет
0

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
21.03.2017, 22:11
Ответы с готовыми решениями:

Квадрат Пифагора
Решил залить программу на C++, которая выводит квадрат Пифагора в StringGrid. Вдруг кому-то...

Квадрат Пифагора
Как в стрингрид выводить например не количество однёрок, а однёрки количеством. Т.е. например...

Квадрат Пифагора
3-квадрат Пифагора

Квадрат Пифагора в БД
Помогите написать код к программе "Квадрат Пифагора". Вот заготовка. Нужно, чтобы в Мемо выводилась...

4
1051 / 498 / 134
Регистрация: 27.02.2013
Сообщений: 1,439
21.03.2017, 23:13 2
Лучший ответ Сообщение было отмечено fantastic33 как решение

Решение

fantastic33, для первой задачи формула
Код
=ЕСЛИ(ЛЕВСИМВ(A1;1)=0;2*ПРАВСИМВ(A1;1);2*ЛЕВСИМВ(A1;1))
для второй
Код
=ЛЕВСИМВ(A2;1)+ПРАВСИМВ(A2;1)
1
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
22.03.2017, 00:00 3
Лучший ответ Сообщение было отмечено fantastic33 как решение

Решение

Задача 1
Код
=2*ЛЕВБ(A1;1)
Задача 2
Код
=СУММ(--ПСТР(A1&0;{1;2};1))
Добавлено через 11 минут
Задача 3
Код
=ПОВТОР(СТРОКА(A1);СУММПРОИЗВ(ДЛСТР(A$1:B$5)-ДЛСТР(ПОДСТАВИТЬ(A$1:B$5;СТРОКА(A1);))))
1
0 / 0 / 0
Регистрация: 19.03.2017
Сообщений: 20
22.03.2017, 04:11  [ТС] 4
Цитата Сообщение от OLEGOFF Посмотреть сообщение
fantastic33, для первой задачи формула
Код
=ЕСЛИ(ЛЕВСИМВ(A1;1)=0;2*ПРАВСИМВ(A1;1);2*ЛЕВСИМВ(A1;1))
для второй
Код
=ЛЕВСИМВ(A2;1)+ПРАВСИМВ(A2;1)
Спасибо, сработало, только 0, нужно было закавычить.
0
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
22.03.2017, 08:17 5
Цитата Сообщение от fantastic33 Посмотреть сообщение
только 0, нужно было закавычить.
Что это значит?
Плохо, что к этой задаче не приложили файл с примерами. По файлу можно было бы понять в каком формате числа от 1 до 31.
Подозреваю, что у чисел пользовательский формат с типом 00. В этом формате одноразрядные числа: 1,2,...9 отображаются 01,02,...09, но при этом остаются числами.
Формула для первой задачи OLEGOFF и AlexM возвращают одинаковые значения, но вторая короче и может быть еще короче
Код
=2*ЛЕВБ(A1)
Формулы для второй задачи при таком же формате значений (пользовательский формат) возвращают неодинаковые результаты для чисел от 1 до 9. Например у OLEGOFF сумма чисел левой и правой цифры для 1 равна 2, для 2=4. В моей формуле возвращается 1 и 2 соответственно.
Что правильно решаете вы или ваш преподаватель.

Другие результаты для первой задачи, если формат чисел от 1 до 31 в текстовом формате. Для значений с 0 впереди обе формулы будут возвращать 0, что будет неверно.
Формулу OLEGOFF и AlexM можно исправить так
Код
=ЕСЛИ(--ЛЕВСИМВ(A1;1)=0;2*ПРАВСИМВ(A1;1);2*ЛЕВСИМВ(A1;1))
=2*ЛЕВБ(--A1)
Короткая формула универсальная, отработает правильно при любом формате чисел от 1 до 31
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
22.03.2017, 08:17

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Delphi квадрат пифагора
Ребят, помогите, нужна программа в делфи, чтобы в мемо выводился "квадрат пифагора-таблица...

Вывести на экран квадрат Пифагора
Написать программу, которая выводит на экран квадрат Пифагора, при помощи операторов цикла.

Вывести квадрат Пифагора (таблицу умножения)
Помогите создать программу, в программирование нечего не понимаю! Задание: Напишите программу,...

Вывести на экран квадрат Пифагора — таблицу умножения
1. Написать программу, которая выводит на экран квадрат Пифагора — таблицу умножения. 2. Задан...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.