Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
8 / 8 / 2
Регистрация: 22.10.2010
Сообщений: 126
1

Сумма непарных элементов

29.11.2010, 21:36. Просмотров 1068. Ответов 4
Метки нет (Все метки)

Помогите найти пожалуйста..) Это нужно найти это одной формулой.
Пардон за ошибку в названии. Сумма нечётных элементов.
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
29.11.2010, 21:36
Ответы с готовыми решениями:

Сумма и подсчет количества парных, непарных элементов в большом массиве (PLINQ)
Здавствуйте, нужна помощь в решении задачи. Дан большой массив радномных целых чисел (10000), нужно...

Сумма непарных елементов
Здравствуйте, помогите пожалуйста, надо сделать так, что бы считалась сумма непарных елементов....

Сумма утроенных непарных чисел
с помощью for решить задачу: дано n найти сумму чисел вида i^3- 3in^2 +n тех, которые являются...

Нужно написать функцию или процедуру в которой сумма трёх непарных чисел наименьшая?
Делаю практику нужно помочь с заданием по функциям и процедурам задание такое: нужно написать...

4
здесь больше нет...
3354 / 1666 / 184
Регистрация: 03.02.2010
Сообщений: 1,219
29.11.2010, 23:29 2
Лучший ответ Сообщение было отмечено как решение

Решение

формула массива:
3
Вложения
Тип файла: xls Книга4.xls (24.0 Кб, 41 просмотров)
671 / 177 / 10
Регистрация: 28.07.2010
Сообщений: 253
30.11.2010, 00:47 3
Прошу прощения, но
Код
=СУММ((ЦЕЛОЕ((A1:A7)/2)=(A1:A7)/2)*A1:A7)
считает четные элементы.
Для нечетных можно так:
Код
=СУММПРОИЗВ(ОСТАТ(A1:A7;2)*A1:A7)
1
956 / 596 / 11
Регистрация: 11.06.2010
Сообщений: 1,345
30.11.2010, 09:35 4
Если имеется ввиду сумма нечётных элементов по-порядку а не по значениям (т.е. в нечётных строках), то можно так:
Код
=СУММПРОИЗВ(ЕНЕЧЁТ(СТРОКА(A1:A7))*A1:A7)
1
8 / 8 / 2
Регистрация: 22.10.2010
Сообщений: 126
30.11.2010, 10:41  [ТС] 5
Всем спасибо за помощь!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
30.11.2010, 10:41

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

"В массиве, который состоит из 15 элементов, найти номера непарных элементов
Собственно вот: "В массиве, который состоит из 15 элементов, найти номера непарных элементов....

Сортировка пузырьком элементов, стоящих на непарных местах
Дан список целых чисел, заданных случайным образом. Количество элементов вводится с клавиатуры....

Подсчет суммы элементов массива на непарных местах
Здравствуйте, мне была поставлена задача, которую я никак не могу реализовать с помощью MSV 2010 на...

Найти полусумму непарных элементов парных столбцов
1.Размер матрицы- 8x9.Формула для определения элементов массива Ai,j=5(i-1)+i*j. Найти полусумму...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.