Форум программистов, компьютерный форум, киберфорум
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
34 / 29 / 7
Регистрация: 24.07.2015
Сообщений: 177
1

Нужно дополнить формулу условием ЕСЛИ или И или ИЛИ

22.08.2017, 15:38. Показов 1229. Ответов 4
Метки нет (Все метки)

Здравствуйте, второй день собираю формулу на подстановку данных в столбце, сегодня нашел вариант и почти правильно работает, но загвоздка в том что надо дополнить еще одним условием, и не могу ничего придумать, ИЛИ и ЕСЛИ и И подставляю и ничего не получается, или ошибка или неверное значение, в общем наведите на правильный ответ, сама формула
Код
=ЕСЛИ(C2="ФГК";"ВРК-1";ЕСЛИ(ИЛИ(F2<>"";G2<>"";H2<>"";I2<>"");"собственник";"в ожидании подачи в цех"))
0
Вложения
Тип файла: xlsx пример(1).xlsx (24.6 Кб, 8 просмотров)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
22.08.2017, 15:38
Ответы с готовыми решениями:

Нужно заново запросить ввод N и M, если они больше 20 или меньше 1, или равны 1 одновременно
Проблема в том, что когда ввожу 1, происходит запрос заново. Например, ввожу 1 и 5. А когда 20, то...

Заменить каждый четный символ или на 'a', если символ не равен 'a' или 'b', или на 'c' в противном случае
Дана строка. Заменить каждый четный символ или на 'a', если символ не равен 'a' или 'b', или на ...

Нужно проверить формулу, работает или нет!
Ребят, у меня нет маткада.Кто может проверить и построить график, помогите пожалуйста!

Вычислить интеграл по замкнутому контуру, используя теорму о вычетах или интегральную теорму Коши, или формулу
для производных высших порядков, где L - окружность |z+1| = 1/2 \int \frac{sin(\frac {\Pi*z}...

4
3388 / 2084 / 685
Регистрация: 02.11.2012
Сообщений: 5,453
22.08.2017, 16:18 2
Лучший ответ Сообщение было отмечено der alex как решение

Решение

так?
Код
=ЕСЛИ(СУММ(F2:I2)=0;"в ожидании подачи в цех";ЕСЛИ(C2="ФГК";"ВРК-1";"собственник"))
1
34 / 29 / 7
Регистрация: 24.07.2015
Сообщений: 177
22.08.2017, 16:30  [ТС] 3
отлично, работает, плюсую, спасибо
0
1688 / 1184 / 567
Регистрация: 23.03.2015
Сообщений: 3,889
22.08.2017, 16:39 4
Лучший ответ Сообщение было отмечено der alex как решение

Решение

der alex,

Так пойдет?
1
Вложения
Тип файла: xlsx пример(1) (1).xlsx (22.8 Кб, 5 просмотров)
34 / 29 / 7
Регистрация: 24.07.2015
Сообщений: 177
22.08.2017, 16:42  [ТС] 5
Да тоже работает, и вам спасибо
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
22.08.2017, 16:42

Заказываю контрольные, курсовые, дипломные работы и диссертации здесь.

Если заканчивается природное сырьё, или какая наука права военная или гражданская
Монополия военной науки или гражданской науки на государственное управление спасёт нас всех, если...

Является ли подстрока числом? Если да, выяснить: целое или вещественное число, положительное или отрицательное
Недавно только поступил на программирование. С делфи еще совсем не освоился, был бы рад хоть какой...

нужно выяснить ИЛИ Я идиот ИЛИ в учебнике ошибка (простая задача статики)
условие : Ha твердое тело в точке А действуют силы FI = 6 Н и F2 = 3 Н, линии действия которых...

Если ли у вас или где-то примеры консольных игр или какие-то учебники по ним? Я имею в виду текстовый квест
Не могу найти в сети тот пример или учебник, который нужен. Везде игры с интерфейсом, а мне нужны...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.