0 / 0 / 0
Регистрация: 16.09.2017
Сообщений: 3
1

Копирование строк из таблицы на другой лист по условию

18.09.2017, 00:59. Показов 5144. Ответов 4
Метки нет (Все метки)

Доброй ночи!
Помогите. Нужно чтобы автоматом происходило копирование строк из одного листа в другой согласно дате.
Идея такая: Хочу сделать так, чтобы из листа "Движение_товара" копировались строчки по дате заполнения на соответствующий листок с номером.
Например: Записи за 17.09.2017 копировались на листок "17" и т.д.
Но в данном случае, чтоб не крутить долго листы прошу подсказать как копировать записи за эту дату на лист "02"

Я пробовал так:
Код
=ИНДЕКС(Движение_Товара!$E$2:$E$1999;НАИМЕНЬШИЙ(ЕСЛИ(Движение_Товара!$M$2:$M$1999<>"17.09.2017");СТРОКА($B$5:$B$1999));СТРОКА(E1))
но не получается.
Прошу помощи.
Вложения
Тип файла: rar Учет_продаж_2.rar (709.9 Кб, 17 просмотров)
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Лучшие ответы (1)
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
18.09.2017, 00:59
Ответы с готовыми решениями:

Копирование строк на другой лист книги по условию
Доброго дня! По моей теме уже было много вопросов и ответов, но я, очевидно, совсем тормоз, не могу...

Копирование строк на другой лист книги по условию
Доброго дня! По моей теме уже было много вопросов и ответов, но я, очевидно, совсем тормоз, не могу...

Как вытащить строки из таблицы на другой лист по условию с заданым распределением, с возможностью добавления или удаления строк в исходнике?
Добрый день! Подскажите кто-нибудь как вытащить строки с таблицы на другой лист с сортировкой по...

Копирование данных на другой лист по условию
Добрый день, уважаемые форумчане. Прошу помощи в решении следующего вопроса: Есть файл (во...

4
771 / 614 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
18.09.2017, 05:21 2
Вариант, формула массива.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Движение_Товара!$E$2:$P$7;НАИМЕНЬШИЙ(ЕСЛИ(ЦЕЛОЕ(Движение_Товара!$M$2:$M$7)=$A$1;СТРОКА($A$1:$A$6));СТРОКА(A1));ПОИСКПОЗ(B$2;Движение_Товара!$E$1:$P$1;0));"")
Вложения
Тип файла: rar Учет_продаж_3.rar (165.6 Кб, 33 просмотров)
1
0 / 0 / 0
Регистрация: 16.09.2017
Сообщений: 3
18.09.2017, 08:23  [ТС] 3
Спасибо за оперативность!
А что в этой формуле нужно менять, чтобы подогнать под каждый лист в соответствии с датой?
0
771 / 614 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
18.09.2017, 09:04 4
Лучший ответ Сообщение было отмечено LexValievich как решение

Решение

Цитата Сообщение от LexValievich Посмотреть сообщение
А что в этой формуле нужно менять, чтобы подогнать под каждый лист в соответствии с датой?
На каждом листе в ячейку A1 ставите дату соответствующую дате листе, через Ctrl+C, копируете формулу в <буфер обмена>, через Ctrl+V, вставляете формулу в ячейку листа. Можно дату прописать в формуле, но тогда надо будет для каждого листа формулу корректировать по дате.
1
0 / 0 / 0
Регистрация: 16.09.2017
Сообщений: 3
18.09.2017, 21:29  [ТС] 5
Цитата Сообщение от AleksSid Посмотреть сообщение
На каждом листе в ячейку A1 ставите дату соответствующую дате листе
Благодарю Вас! Всё отлично работает!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
18.09.2017, 21:29

Копирование содержимого ячейки на другой лист по условию
Привет великим гуру владеющим в совершенстве Excel. В программе не силен, поэтому вопрос глупый:...

Копирование содержимого ячейки из списка на другой лист по условию
Добрый день! Прошу помощи в решении следующего вопроса: Есть список операций , нужно из него...

Копирование строк из нескольких Листов по условию на Лист этой же Книги
Добрый день, Нужна ваша помощь для реализации, думаю не сложной, задачи. Стандартными средствами...

Как вытащить строки из таблицы на другой лист по условию?
Доброго времени суток! Имеется таблица где в строках содержится информация о жителях ( ФИО, адрес и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru