0 / 0 / 0
Регистрация: 05.04.2018
Сообщений: 1
1

Сравнение двух столбцов Excel и вывод на другой лист общих значений

05.04.2018, 17:22. Показов 1707. Ответов 1
Метки нет (Все метки)

Доброго времени суток.
Встала острая необходимость в следующем:

на листе "Замечания" есть таблица с данными осмотра автомобилей. Мне необходимо сравнить два столбца, которые находятся рядом на наличие одинаковых дефектов, если есть таковые, их необходимо внести в таблицу на листе "Отчет" в нужную ячейку.

То есть, к примеру при сравнении замечаний по 1 и 2 машине, у них есть общий недочет по "КПП", следовательно в таблицу на закладке "Отчет" в столбец "Общие замечания м-у 1 и 2-й машинами" вносится "КПП".

Сверяем только ближайшие две машины, кол-во общих замечаний не ограничено.

При внесении изменений, данные должны обновляться.

Буду очень признателен в помощи, сам не знаю как осужествить идею в жизнь.
Вложения
Тип файла: xlsx Сравнение.xlsx (11.0 Кб, 24 просмотров)
__________________
Помощь в написании контрольных, курсовых и дипломных работ, диссертаций здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
05.04.2018, 17:22
Ответы с готовыми решениями:

Сравнение числовых значений двух столбцов по строкам с третьим столбцом нормативных
Здравствуйте, как же сообразить это. Пробовал Условным форматированием, но это тогда для каждой...

Сравнение двух диапазонов и вывод различий на другой лист
Добрый день уважаемые форумчане! Нашёл в инете такой вот код: Option Explicit Sub...

Сравнение двух столбцов в Excel и вывод несовпавших данных
Добрый день, Помогите, пожалуйста, составить макрос: имеется лист со столбцами A и B. В...

Сравнение двух строк и вывод общих символов
#include <iostream> using namespace std; void main() { char str; char strl;

1
65 / 22 / 7
Регистрация: 28.02.2018
Сообщений: 211
06.04.2018, 08:17 2
MupoH4uk1989,
Код
Отчет!A2:=ЕСЛИ(СЧЁТЕСЛИ(Замечания!B$2:C$11;Замечания!B2)>1;Замечания!B2;"")
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
06.04.2018, 08:17
Помогаю со студенческими работами здесь

Сравнение двух таблиц(столбцов) и замена значений
Подскажите.... Есть две таблицы, нужно сравнить одну таблицу с другой таким образом: Запрос на...

Поиск схожих значений в двух столбцах и перенос из первого на другой лист
Добрый вечер! Идея такая! Есть Два столбца, Один большой, второй меньше, нужно найти значения из...

Поиск по значению и вывод строк из таблицы на другой лист Excel
Люди, хелп!!! Срочно! Нужно в Excel или дописать модуль или что-то с формулами нахимичить. Есть...

Сравнение значений 2х столбцов, вывод данных из 3его
Всем здравствуйте! Помогите пожалуйста, с наскока сам разобраться не могу. 1) Есть значения в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin
Copyright ©2000 - 2022, CyberForum.ru