0 / 0 / 0
Регистрация: 13.07.2018
Сообщений: 4
1

Как убрать пустые ячейки при переносе?

14.07.2018, 00:06. Показов 972. Ответов 6
Метки нет (Все метки)

Добрый день.
Такая проблема: есть таблица на Листе1 и таблица на Листе2. на листе 1 объединенные ячейки нужно сложить и перенести в таблицу 2, и это не сложно, но там и там длинный список с одинаковым количество ячеек и когда в таблице 2 начинаешь растягивать формулу, она сбивается. Шаг получается 5 строк, если это важно... Надеюсь, что кто-то хоть что-то понял... Я дилетант и только осваиваю excel.
__________________
Помощь в написании контрольных, курсовых и дипломных работ здесь
0
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
14.07.2018, 00:06
Ответы с готовыми решениями:

Убрать пустые ячейки в dataGridView
У меня есть вот такая матрица в dataGridView Где " - пустая ячейка Нужно сместить все числа...

Необходимо убрать из сцепки пустые ячейки
Добрый день. Столкнулся с проблемой. Делаю сцепку текста из ячеек (А1:А15). Данные в ячейках...

Как заставить Excel при переносе слов в ячейке увеличивать высоту ячейки?
Как заставить Excel при переносе слов в ячейке увеличивать высоту ячейки?

При переносе данных из datagridview в Excel, ячейки, в которые не влезают данные, заполняются решетками. Как исправить?
Всем добрый день. Из заголовка, мне кажется, всё и так понятно. Как можно это по-другому оформить? ...

6
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
14.07.2018, 08:13 2
Для понимания нужен файл пример
0
0 / 0 / 0
Регистрация: 13.07.2018
Сообщений: 4
14.07.2018, 13:19  [ТС] 3
Пример.
Вложения
Тип файла: xlsx Пример.xlsx (28.6 Кб, 6 просмотров)
0
0 / 0 / 0
Регистрация: 13.07.2018
Сообщений: 4
14.07.2018, 13:23  [ТС] 4
приложил пример
0
771 / 614 / 294
Регистрация: 05.01.2014
Сообщений: 1,338
14.07.2018, 16:56 5
Как вариант. Для столбца с датой.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$1:$A$24;1+6*(СТРОКА(A1)-1));"")
Для суммирования по столбцу Н без привязки к дате.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$H$1:$H$24;1+6*(СТРОКА(A1)-1))+ИНДЕКС(Лист1!$H$1:$H$24;4+6*(СТРОКА(A1)-1));"")
С привязкой к дате.
Код
=СУММЕСЛИ(Лист1!$A$1:$A$24;A2;Лист1!$H$1:$H$24)+СУММЕСЛИ(Лист1!$A$1:$A$21;A2;Лист1!$H$4:$H$24)
Вложения
Тип файла: xlsx Пример (1).xlsx (16.2 Кб, 9 просмотров)
1
2634 / 1691 / 694
Регистрация: 04.09.2015
Сообщений: 3,367
15.07.2018, 09:04 6
для даты и суммы
Код
=ТЕКСТ(ИНДЕКС(Лист1!A:A;6*СТРОКА(A1)-5);"ДД.ММ.ГГГ;;")
=ЕСЛИ(A2>"";СУММ(Лист1!H$1:ИНДЕКС(Лист1!H:H;ПОИСКПОЗ(--A2;Лист1!A:A)+3))-СУММ(B$1:B1);"")
Вложения
Тип файла: xlsx Пример_01.xlsx (11.8 Кб, 6 просмотров)
1
0 / 0 / 0
Регистрация: 13.07.2018
Сообщений: 4
15.07.2018, 21:06  [ТС] 7
большое спасибо, разобрался!
0
IT_Exp
Эксперт
87844 / 49110 / 22898
Регистрация: 17.06.2006
Сообщений: 92,604
15.07.2018, 21:06

Как сделать так, что бы размер ячейки при переносе раздвигался в зависимости от обьема текста в ней?
Формирую из одной книги другую. Необходимо перенести в ячейки текст разной длины. Ориентироваться...

Как заполнить пустые ячейки нужной колонки при нажатии на чекбокс?
Как заполнит пустые ячейки нужного поля нажимая на чекбокс, например: "IDX" " ...

Как убрать пустые места при изменении разметки в коде?
Делать изменение размера формы в зависимости от того сколько строчек (Textbox) в Leistung и...

Класс перехватчик, заполнить пустые ячейки грида строкой (при повторном нажатии - очистить как было)
Задание: при нажатии клавиши F11 все пустые ячейки Cells заполняются строкой из трех символов ###,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.